<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Steam Audio 2.0 Adds AMD TrueAudio Next Support - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2016">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<script type="text/javascript">

		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-1978569-1']);
		  _gaq.push(['_trackPageview']);

		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();


		    Shadowbox.init({
		       skipSetup: true
		   });
		</script>
			</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
						<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("3dc78b").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="3dc78b" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 14 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>Steam Audio 2.0 Adds AMD TrueAudio Next Support</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=Valve">Valve</a> on 9 February 2018 at 11:29 AM EST. <a href="/forums/node/1006700">8 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="VALVE -- " src="assets/categories/valve.jpg" width="100" height="100" /></div>
Valve has added support for the AMD/GPUOpen TrueAudio Next within the latest beta of SteamAudio 2.0.<br /><br />Steam Audio as a refresher is Valve's full-featured spatial audio solution designed for VR and gaming audio in general. Steam Audio can be enabled into Unreal Engine 4, Unity, and other game engines with also having a C API. SteamAudio does support Linux.<br /><br />TrueAudio Next meanwhile is AMD's current generation solution for dealing with advanced audio capabilities while using the GPU driven via OpenCL. Unlike TrueAudio with the dedicated DSP, TrueAudio Next delivers advanced audio effects using OpenCL kernels. The TrueAudio Next SDK has been open-source since 2016 even though AMD doesn't officially support it on Linux at the moment.<br /><br />This news is still important though for Linux gamers as hopefully this year we will see official TrueAudio Next support on Linux, since after all it's implemented in OpenCL. Additionally, with the Linux 4.17 kernel is when we are seeing ROCm/OpenCL beginning to work on the mainline Linux kernel for select GPUs, making it much easier for Linux gamers to deploy AMD's official OpenCL compute stack. When this barrier to entry for ROCm/OpenCL is lowered and running on the mainline kernel, it's very reasonable to imagine AMD offering TrueAudio Next officially on Linux and other GPGPU expansions.<br /><br />Those wishing to learn more about TrueAudio Next integration into Steam Audio 2.0 Beta can find the details via <a href="http://steamcommunity.com/app/596420/allnews/#scrollTop=0">SteamCommunity.com</a>.<br /><br />The AMD folks have also published their own information at <a href="https://gpuopen.com/trueaudio-next-now-integrated-steam-audio/">GPUOpen.com</a>, "<em>The TAN version used in Steam Audio has our latest OpenCL multi-core optimizations for better convolution performance with the lowest possible latency impact to the main audio rendering loop (using just 4 compute units, up to 7x lower than CPU). Steam Audio is able to leverage the TAN library’s batch convolution method to maximize GPU utilization. The optimizations used in this TAN version will be posted in an upcoming TAN update on GPUOpen.</em>"</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1006700">8 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=news_item&amp;px=Steam-Audio-TrueAudio-Next"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Steam Audio 2.0 Adds AMD TrueAudio Next Support" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=Steam-Audio-TrueAudio-Next" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DSteam-Audio-TrueAudio-Next&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<p align="center"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "728x90";
//--></script>
<script type="text/javascript" src="//tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script></p>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="http://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related Valve News</header>
								<div class="node"><a href="?page=news_item&amp;px=Daniel-Joins-Valve-Driver">Valve Has Hired Another Open-Source Linux GPU Driver Developer</a></div><div class="node"><a href="?page=news_item&amp;px=Steam-Stats-January-2018">Steam On Linux Starts 2018 With A Slight Increase In Gamers</a></div><div class="node"><a href="?page=news_item&amp;px=RadeonSI-Semaphores-Git-Start">RadeonSI Semaphore Begins Hitting Mesa Git, Needed By SteamVR On Linux</a></div><div class="node"><a href="?page=news_item&amp;px=Steam-2X-UI-Mode">Steam UI Finally Has A Scaling Mode For HiDPI Monitors</a></div><div class="node"><a href="?page=news_item&amp;px=SteamOS-2.145-Beta">SteamOS Beta Switches To Linux 4.14.13 For KPTI To Mitigate Meltdown</a></div><div class="node"><a href="?page=news_item&amp;px=StreamOS-Brewmaster-2.141">Valve Ships Its First SteamOS Brewmaster Beta Of 2018</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News</header>
								<div class="node"><a href="?page=news_item&amp;px=Linux-Now-Needs-Flex-Bison">Flex &amp; Bison Are Now Needed To Build The Linux Kernel; Linux 4.16 Can Also Be Snap'ed</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-4.16-Feature-Start">Linux 4.16 Is Off To A Busy Start With Big New Features</a></div><div class="node"><a href="?page=news_item&amp;px=Ubuntu-18.04-Minimal-Is-Smaller">Ubuntu 18.04 Minimal Spin Down To ~30MB Compressed / ~81MB On Disk</a></div><div class="node"><a href="?page=news_item&amp;px=Wine-3.1-Released">Wine 3.1 Released As The First Step Towards Wine 4.0</a></div><div class="node"><a href="?page=news_item&amp;px=Fedora-Battery-Numbers-2018">Fedora's Power Tweaks Dropped The Power Use On A ThinkPad By ~30%</a></div><div class="node"><a href="?page=news_item&amp;px=Daniel-Joins-Valve-Driver">Valve Has Hired Another Open-Source Linux GPU Driver Developer</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Steam-Audio-TrueAudio-Next">Steam Audio 2.0 Adds AMD TrueAudio Next Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GNOME-Alt-Tab-Quit">GNOME Shell Gets macOS-Like Ability To Close Apps From The Alt-Tab Switcher</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=S390-Expoline-Linux-4.16">S390 Architecture Gets Spectre Mitigation With &quot;Expoline&quot; &amp; Other Patches</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=VLC-3.0-Released">VLC 3.0 Released</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Clasen-Fedora-Atomic-Trial">Experimenting With Fedora Atomic Workstation, But Still Rough Around The Edges</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Nouveau-DRM-Linux-4.16-Round-2">Nouveau Updates Submitted For Linux 4.16, Bringing GP108 &amp; Kepler Clock Gating</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Mesa-18.0-RC4-Released">Mesa 18.0-RC4 Released With More Fixes</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=KDE-Flash-Drive-Security-Bug">KDE Plasma Had A Silly But Serious Security Bug</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Ubuntu-18.04-Snap-Policy">Ubuntu 18.04 LTS Policy Forming For Allowing Snaps By Default</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Chrome-65-Beta">Chrome 65 Now In Beta With The CSS Paint API</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250,160x600,300x600";
//--></script>
<script type="text/javascript" src="https://tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=25988">The Cost Of Home Directory Encryption &amp; LUKS Full Disk Encryption On Ubuntu 18.04</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25982">Mesa 12.0 To Mesa 18.0 Benchmarks Show The OpenGL/Vulkan Radeon Evolution</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25981">Intel Atom C3950 + Tyan Tempest S3227</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25977">Trying Out openSUSE Leap 15.0 Beta, Comparison Linux Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25973">Intel OpenGL/Vulkan Performance Edging Slightly Higher With Mesa 18.0</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-2'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6875.7_phoronix.com_tier1', [300, 600], 'div-pg-ad-1506416552-2'); });
  </script>
</div>

                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="http://www.phoronix-media.com/?k=legal">Legal Disclaimer</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a> | <a href="?page=cookies">Cookie Policy</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2018 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
