<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Updated Vega 20 Open-Source Driver Patches Posted, Including PSP &amp; PowerPlay Support - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2018">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<!-- AA -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		     (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-0253814508491313",
			  enable_page_level_ads: true
		     });
		</script>
		<!-- AA -->
			</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("d0f3e3").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="d0f3e3" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  Did you know that the hundreds of articles written on Phoronix each month are mostly authored by one individual working insane hours? Phoronix.com doesn't have a whole news room with unlimited resources and relies upon people reading our content without blocking ads and alternatively by people <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">subscribing to Phoronix Premium</a> for our ad-free service with other extra features. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
<header>Updated Vega 20 Open-Source Driver Patches Posted, Including PSP &amp; PowerPlay Support</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=Radeon">Radeon</a> on 14 August 2018 at 08:13 PM EDT. <a href="/forums/node/1040967">Add A Comment</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="RADEON -- " src="assets/categories/radeon.jpg" width="100" height="100" /></div>
Back in May <a href="https://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-Vega-20-Patches">AMD posted initial open-source "Vega 20" patches</a> and support for that yet-to-launch graphics processor was subsequently merged for the Linux 4.18 kernel. More of the Vega 20 AMDGPU kernel driver enablement has now been posted.<br /><br />This latest 69,910 lines of code -- before fretting, most of that is auto-generated header files for the GPU -- notably adds PSP (Platform Security Processor) and SMU (System Management Unit) for <a href="https://www.phoronix.com/scan.php?page=search&q=Vega+20">Vega 20</a>. With the SMU enablement code, it's also now wired in to enable Vega 20 PowerPlay support as well as related power/clocking-functionality like OverDrive overclocking is also available.<br /><br />Following these PSP/SMU/PowerPlay patches, the AMDGPU kernel driver goes ahead and drops the experimental flag for the Vega 20 graphics processor.<br /><br />The golden register settings for Vega 20 were also updated. In my cursory digging through these patches, no major secrets were revealed for this GPU we've been awaiting to launch. Vega 20 is widely expected to be a 7nm Vega graphics card with upwards of 20 TFLOPS of compute power, feature deep learning instructions, and be some sort of exciting HPC/workstation GPU coming out before the end of 2018.<br /><br />Based upon these 38 patches coming out today and being too late for the Linux 4.19 kernel merge window via DRM-Next, this code is most likely waiting until the Linux 5.0 (nee Linux 4.20) cycle unless it happens to get added as a late item considering it's for new hardware support and shouldn't regress existing users. But we'll see... If AMD tries to squeeze it in Linux 4.19 it could mean the launch is closer than we think.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1040967">Add A Comment</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=news_item&amp;px=Vega-20-More-Driver-Code"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Updated Vega 20 Open-Source Driver Patches Posted, Including PSP &amp; PowerPlay Support" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=Vega-20-More-Driver-Code" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DVega-20-More-Driver-Code&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<p align="center"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "728x90";
//--></script>
<script type="text/javascript" src="//tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script></p>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="http://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related Radeon News</header>
								<div class="node"><a href="?page=news_item&amp;px=RADV-On-Demand-Built-In-Shaders">RADV Now Supports On-Demand Compilation Of Built-In Shaders</a></div><div class="node"><a href="?page=news_item&amp;px=Radeon-Pro-WX-8200">Radeon Pro WX 8200 Launches As &quot;Best Workstation Graphics Performance Under $1,000&quot;</a></div><div class="node"><a href="?page=news_item&amp;px=RadeonSI-More-Extensions">More OpenGL Extensions For RadeonSI Are The Latest In A Flurry Of Interesting Activity</a></div><div class="node"><a href="?page=news_item&amp;px=Radeon-Pro-18.Q3-Linux-Driver">AMD Radeon Pro 18.Q3 Linux Driver Released</a></div><div class="node"><a href="?page=news_item&amp;px=AMDGPU-LRU-Bulk-Move">AMDGPU LRU Bulk Move Patches Yielding OpenCL &amp; Vulkan Performance Boosts</a></div><div class="node"><a href="?page=news_item&amp;px=AMDVLK-Starts-August-2018">AMDVLK Radeon Vulkan Driver Updated With 8-Bit Storage Support</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Linux-4.18-Feature-Reminder">The Best Features Of The Linux 4.18 Kernel</a></div><div class="node"><a href="?page=news_item&amp;px=More-Linux-4.19-Activity">Linux 4.19 Certainly Is Going To Be A Big Kernel</a></div><div class="node"><a href="?page=news_item&amp;px=Steam-64-bit-Client-Maybe-Soon">It Looks Like A Steam 64-Bit Client Could Finally Be Near</a></div><div class="node"><a href="?page=news_item&amp;px=Threadripper-2-Kernel-Bulletin">Linux Kernel Expectations For AMD Threadripper 2</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-4.18-Released">Linux 4.18 Kernel Officially Released</a></div><div class="node"><a href="?page=news_item&amp;px=Julia-1.0-Released">Julia 1.0 Programming Language Released</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Vega-20-More-Driver-Code">Updated Vega 20 Open-Source Driver Patches Posted, Including PSP &amp; PowerPlay Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-4.19-Power-Management">Power Management Updates Land In The Linux 4.19 Kernel</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=xf86-video-v4l-0.3.0-Released">xf86-video-v4l X.Org Driver Sees First New Release In A Decade</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Libinput-1.12-RC2-Released">Libinput 1.12 RC2 Continues Working On Improving Linux Touchpad Behavior</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=L1-Terminal-Fault">L1 Terminal Fault - The Latest Speculative Execution Side Channel Attack</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-4.19-x86-PTI-Spectre">A Lot Of Spectre Changes Land In The Linux 4.19 Git Tree, Possible Performance Impact</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-4.19-Sound-Drivers">New Sound Hardware Support &amp; Other Improvements Playing In Linux 4.19</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=RADV-On-Demand-Built-In-Shaders">RADV Now Supports On-Demand Compilation Of Built-In Shaders</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=EXT4-XFS-Linux-4.19">EXT4 &amp; XFS File-System Updates Submitted For Linux 4.19</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=NVIDIA-CUDA-10-Toolkit">NVIDIA CUDA 10 Adding nvJPEG, Turing Support</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-1'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6874.4_phoronix.com_tier1', [300, 250], 'div-pg-ad-1506416552-1'); });
  </script>
</div>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=26705">A Look At The Windows 10 vs. Linux Performance On AMD Threadripper 2990WX</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26700">AMD Threadripper 2990WX Linux Benchmarks: The 32-Core / 64-Thread Beast</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26693">AMD Threadripper 2990WX Cooling Performance - Testing Five Heatsinks &amp; Two Water Coolers</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26687">AMD Threadripper 2950X Offers Great Linux Performance At $900 USD</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26679">SIGGRAPH 2018: OpenCL-Next Taking Shape, Vulkan Continues Evolving</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[160,600]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2018 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
