<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>RISC-V Software Support Adds More Features With Linux 5.9 - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2019">
				<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag -->
<script type="text/javascript" async=true>
    var elem = document.createElement('script');
    elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    (function() {
    var gdprAppliesGlobally = false;
    function addFrame() {
        if (!window.frames['__cmpLocator']) {
        if (document.body) {
            var body = document.body,
                iframe = document.createElement('iframe');
            iframe.style = 'display:none';
            iframe.name = '__cmpLocator';
            body.appendChild(iframe);
        } else {
            // In the case where this stub is located in the head,
            // this allows us to inject the iframe more quickly than
            // relying on DOMContentLoaded or other events.
            setTimeout(addFrame, 5);
        }
        }
    }
    addFrame();
    function cmpMsgHandler(event) {
        var msgIsString = typeof event.data === "string";
        var json;
        if(msgIsString) {
        json = event.data.indexOf("__cmpCall") != -1 ? JSON.parse(event.data) : {};
        } else {
        json = event.data;
        }
        if (json.__cmpCall) {
        var i = json.__cmpCall;
        window.__cmp(i.command, i.parameter, function(retValue, success) {
            var returnMsg = {"__cmpReturn": {
            "returnValue": retValue,
            "success": success,
            "callId": i.callId
            }};
            event.source.postMessage(msgIsString ?
            JSON.stringify(returnMsg) : returnMsg, '*');
        });
        }
    }
    window.__cmp = function (c) {
        var b = arguments;
        if (!b.length) {
        return __cmp.a;
        }
        else if (b[0] === 'ping') {
        b[2]({"gdprAppliesGlobally": gdprAppliesGlobally,
            "cmpLoaded": false}, true);
        } else if (c == '__cmp')
        return false;
        else {
        if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
        }
        __cmp.a.push([].slice.apply(b));
        }
    }
    window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
    window.__cmp.msgHandler = cmpMsgHandler;
    if (window.addEventListener) {
        window.addEventListener('message', cmpMsgHandler, false);
    }
    else {
        window.attachEvent('onmessage', cmpMsgHandler);
    }
    })();
    window.__cmp('init', {
    		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Phoronix Media',
		'Publisher Logo': 'https://www.phoronix.com/phxcms7-css/phoronix.png',
		'Min Days Between UI Displays': 60,
		'Consent Scope': 'service',
		'UI Layout': 'banner',
		'No Option': false,
    });
</script>
<!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
        .qc-cmp-button {
          background-color: #fff !important;
          border-color: #fff !important;
        }
        .qc-cmp-button:hover {
          background-color: transparent !important;
          border-color: #fff !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
          color: #fff !important;
        }
        .qc-cmp-button {
          color: #222 !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button {
          color: #222 !important;
        }
        .qc-cmp-button.qc-cmp-button.qc-cmp-secondary-button:hover {
          color:#ffffff !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button {
          border-color: #ccc !important;
          background-color: transparent !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button:hover {
          background-color: #ccc !important;
        }
        .qc-cmp-ui,
        .qc-cmp-ui .qc-cmp-main-messaging,
        .qc-cmp-ui .qc-cmp-messaging,
        .qc-cmp-ui .qc-cmp-beta-messaging,
        .qc-cmp-ui .qc-cmp-title,
        .qc-cmp-ui .qc-cmp-sub-title,
        .qc-cmp-ui .qc-cmp-purpose-info,
        .qc-cmp-ui .qc-cmp-table,
        .qc-cmp-ui .qc-cmp-table-header,
        .qc-cmp-ui .qc-cmp-vendor-list,
        .qc-cmp-ui .qc-cmp-vendor-list-title {
            color: #121212 !important;
        }
        .qc-cmp-ui a,
        .qc-cmp-ui .qc-cmp-alt-action {
          color: #444 !important;
        }
        .qc-cmp-ui {
            background-color: #348755 !important;
        }
        .qc-cmp-publisher-purposes-table .qc-cmp-table-header {
          background-color: #fafafa !important;
        }
        .qc-cmp-publisher-purposes-table .qc-cmp-table-row {
          background-color: #ffffff !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #666 !important;
            border-color: #666 !important;
        }
    </style>
		<!-- AA -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		     (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-0253814508491313",
			  enable_page_level_ads: true
		     });
		</script>
		<!-- AA -->
		
	</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- responsive, lead of site for mobile -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="8685179274"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>RISC-V Software Support Adds More Features With Linux 5.9</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=RISC-V">RISC-V</a> on 7 August 2020 at 07:15 AM EDT. <a href="/forums/node/1199245">Add A Comment</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="RISC-V -- " src="assets/categories/risc-v.jpg" width="100" height="100" /></div>
More kernel architecture features continue to be supported by the RISC-V code with <a href="https://www.phoronix.com/scan.php?page=search&q=Linux+5.9">Linux 5.9</a>.<br /><br />Each kernel cycle we have been seeing more RISC-V code get squared away and over the past year has begun running nicely on the likes of <a href="https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.1-RISC-V-Maturing">SiFive's HiFive Unleashed</a>. With the Linux 5.9 merge window on the RISC-V side there are a number of new features now supported:<br /><br />- Atomic read modify write is advertised for allowing OSQ locks to be enabled.<br /><br />- Support for NO_HZ_FULL builds on RISC-V, which allows scheduling clock ticks to be avoided on CPUs that are idle or have only one runnable task. This can be important for HPC and real-time workloads.<br /><br />- KCOV support for this code coverage tool.<br /><br />- KMemleak support for detecting kernel memory leaks.<br /><br />- Stack protector but buffer overflow protection.<br /><br />- VM debugging for virtual memory.<br /><br />- JUMP_LABEL support.<br /><br />These changes plus other code improvements make for a nice RISC-V <a href="https://lkml.org/lkml/2020/8/6/948">pull request</a> for Linux 5.9.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="2682229815"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1199245">Add A Comment</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="RISC-V Software Support Adds More Features With Linux 5.9" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=RISC-V-For-Linux-5.9" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DRISC-V-For-Linux-5.9&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="7279734770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div class="article-box">
								<header>Related News</header>
								<div class="node"><a href="?page=news_item&amp;px=RISC-V-UEFI-Linux-Review">RISC-V UEFI Linux Support Under Review</a></div><div class="node"><a href="?page=news_item&amp;px=RISC-V-Changes-Linux-5.8">RISC-V For Linux 5.8 Finishes Bringing Up The Kendryte K210, Adds KGDB Support</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-5.7-RISC-V">Linux 5.7 Begins Landing Support For The Kendryte K210 Dual-Core RISC-V SoC</a></div><div class="node"><a href="?page=news_item&amp;px=UEFI-RISC-V-Linux-Patches">UEFI Boot Support Published For RISC-V On Linux</a></div><div class="node"><a href="?page=news_item&amp;px=RISC-V-Linux-SBI-v0.2-Continues">Linux Kernel Continues Prepping For RISC-V's Updated Supervisor Binary Interface</a></div><div class="node"><a href="?page=news_item&amp;px=RISC-V-Vector-Linux-Prep">Linux Kernel Preparations For RISC-V Vector ISA Support</a></div>
	                             
							</div>						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Phoronix Homepage -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="2439829920"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Linux-Kernel-Blocking-NV-NetGPU">Kernel Developers Work To Block NVIDIA &quot;GPL Condom&quot; Effort Around New NetGPU Code</a></div><div class="node"><a href="?page=news_item&amp;px=Eight-Linux-5.8-Features">Eight Great Features Of Linux 5.8</a></div><div class="node"><a href="?page=news_item&amp;px=Nano-5.0-Released">Nano 5.0 Released As A Big Feature Update To This Easy-To-Use Terminal Text Editor</a></div><div class="node"><a href="?page=news_item&amp;px=BootHole-GRUB2-Secure-Boot">BootHole Blows Hole In GRUB2 Bootloader Security, Including UEFI SecureBoot</a></div><div class="node"><a href="?page=news_item&amp;px=System76-Keyboard-Hype">System76 Talks Up Their Forthcoming Linux Keyboard</a></div><div class="node"><a href="?page=news_item&amp;px=systemd-246-Released">Systemd 246 Released With Many Changes</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-5.8-Released">Linux 5.8 Released With AMD Energy Driver, F2FS LZO-RLE, IBM POWER10 Booting</a></div><div class="node"><a href="?page=news_item&amp;px=Unigine-Engine-2.12-Released">The Beautiful + Linux-Friendly Unigine 2.12 Engine Released</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Right Hand Leader -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="2946148183"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=RISC-V-For-Linux-5.9">RISC-V Software Support Adds More Features With Linux 5.9</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMDVLK-2020.Q3.3">AMDVLK 2020.Q3.3 Driver Enables Its Pipeline Cache</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Reviving-Foreshadow-Bad">Researchers Make More Discoveries Around L1TF/Foreshadow - It's Not Good</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=USB-Thunderbolt-Linux-5.9">USB Cleans Up Its Terminology, Continued USB4 Work For Linux 5.9</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=NVIDIA-HPC-SDK-Released">NVIDIA Releases Their Previously Announced HPC SDK</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Mesa-20.2-RC1-Features-Released">Mesa 20.2 Development Ends After Many New Features Land</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.9-Graphics-Drivers">Open-Source GPU Driver Updates Sent In For Linux 5.9 From Sienna Cichlid To Rocket Lake</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Ubuntu-20.04.1-LTS-Released">Ubuntu 20.04.1 LTS Released With The Latest Fixes</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Fedora-IoT-Official-Proposal">Fedora IoT Looks For Promotion To Becoming Official Spin</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Glibc-2.32-Released">GNU C Library 2.32 Released</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=PHP-8.0-Beta-Released">PHP 8.0 Beta Released, Now Under Feature Freeze</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.9-Multi-Color-LEDs">Linux 5.9 Introducing A Multi-Color LED Framework</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-1'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6874.4_phoronix.com_tier1', [300, 250], 'div-pg-ad-1506416552-1'); });
  </script>
</div>
                        </div>
                        </aside>
			                        <aside class="widget">
                       <header>Show Your Support, Go Premium</header>
                       <p><a href="https://www.phoronix.com/scan.php?page=phoronix_premium">Phoronix Premium</a> allows ad-free access to the site, multi-page articles on a single page, and other features while supporting this site's continued operations.</p>
                        </aside>
			                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=29434">Intel's Clear Linux Still Outperforming Other Distributions For Mid-2020</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=29427">Intel Celeron G5900 + Pentium Gold G6400 Benchmarks - Low-Price Comet Lake CPUs</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=29418">Samsung 870 QVO SSD Performance On Ubuntu Linux</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=29417">GCC Benchmarks At Varying Optimization Levels With Core i9 10900K Show An Unexpected Surprise</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=29411">Intel Core i5 10600K Comet Lake vs. Core i5 Skylake / Haswell / Sandy Bridge</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="https://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="https://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2020 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
		<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
	</body>
</html>
