<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Motorola m68k Support Improved Upon In GCC - Saved From Being Removed In GCC 11 - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2019">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag -->
<script type="text/javascript" async=true>
    var elem = document.createElement('script');
    elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    (function() {
    var gdprAppliesGlobally = false;
    function addFrame() {
        if (!window.frames['__cmpLocator']) {
        if (document.body) {
            var body = document.body,
                iframe = document.createElement('iframe');
            iframe.style = 'display:none';
            iframe.name = '__cmpLocator';
            body.appendChild(iframe);
        } else {
            // In the case where this stub is located in the head,
            // this allows us to inject the iframe more quickly than
            // relying on DOMContentLoaded or other events.
            setTimeout(addFrame, 5);
        }
        }
    }
    addFrame();
    function cmpMsgHandler(event) {
        var msgIsString = typeof event.data === "string";
        var json;
        if(msgIsString) {
        json = event.data.indexOf("__cmpCall") != -1 ? JSON.parse(event.data) : {};
        } else {
        json = event.data;
        }
        if (json.__cmpCall) {
        var i = json.__cmpCall;
        window.__cmp(i.command, i.parameter, function(retValue, success) {
            var returnMsg = {"__cmpReturn": {
            "returnValue": retValue,
            "success": success,
            "callId": i.callId
            }};
            event.source.postMessage(msgIsString ?
            JSON.stringify(returnMsg) : returnMsg, '*');
        });
        }
    }
    window.__cmp = function (c) {
        var b = arguments;
        if (!b.length) {
        return __cmp.a;
        }
        else if (b[0] === 'ping') {
        b[2]({"gdprAppliesGlobally": gdprAppliesGlobally,
            "cmpLoaded": false}, true);
        } else if (c == '__cmp')
        return false;
        else {
        if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
        }
        __cmp.a.push([].slice.apply(b));
        }
    }
    window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
    window.__cmp.msgHandler = cmpMsgHandler;
    if (window.addEventListener) {
        window.addEventListener('message', cmpMsgHandler, false);
    }
    else {
        window.attachEvent('onmessage', cmpMsgHandler);
    }
    })();
    window.__cmp('init', {
    		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Phoronix Media',
		'Publisher Logo': 'https://www.phoronix.com/phxcms7-css/phoronix.png',
		'Min Days Between UI Displays': 60,
		'Consent Scope': 'service',
		'UI Layout': 'banner',
		'No Option': false,
    });
</script>
<!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
        .qc-cmp-button {
          background-color: #fff !important;
          border-color: #fff !important;
        }
        .qc-cmp-button:hover {
          background-color: transparent !important;
          border-color: #fff !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
          color: #fff !important;
        }
        .qc-cmp-button {
          color: #222 !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button {
          color: #222 !important;
        }
        .qc-cmp-button.qc-cmp-button.qc-cmp-secondary-button:hover {
          color:#ffffff !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button {
          border-color: #ccc !important;
          background-color: transparent !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button:hover {
          background-color: #ccc !important;
        }
        .qc-cmp-ui,
        .qc-cmp-ui .qc-cmp-main-messaging,
        .qc-cmp-ui .qc-cmp-messaging,
        .qc-cmp-ui .qc-cmp-beta-messaging,
        .qc-cmp-ui .qc-cmp-title,
        .qc-cmp-ui .qc-cmp-sub-title,
        .qc-cmp-ui .qc-cmp-purpose-info,
        .qc-cmp-ui .qc-cmp-table,
        .qc-cmp-ui .qc-cmp-table-header,
        .qc-cmp-ui .qc-cmp-vendor-list,
        .qc-cmp-ui .qc-cmp-vendor-list-title {
            color: #121212 !important;
        }
        .qc-cmp-ui a,
        .qc-cmp-ui .qc-cmp-alt-action {
          color: #444 !important;
        }
        .qc-cmp-ui {
            background-color: #348755 !important;
        }
        .qc-cmp-publisher-purposes-table .qc-cmp-table-header {
          background-color: #fafafa !important;
        }
        .qc-cmp-publisher-purposes-table .qc-cmp-table-row {
          background-color: #ffffff !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #666 !important;
            border-color: #666 !important;
        }
    </style>
		<!-- AA -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		     (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-0253814508491313",
			  enable_page_level_ads: true
		     });
		</script>
		<!-- AA -->
		
	</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("01c8").style.display = 'block';
}
 }, 2000);  
  };
</script>
<strong id="01c8" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">Happy Holidays -</strong>  This site is primarily supported by advertisements and your support. If you enjoy the daily Linux hardware benchmarking and open-source news coverage provided on Phoronix.com, consider showing your support by <a href="https://www.phoronix.com/scan.php?page=news_item&px=2019-Black-Friday-Week-Sale">participating in our holiday/winter premium special</a> running just this week. Go ad-free and enjoy other benefits while ensuring our Linux benchmarking continues strong into the new year.</strong>
<header>Motorola m68k Support Improved Upon In GCC - Saved From Being Removed In GCC 11</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=GNU">GNU</a> on 26 November 2019 at 05:27 PM EST. <a href="/forums/node/1141715">2 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="GNU -- " src="assets/categories/gnu.jpg" width="100" height="100" /></div>
While the Motorola 68000 32-bit processors are from the 80's and early 90's, there still is a loyal following of hobbyists who managed to save the "m68k" compiler back-end from being removed in GCC 11.<br /><br />The m68k back-end in GCC was at risk of being removed due to <a href="https://www.phoronix.com/scan.php?page=news_item&px=GCC-11-Dropping-CC0">plans for GCC 11 to drop the CC0 representation code</a> and the back-ends still depending upon it. M68k was the most notable user relying upon the deprecated CC0 representation but there are also other back-ends like AVR (AVR micro-controller), CRIS (the Axis Communications' ETRAX CRIS embedded processors), H8300 (the Renesas H8 microcontrollers), VAX (DEC VAX), and CR16 (National Semi CompactRISC). But now at least m68k is safe.<br /><br />This week <a href="https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=b011c4b9e1c7539ea9e727bc1b269abb56502217">code was merged</a> to GCC 10 for converting m68k to not use the deprecated cc0 functionality. That huge back-end rework comes after <a href="https://www.bountysource.com/issues/80706251-m68k-convert-the-backend-to-mode_cc-so-it-can-be-kept-in-future-releases">a BountySource campaign</a> raised thousands of dollars from passionate Motorola 68000 fans. The Motorola 68000 series was used in devices ranging from the Palm Pilot to Sega Genesis to various TI calculators and dated workstations from the likes of SGI and Sun. With the GNU Compiler Collection support sticking around for this target, the compiler can continue to work for building <a href="https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.17-m68k-Powerbook">the still maintaining m68k Linux port</a> and the BSDs for years to come. <br /><br />More details on the CC0 transition to the modern MODE_CC representation needed to save the other older CPU targets is documented via the <a href="https://gcc.gnu.org/wiki/CC0Transition">GCC Wiki</a>.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<div style="width: 50%; text-align: center; float: left;"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250";
//--></script>
<script type="text/javascript" src="//tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script>
</div><div style="width: 50%; text-align: center; float: right;">	<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
</div>							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1141715">2 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Motorola m68k Support Improved Upon In GCC - Saved From Being Removed In GCC 11" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=GCC-11-m68k-Is-Safe" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DGCC-11-m68k-Is-Safe&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="7279734770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div class="article-box">
								<header>Related News</header>
								<div class="node"><a href="?page=news_item&amp;px=GNUstep-Might-Deprecate-GCC">GNUstep Might Deprecate Support For GNU's GCC In Favor Of LLVM Clang</a></div><div class="node"><a href="?page=news_item&amp;px=GCC-10-Enters-Stage-Three">GCC 10 Feature Development Is Over - Now The Focus Turns To Bug Fixing</a></div><div class="node"><a href="?page=news_item&amp;px=GCC-Cpp20-Coroutines-Patches">Initial Patches Wire In C++20 Coroutines For The GCC Compiler</a></div><div class="node"><a href="?page=news_item&amp;px=GCC-Static-Analysis-RH-Patches">GCC Might Finally Have A Static Analysis Framework Thanks To Red Hat</a></div><div class="node"><a href="?page=news_item&amp;px=GCC-10-MP-ACC-Offload-Merged">The GCC 10 Compiler Lands OpenMP / OpenACC Offloading To AMD Radeon GPUs</a></div><div class="node"><a href="?page=news_item&amp;px=GCC-Record-Command-Line-Info">GCC Developers Discuss New Option For Recording Compiler Flags / Details In Binaries</a></div>
	                             
							</div>						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Phoronix Homepage -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="2439829920"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Glimpse-0.1-Released">Glimpse 0.1 Released As The Rebranded Fork Of The GIMP</a></div><div class="node"><a href="?page=news_item&amp;px=Faster-Emulators-Mesa-GL-Thread">Various Game Emulators Are Faster On Mesa Drivers Now Thanks To OpenGL Threading</a></div><div class="node"><a href="?page=news_item&amp;px=Half-Life-Alyx-Released">Half-Life: Alyx Releasing In March 2020 With Linux Support</a></div><div class="node"><a href="?page=news_item&amp;px=Fedora-Workstation-Vi-To-Nano">Fedora Developers Looking To Change The Default Text Editor From Vi To Nano</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-5.4-Released">Linux 5.4 Kernel Released With exFAT Support, Faster Radeon Graphics, New Hardware</a></div><div class="node"><a href="?page=news_item&amp;px=Debian-GR-New-Systemd-Option">Debian Adds Another Option For Its Init System Diversity General Resolution</a></div><div class="node"><a href="?page=news_item&amp;px=Intel-Data-Streaming-Accel">Intel Details New Data Streaming Accelerator For Future CPUs - Linux Support Started</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-5.5-Expected-Features">Linux 5.5 Cycle Kicks Off Next Week With Exciting Changes On Tap</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.2-Go-Register-Corrupt">Linux 5.2+ Hit By AVX Register Corruption Bug - Affecting At Least Golang Programs</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GCC-11-m68k-Is-Safe">Motorola m68k Support Improved Upon In GCC - Saved From Being Removed In GCC 11</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.5-Wake-On-Voice">Linux 5.5 Adding Wake-On-Voice Support - Capable On Some Chromebook Hardware</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.5-5-Level-Paging">Linux 5.5 To Enable Intel's 5-Level Paging Support By Default</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Fedora-32-Empty-Passwords">Fedora 32 Might Disallow Empty Passwords For Local Users By Default</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMD-TEE-Linux-Driver-Secure">AMD's TEE Driver For Loading &quot;Trusted Applications&quot; On Their Secure Processor Under Linux</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.5-Scheduler">Linux 5.5's Scheduler Sees A Load Balancing Rework For Better Perf But Risks Regressions</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Mesa-20.0-ACO-Load-Store-Vec">Mesa 20.0 Lands A Load/Store Vectorizer As Latest &quot;ACO&quot; Backend Improvement</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Intel-SVT-AV1-0.7.5-Released">Intel's SVT-AV1 0.7.5 Released With AVX2 + AVX-512 Optimizations</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=2019-Black-Friday-Week-Sale"><span style="font-weight: 600;">It's That Time Of The Year For The Annual Phoronix Premium Sale To Show Your Support</span></a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GNOME-Software-Promotes-Blobs">Some Fedora Users Concerned GNOME Software Promotes Proprietary Software With Flathub</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.5-RdRand-Sanity-Check">Linux 5.5 Begins Sanity Checking RdRand Output Due To Buggy Processor Behavior</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-1'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6874.4_phoronix.com_tier1', [300, 250], 'div-pg-ad-1506416552-1'); });
  </script>
</div>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=28559">Blender 2.81 Benchmarks On 19 NVIDIA Graphics Cards - RTX OptiX Rendering Performance Is Incredible</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28555">AMD Ryzen Threadripper 3970X / 3960X Linux Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28546">Intel Core i9 10980XE Linux Performance Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28537">The Combined Impact Of Mitigations On Cascade Lake Following Recent JCC Erratum + TAA</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28528">Rosewill RSV-4310 - Useful Revision To One Of The Best Value 4U Server Cases</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-2'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6875.7_phoronix.com_tier1', [300, 600], 'div-pg-ad-1506416552-2'); });
  </script>
</div>

                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="https://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="https://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2019 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
