<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1978569-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1978569-1');
</script>

<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  freestar.config.enabled_slots = [];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/phoronix-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>

<script>
freestar.config.disabledProducts = {
    googleInterstitial: true
};
</script>
		<title>Linux 6.2 Adds AMD Zen 4 Pipeline Utilization Data To Help Find Performance Bottlenecks - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="/phxcms-css/phoronix-10.css?2027">
				<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux server benchmarks, Linux benchmarking, Desktop Linux, Linux performance, Open Source graphics, Linux How To, Ubuntu benchmarks, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Ahead of the Linux 6.2 merge window ending this weekend, a second batch of the perf subsystem changes have been submitted for this next Linux kernel version" />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
		<meta name="twitter:card" content="summary_large_image" />
		<meta name="twitter:site" content="@phoronix" />
		<meta name="twitter:creator" content="@michaellarabel" />
		<meta name="twitter:title" content="Linux 6.2 Adds AMD Zen 4 Pipeline Utilization Data To Help Find Performance Bottlenecks" />
		<meta name="og:title" content="Linux 6.2 Adds AMD Zen 4 Pipeline Utilization Data To Help Find Performance Bottlenecks" />
		<meta name="twitter:image" content="https://www.phoronix.net/image.php?id=2022&image=zen4_linux62_perf1" />
		<meta name="og:image" content="https://www.phoronix.net/image.php?id=2022&image=zen4_linux62_perf1" />
		<meta name="twitter:description" content="Ahead of the Linux 6.2 merge window ending this weekend, a second batch of the perf subsystem changes have been submitted for this next Linux kernel version" />
		<!-- PHORONIX (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
(function() {
  var host = 'phoronix.com';
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://cmp.quantcast.com'
    .concat('/choice/', 'UEFjU_w924fg3', '/', host, '/choice.js');
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        if(args[0] === 'init' && typeof args[3] === 'object') {
          args[3] = { ...args[3], tag_version: 'V2' };
        }
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            if (event && event.source && event.source.postMessage) {
              event.source.postMessage(returnMsg, '*');
            }
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
    		
	</head>
	<body style="overflow: initial !important;">
		<div style="text-align: center; overflow: hidden; background: #222;"><div align="center" id="phoronix_desktop_leaderboard_header">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_header", slotId: "phoronix_desktop_leaderboard_header" });
  </script>
</div>
</div>		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="/"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" rel="me" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" rel="me" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="/reviews">Articles &amp; Reviews</a></li>
		        <li><a href="/news">News Archive</a></li>
		        <li><a href="/forums/">Forums</a></li>
		        <li><a href="/phoronix-premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		         <li><a href="/reviews/Computers">Computers</a></li> <li><a href="/reviews/Display+Drivers">Display Drivers</a></li> <li><a href="/reviews/Graphics+Cards">Graphics Cards</a></li> <li><a href="/reviews/Linux+Gaming">Linux Gaming</a></li> <li><a href="/reviews/Memory">Memory</a></li> <li><a href="/reviews/Motherboards">Motherboards</a></li> <li><a href="/reviews/Processors">Processors</a></li> <li><a href="/reviews/Software">Software</a></li> <li><a href="/reviews/Storage">Storage</a></li> <li><a href="/reviews/Operating+Systems">Operating Systems</a></li> <li><a href="/reviews/Peripherals">Peripherals</a></li>				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="/reviews">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/phoronix-premium">Premium</a>
					</li>					<li class="menulink">
						<a class="linknode" href="/contact">Contact</a>
					</li>
					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
		         <a href="/reviews/Computers">Computers</a> <a href="/reviews/Display+Drivers">Display Drivers</a> <a href="/reviews/Graphics+Cards">Graphics Cards</a> <a href="/reviews/Linux+Gaming">Linux Gaming</a> <a href="/reviews/Memory">Memory</a> <a href="/reviews/Motherboards">Motherboards</a> <a href="/reviews/Processors">Processors</a> <a href="/reviews/Software">Software</a> <a href="/reviews/Storage">Storage</a> <a href="/reviews/Operating+Systems">Operating Systems</a> <a href="/reviews/Peripherals">Peripherals</a>							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<div align="center" id="phoronix_desktop_leaderboard_atf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_atf", slotId: "phoronix_desktop_leaderboard_atf" });
  </script>
</div>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("597bdc6").style.display = 'block';
}
 }, 3000);  
  };
</script>
<p id="597bdc6" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">Happy Holidays</strong>  If you have enjoyed reading the new and original content on Phoronix each and every day this year, consider showing your support by <a href="https://www.phoronix.com/news/Phoronix-Premium-Xmas-22-Sale">the end of year / holiday deal on Phoronix Premium</a>. <a href="https://www.phoronix.com/phoronix-premium">Phoronix Premium</a> helps make operations possible while you get to enjoy ad-free viewing and multi-page articles on a single page. There have been more than 2,800 news articles and 185+ Linux hardware reviews written this year by your's truly, but unfortunately, operations remain difficult driven by extreme ad-block use.</p>
<h1>Linux 6.2 Adds AMD Zen 4 Pipeline Utilization Data To Help Find Performance Bottlenecks</h1>
<div class="author">Written by <a href="https://www.michaellarabel.com/">Michael Larabel</a> in <a href="/linux/AMD">AMD</a> on 22 December 2022 at 01:00 PM EST. <a href="/forums/node/1364198">1 Comment</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="AMD -- " src="/assets/categories/amd.webp" width="100" height="100" /></div>
Ahead of the <a href="https://www.phoronix.com/search/Linux+6.2">Linux 6.2</a> merge window ending this weekend, a second batch of the perf subsystem changes have been submitted for this next Linux kernel version. Notable among the various additions to the powerful Linux kernel perf code is handling for various new performance monitoring events with new AMD <a href="https://www.phoronix.com/search/Zen%204">Zen 4</a> processors.
<br />
<br />With today's collection of perf tools fixes/improvements mailed in to Linus Torvalds for merging, the AMD Zen 4 additions are worth mentioning. A variety of new core performance monitor counters, L3 cache performance monitor counters, and fabric performance monitor counter events. A wide variety of event metrics around dispatch, execution and retirement, branch prediction, L1/L2 cache activity, and TLB activity are exposed in a compatible manner for Zen 4 processors.
<br /><p align="center"><a href="//www.phoronix.com/image-viewer.php?id=2022&image=zen4_linux62_perf1_lrg" target="_blank"><img src="//www.phoronix.net/image.php?id=2022&image=zen4_linux62_perf1_med" /></a></p>
<br />In addition, there are new performance measurements that can now be tapped into by Linux's <em>perf</em> utility with Zen 4 processors headlined by now having pipeline utilization data. Among the many pipeline utilization metrics that are new with Zen 4 CPUs include details around bad speculation and miss-predicts, front-end bound bandwidth, back-end bound by the memory subsystem or CPU, 
<br />
<br />The Zen 4 pipeline utilization metrics allow analyzing activity at different stages of the CPU pipeline for determining performance bottlenecks in the executed code. This should help developers greatly in figuring out any shortcomings in their code and make more effective performance optimizations as a result of these hardware insights.
<br /><p align="center"><a href="//www.phoronix.com/image-viewer.php?id=2022&image=zen4_linux62_perf2_lrg" target="_blank"><img src="//www.phoronix.net/image.php?id=2022&image=zen4_linux62_perf2_med" /></a></p>
<br />These new performance counters with Zen 4 have been detailed already in AMD's public Processor Programming Reference (PPR) manual while now it's sliced up in JSON form for consumption by Linux's perf tooling. It's unfortunate that these perf additions weren't upstreamed into the Linux kernel sooner to assist developers with early access to Ryzen 7000 series and EPYC 9004 series processors to help in their profiling and optimizations, but at least it's on the way now with Linux 6.2. Some Zen 4 additions did arrive earlier like <a href="https://www.phoronix.com/news/Linux-6.0-Zen4-IBS-Perf-Tools">the Zen 4 instruction-based sampling (IBS) with Linux 6.0</a> while these JSON additions are coming post-launch.
<br />
<br />Today's <a href="https://lore.kernel.org/lkml/20221222164914.508929-1-acme@kernel.org/">perf tools pull</a> also has various fixes, perf lock contention reporting, refreshed metrics/events for various generations of Intel CPUs, and other updates.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<div align="center" id="phoronix_leaderboard_btf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_btf", slotId: "phoronix_leaderboard_btf" });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1364198">1 Comment</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Linux 6.2 Adds AMD Zen 4 Pipeline Utilization Data To Help Find Performance Bottlenecks" data-url="https://www.phoronix.com/news/LInux-6.2-AMD-Zen-4-Events" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=https://www.phoronix.com/news/LInux-6.2-AMD-Zen-4-Events&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="7279734770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div class="article-box">
								<header>Related News</header>
								<div class="node"><a href="/news/AMD-Zen-4-Tuning-GCC-13-Lands">AMD Zen 4 Tuning Patches Begin Landing In GCC 13</a></div><div class="node"><a href="/news/AMD-P-State-EPP-v8">AMD P-State EPP Patches Spun An 8th Time For Helping Out Linux Performance &amp; Efficiency</a></div><div class="node"><a href="/news/AMD-Zen-4-Znver4-LLVM-Added">Initial AMD Zen 4 Enablement Lands In LLVM Clang 16.0</a></div><div class="node"><a href="/news/AMD-SEV-SNP-Linux-Back-To-RFC">AMD Overhauls Their SEV-SNP Hypervisor Patches They Are Working To Upstream In Linux</a></div><div class="node"><a href="/news/AMD-P-State-EPP-No-Linux-6.2">AMD P-State EPP Won&#039;t Be Ready Until Linux 6.3</a></div><div class="node"><a href="/news/AMD-AOMP-16.0-3">AMD Releases AOMP 16.0-3 Compiler</a></div>
	                             
							</div>						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<div align="center" id="phoronix_leaderboard_incontent_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_incontent_3", slotId: "phoronix_leaderboard_incontent_3" });
  </script>
</div>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a>, <a href="https://www.linkedin.com/in/michaellarabel/">LinkedIn</a>, or contacted via <a href="https://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="/news/Torvalds-Bashes-Intel-LAM">Linus Torvalds Bashes Intel&#039;s LAM - Rejected For Linux 6.2</a></div><div class="node"><a href="/news/Linux-m68k-strcmp-Always-Broken">Whoops: Linux&#039;s strcmp() For The m68k Has Always Been Broken</a></div><div class="node"><a href="/news/Linux-9p-10x-Performance">New Patches Aim To Boost Linux 9p Performance By ~10x</a></div><div class="node"><a href="/news/Microsoft-DX-Shader-Linux-Build">Microsoft Begins Providing DirectX Shader Compiler Linux Binaries</a></div><div class="node"><a href="/news/KDE-Plasma-5.27-Multi-Monitor">KDE Plasma 5.27 To Provide Better Multi-Monitor Support</a></div><div class="node"><a href="/news/Apache-SpamAssassin-4.0">Apache SpamAssassin 4.0 Released With Many Improvements For Fighting Spam</a></div><div class="node"><a href="/news/Xfce-4.18-Released">Xfce 4.18 Released - Much Improved File Manager, Better HiDPI, Adaptive Vsync With GLX</a></div><div class="node"><a href="/news/Debian-11.6-Released">Debian 11.6 Released For The Latest &quot;Bullseye&quot; Packages</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<div align="center" id="phoronix_right_rail_1">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_1", slotId: "phoronix_right_rail_1" });
  </script>
</div>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="/news/Intel-New-Xe-Linux-Driver">Intel Preparing New &quot;Xe&quot; Linux Kernel Graphics Driver For Modern iGPUs &amp; dGPUs</a>
                            </div>
<div class="popular-list">
                                <a href="/news/LInux-6.2-AMD-Zen-4-Events">Linux 6.2 Adds AMD Zen 4 Pipeline Utilization Data To Help Find Performance Bottlenecks</a>
                            </div>
<div class="popular-list">
                                <a href="/news/AMD-Zen-4-Tuning-GCC-13-Lands">AMD Zen 4 Tuning Patches Begin Landing In GCC 13</a>
                            </div>
<div class="popular-list">
                                <a href="/news/VP9-AV1-Vulkan-2023">VP9 &amp; AV1 Vulkan Video Extensions Expected Next Year</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Fedora-Disallow-Endianess-X.Org">Fedora Linux Looks To Close Another &quot;Large Attack Surface&quot; With The X.Org Server</a>
                            </div>
<div class="popular-list">
                                <a href="/news/OpenBMC-2.12-Released">OpenBMC 2.12 Released For This Open-Source, Linux-Powered BMC Software Stack</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Linux-m68k-strcmp-Always-Broken">Whoops: Linux&#039;s strcmp() For The m68k Has Always Been Broken</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Linux-6.2-ZRAM-Multi-Compress">Linux 6.2 Lands Support For Multiple Compression Streams With ZRAM</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Fedora-38-Unified-Kernel-Part-1">Fedora 38 Plots Path To Unified Kernel Support</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Phoronix-Premium-Xmas-22-Sale"><span style="font-weight: 600;">Phoronix Premium 2022 Christmas Deal For Enjoying Ad-Free Access, Single Page Articles</span></a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <div align="center" id="phoronix_right_rail_2">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_2", slotId: "phoronix_right_rail_2" });
  </script>
</div>

                        </div>
                        </aside>
			                        <aside class="widget">
                       <header>Show Your Support, Go Premium</header>
                       <p><a href="/phoronix-premium">Phoronix Premium</a> allows ad-free access to the site, multi-page articles on a single page, and other features while supporting this site's continued operations.</p>
                        </aside>
			                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/review/amd-sme-genoa">AMD Secure Memory Encryption &quot;SME&quot; Performance With 4th Gen EPYC Genoa</a>
                            </div>
<div class="popular-list">
                                <a href="/review/linux-62-rtx30">Running The New Open-Source NVIDIA GeForce RTX 30 Series Support In Linux 6.2</a>
                            </div>
<div class="popular-list">
                                <a href="/review/amd-epyc-avx512">AMD 4th Gen EPYC 9654 &quot;Genoa&quot; AVX-512 Performance Analysis</a>
                            </div>
<div class="popular-list">
                                <a href="/review/amd-epyc-aocc4">AOCC 4.0 Shows The Strong Advantages Of Compiler Optimizations With 4th Gen AMD EPYC CPUs</a>
                            </div>
<div class="popular-list">
                                <a href="/review/rx7900-blender-opencl">Blender 3.4 HIP Performance With Radeon RX 7900 Series + RDNA3 OpenCL Compute Benchmarks</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<div style="position: sticky; top: 0; position: -webkit-sticky;"><div align="center" id="phoronix_right_rail_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_3", slotId: "phoronix_right_rail_3" });
  </script>
</div>

</div>                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="/phoronix-premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/donate/?hosted_button_id=EA79CCDLNFJNW">PayPal tip</a> or <a href="https://buy.stripe.com/28o02d1yG1Lp8H67ss">tip via Stripe</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="/contact">Contact</a></li>
		                    <li><a href="/michaellarabel">Michael Larabel</a></li>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="/phoronix-premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix" rel="me">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix" rel="me">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="/legal">Legal Disclaimer, Privacy Policy, Cookies</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2022 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
	</body>
</html>
