<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1978569-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1978569-1');
</script>

<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  freestar.config.enabled_slots = [];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/phoronix-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>

<script>
freestar.config.disabledProducts = {
    googleInterstitial: true
};
</script>
		<title>Linux 5.19.1 Released With LTS Kernels Back To 4.19 For The &quot;PBRSB&quot; CPU Issue - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="/phxcms-css/phoronix-10.css?2027">
				<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux server benchmarks, Linux benchmarking, Desktop Linux, Linux performance, Open Source graphics, Linux How To, Ubuntu benchmarks, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="A number of new Linux kernel stable releases are out this week with new mitigations around the latest batch of published CPU security vulnerabilities" />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
		<meta name="twitter:card" content="summary_large_image" />
		<meta name="twitter:site" content="@phoronix" />
		<meta name="twitter:creator" content="@michaellarabel" />
		<meta name="twitter:title" content="Linux 5.19.1 Released With LTS Kernels Back To 4.19 For The &quot;PBRSB&quot; CPU Issue" />
		<meta name="og:title" content="Linux 5.19.1 Released With LTS Kernels Back To 4.19 For The &quot;PBRSB&quot; CPU Issue" />
		<meta name="twitter:image" content="https://www.phoronix.net/image.php?id=2022&image=linux_5191" />
		<meta name="og:image" content="https://www.phoronix.net/image.php?id=2022&image=linux_5191" />
		<meta name="twitter:description" content="A number of new Linux kernel stable releases are out this week with new mitigations around the latest batch of published CPU security vulnerabilities" />
		<!-- PHORONIX (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
(function() {
  var host = 'phoronix.com';
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://cmp.quantcast.com'
    .concat('/choice/', 'UEFjU_w924fg3', '/', host, '/choice.js');
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        if(args[0] === 'init' && typeof args[3] === 'object') {
          args[3] = { ...args[3], tag_version: 'V2' };
        }
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            if (event && event.source && event.source.postMessage) {
              event.source.postMessage(returnMsg, '*');
            }
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
    		
	</head>
	<body style="overflow: initial !important;">
		<div style="text-align: center; overflow: hidden; background: #222;"><div align="center" id="phoronix_desktop_leaderboard_header">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_header", slotId: "phoronix_desktop_leaderboard_header" });
  </script>
</div>
</div>		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="/"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" rel="me" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" rel="me" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="/reviews">Articles &amp; Reviews</a></li>
		        <li><a href="/news">News Archive</a></li>
		        <li><a href="/forums/">Forums</a></li>
		        <li><a href="/phoronix-premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		         <li><a href="/reviews/Computers">Computers</a></li> <li><a href="/reviews/Display+Drivers">Display Drivers</a></li> <li><a href="/reviews/Graphics+Cards">Graphics Cards</a></li> <li><a href="/reviews/Linux+Gaming">Linux Gaming</a></li> <li><a href="/reviews/Memory">Memory</a></li> <li><a href="/reviews/Motherboards">Motherboards</a></li> <li><a href="/reviews/Processors">Processors</a></li> <li><a href="/reviews/Software">Software</a></li> <li><a href="/reviews/Storage">Storage</a></li> <li><a href="/reviews/Operating+Systems">Operating Systems</a></li> <li><a href="/reviews/Peripherals">Peripherals</a></li>				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="/reviews">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="/phoronix-premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
		         <a href="/reviews/Computers">Computers</a> <a href="/reviews/Display+Drivers">Display Drivers</a> <a href="/reviews/Graphics+Cards">Graphics Cards</a> <a href="/reviews/Linux+Gaming">Linux Gaming</a> <a href="/reviews/Memory">Memory</a> <a href="/reviews/Motherboards">Motherboards</a> <a href="/reviews/Processors">Processors</a> <a href="/reviews/Software">Software</a> <a href="/reviews/Storage">Storage</a> <a href="/reviews/Operating+Systems">Operating Systems</a> <a href="/reviews/Peripherals">Peripherals</a>							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<div align="center" id="phoronix_desktop_leaderboard_atf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_atf", slotId: "phoronix_desktop_leaderboard_atf" });
  </script>
</div>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("f75dce6").style.display = 'block';
}
 }, 2000);  
  };
</script>
<strong id="f75dce6" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  Did you know that the hundreds of articles written on Phoronix each month are mostly authored by one individual working insane hours? Phoronix.com doesn't have a whole news room with unlimited resources and relies upon people reading our content without blocking ads and alternatively by people <a href="/phoronix-premium">subscribing to Phoronix Premium</a> for our ad-free service with other extra features. You can also consider <a href="https://www.paypal.com/donate/?hosted_button_id=EA79CCDLNFJNW">a tip via PayPal</a>.</strong>
<h1>Linux 5.19.1 Released With LTS Kernels Back To 4.19 For The &quot;PBRSB&quot; CPU Issue</h1>
<div class="author">Written by <a href="https://www.michaellarabel.com/">Michael Larabel</a> in <a href="/linux/Linux+Kernel">Linux Kernel</a> on 11 August 2022 at 11:00 AM EDT. <a href="/forums/node/1340057">6 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="LINUX KERNEL -- " src="/assets/categories/linuxkernel.webp" width="100" height="100" /></div>
A number of new Linux kernel stable releases are out this week with new mitigations around the latest batch of published CPU security vulnerabilities. Linux 5.19.1, 5.18.17, 5.15.60, 5.10.136, 5.4.210, and 4.19.255 are the new releases out today.<br /><br />Most notable with these new Linux kernel releases are <a href="https://www.phoronix.com/news/Linux-PBRSB-Mitigation">eIBRS-PBRSB after finding Intel eIBRS CPUs to provide insufficient protections</a>. The Linux kernel via its vulnerabilities reporting will now indicate if a system is vulnerable to EIBRS Post-barrier Return Stack Buffer (PBRSB), whether the system is running with protection of RSB on VMEXITs, or if the system is not affected. The kernel change adds an LFENCE to the return stack buffer (RSB) fill sequence and adds RSB VMEXIT protections. The kernel patch treats all Intel eIBRS-using CPUs -- including latest-generation Alder Lake and Xeon Scalable Ice Lake -- as needing PBRSB handling except for Goldmont Plus and Tremont.<br /><br />From one of the kernel patches:<br /><blockquote>    tl;dr: The Enhanced IBRS mitigation for Spectre v2 does not work as documented for RET instructions after VM exits. Mitigate it with a new one-entry RSB stuffing mechanism and a new LFENCE.</blockquote><br />The back-ported x86 security work is in regards to that eIBRS-PBRSB affecting newer Intel CPUs. There are <em>not</em> any kernel mitigation changes at this time around the <a href="https://www.phoronix.com/news/AMD-Side-Channel-SQUIP">AMD SQUIP side-channel vulnerability</a> that was also disclosed on Tuesday.<br /><p align="center"><img src="//www.phoronix.net/image.php?id=2022&image=linux_5191" /></p><br />The other changes in today's kernel stable releases are the usual bug fixing. Grab the new stable kernel sources at <a href="https://kernel.org/">kernel.org</a>.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<div align="center" id="phoronix_leaderboard_btf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_btf", slotId: "phoronix_leaderboard_btf" });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1340057">6 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Linux 5.19.1 Released With LTS Kernels Back To 4.19 For The &quot;PBRSB&quot; CPU Issue" data-url="https://www.phoronix.com/news/Linux-5.19.1-And-Older-LTS" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=https://www.phoronix.com/news/Linux-5.19.1-And-Older-LTS&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="7279734770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div class="article-box">
								<header>Related News</header>
								<div class="node"><a href="/news/Linux-6.0-Drops-O3-Kconfig">&quot;CC_OPTIMIZE_FOR_PERFORMANCE_O3&quot; Performance Tunable Dropped In Linux 6.0</a></div><div class="node"><a href="/news/Linux-6.0-EFI">Linux 6.0 Adds EFI Mirrored Memory &amp; ACPI PRM For 64-bit Arm</a></div><div class="node"><a href="/news/Linux-PBRSB-Mitigation">Linux Kernel Patched For &quot;PBRSB&quot; After Intel eIBRS CPUs Found To Be Insufficient</a></div><div class="node"><a href="/news/Linux-6.0-Hostname">Linux 6.0 Allows Setting The Hostname Via New &quot;hostname=&quot; Parameter</a></div><div class="node"><a href="/news/Linux-6.0-Char-Misc">Habana Labs Gaudi2 Support Leads The Linux 6.0 Char/Misc Changes</a></div><div class="node"><a href="/news/Linux-6.0-POWER-Updates">IBM Power Improvements For Linux 6.0 Support The PowerVM Platform KeyStore</a></div>
	                             
							</div>						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<div align="center" id="phoronix_leaderboard_incontent_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_incontent_3", slotId: "phoronix_leaderboard_incontent_3" });
  </script>
</div>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a>, <a href="https://www.linkedin.com/in/michaellarabel/">LinkedIn</a>, or contacted via <a href="https://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="/news/NVIDIA-3D-Headers-Fermi-Ampere">NVIDIA Publishes 73k Lines Worth Of 3D Header Files For Fermi Through Ampere GPUs</a></div><div class="node"><a href="/news/DreamWorks-MoonRay-Open-Source">DreamWorks Animation To Open-Source MoonRay Renderer</a></div><div class="node"><a href="/news/AMD-PMF-Linux-Driver">AMD Developing &quot;PMF&quot; Linux Driver For Better Desktop/Laptop User Experience</a></div><div class="node"><a href="/news/BUS1-r-linux">BUS1 Working On &quot;r-linux&quot; - A Rust Capability-Based Linux Runtime</a></div><div class="node"><a href="/news/AMD-EPYC-Linux-6.0-Early-Tests">An Early Look At AMD EPYC Performance Gains On Linux 6.0</a></div><div class="node"><a href="/news/Ubuntu-22.04.1-LTS-Delayed">Ubuntu 22.04.1 LTS Delayed Due To An OEM Install Issue Leading To Broken Snaps</a></div><div class="node"><a href="/news/Linux-6.0-Runtime-Verification">Linux 6.0 Adding Run-Time Verification For Running On Safety Critical Systems</a></div><div class="node"><a href="/news/Steam-OS-3.3-Steam-Deck">SteamOS 3.3 Now Available With Many Improvements For The Steam Deck</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<div align="center" id="phoronix_right_rail_1">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_1", slotId: "phoronix_right_rail_1" });
  </script>
</div>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="/news/Asahi-Apple-DRM-In-Rust">Asahi Linux May Pursue Writing Apple Silicon GPU Driver In Rust</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Linux-5.19.1-And-Older-LTS">Linux 5.19.1 Released With LTS Kernels Back To 4.19 For The &quot;PBRSB&quot; CPU Issue</a>
                            </div>
<div class="popular-list">
                                <a href="/news/AMD-Zen-4-LbrExtV2">AMD Posts Linux Patches For &quot;LbrExtV2&quot; Zen 4 CPU Feature</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Ubuntu-22.04.1-LTS">Ubuntu 22.04.1 LTS Released</a>
                            </div>
<div class="popular-list">
                                <a href="/news/LibreOffice-LoongArch">Loongson Adds LoongArch Support To LibreOffice</a>
                            </div>
<div class="popular-list">
                                <a href="/news/GNOME-Mutter-Shell-43-Beta">GNOME Mutter &amp; Shell 43 Beta Bring Several Very Exciting Changes</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Linux-6.0-Fixes-TUXEDO-Input">Linux 6.0 Fixes Touchpad &amp; Keyboard Issues After Suspend For Many TUXEDO Laptops</a>
                            </div>
<div class="popular-list">
                                <a href="/news/xorgproto-2022.2">X.Org Protocols 2022.2 Released With XWAYLAND Extension, DRI3 v1.3</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Mesa-22.2-rc2">Mesa 22.2-rc2 Released With Many Fixes - Heavy On Zink</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Linux-6.0-Drops-O3-Kconfig">&quot;CC_OPTIMIZE_FOR_PERFORMANCE_O3&quot; Performance Tunable Dropped In Linux 6.0</a>
                            </div>
<div class="popular-list">
                                <a href="/news/Weston-11.0-Alpha">Weston 11.0 Alpha Released With Many Improvements For This Wayland Compositor</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <div align="center" id="phoronix_right_rail_2">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_2", slotId: "phoronix_right_rail_2" });
  </script>
</div>

                        </div>
                        </aside>
			                        <aside class="widget">
                       <header>Show Your Support, Go Premium</header>
                       <p><a href="/phoronix-premium">Phoronix Premium</a> allows ad-free access to the site, multi-page articles on a single page, and other features while supporting this site's continued operations.</p>
                        </aside>
			                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/review/apple-m2-linux">Apple M2 vs. AMD Rembrandt vs. Intel Alder Lake Linux Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/review/amd-threadripper-5965wx">AMD Ryzen Threadripper PRO 5965WX Performance On Linux</a>
                            </div>
<div class="popular-list">
                                <a href="/review/ryzen7-6850u-acpi">AMD Ryzen 7 PRO 6850U: ACPI Platform Profile Low-Power vs. Balanced vs. Performance</a>
                            </div>
<div class="popular-list">
                                <a href="/review/intel-1280p-windows-linux">Intel Core i7 1280P Windows 11 vs. Ubuntu vs. Clear Linux Performance</a>
                            </div>
<div class="popular-list">
                                <a href="/review/xeon-skylake-retbleed">Retbleed Impact, Overall CPU Security Mitigation Cost For Intel Xeon E3 v5 Skylake</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<div style="position: sticky; top: 0; position: -webkit-sticky;"><div align="center" id="phoronix_right_rail_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_3", slotId: "phoronix_right_rail_3" });
  </script>
</div>

</div>                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="/phoronix-premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/donate/?hosted_button_id=EA79CCDLNFJNW">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="/contact">Contact</a></li>
		                    <li><a href="/michaellarabel">Michael Larabel</a></li>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="/phoronix-premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix" rel="me">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix" rel="me">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="/legal">Legal Disclaimer, Privacy Policy, Cookies</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2022 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
	</body>
</html>
