No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

  • Filter
  • Time
  • Show
Clear All
new posts

  • Great... glad to hear it's working.


    • A few updates ago I have noticed low performance in some of my games, namely Bioshock Infinite and Tomb Raider (both on Steam). Neither of those games run higher than 30fps, despite being able to game smoothly at 50-60fps a few weeks ago with the same settings. It's like the games are being capped at 30fps. Turning off vsync in the games does not solve this either. I have not tried turning off vsync and swapbuffers wait in the driver, but other games (Half Life 2 and Xonotic) work fine. Anyone have been experiencing something similar?


      • This may be the same as the "290 slowdown" bug... seems to have effect when fps would normally be under 60 Hz. Don't think the root cause is understood yet but has been bisected to a page-flip commit:


        • Just a note I upgraded llvm in the ppa to 3.9.


          • Hi, I had previously installed your PPA on my copy of Kubuntu 14.04 (Trusty Tahir), and at some point, the repo stopped updating itself. I didn't think much of it until now when I went to try to upgrade my system to 16.04. I can't upgrade it because the upgrade manager can't calculate the dependencies. I figured maybe one of the causes was any extra repos I had, so I removed the other ones I had installed, but I ran into an issue with the oibaf PPA.
            I can remove the repo, but there's no easy way to downgrade the packages back to the original versions- using ppa-purge gives me this:

            sudo ppa-purge ppaibaf/graphics-drivers
            Updating packages lists
            PPA to be removed: oibaf graphics-drivers
            Warning: Could not find package list for PPA: oibaf graphics-drivers

            There doesn't appear to be packages for the oibaf graphics PPA before 16.04 now, which might be why ppa-purge doesn't work.
            It looks like the only way to reset the packages to the original versions is to do it manually, bit by bit:
            Is there a better way to do this, or is this the only way?


            • Hello.

              Thought I'd give a warning - latest update(s) of mesa-vdpau-drivers has broken UVD (VDPAU, hardware video decoding) for me.
              MPV and Xine couldn't use hwdec anymore complaining about the kernel rejecting the Command Stream (CS).

              While trying to decode video using VDPAU, dmesg repeatedly showed errors:
              [14049.006274] [drm:radeon_uvd_cs_parse [radeon]] *ERROR* Handle 0x61d40001 already in use!
              [14049.006304] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !

              The earliest version to blame: mesa-vdpau-drivers_12.1~git1609280730.8d8c44~gd~x_amd64.deb (yesterdays)

              Downgrading to mesa-vdpau-drivers_12.1~git1609180730.073129~gd~x_amd64.deb restored VDPAU to working order.

              GPU: Cape Verde XT Radeon HD 7770
              Kernel version: Tried with Ubuntu's 4.4 and 4.8


              • I just enabled the recently merged block I/O, network I/O and lmsensor stats as well power sensor support.


                • Hello!
                  Firstly, thanks for all your work!

                  It seems tho that these changes didn't help in my case. Only the error message has changed slightly:
                  [ 68.810156] [drm:radeon_uvd_cs_parse [radeon]] *ERROR* invalid reloc offset 831000!
                  [ 68.810180] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !

                  Guess I'll have to hold on to this mesa-vdpau version for some time. Cheers anyway!


                  • Current version (installed with other updates across the stack) works. Thanks.


                    • I have a similar problem to mos87's.

                      [ 2451.093882] radeon 0000:01:00.0: evergreen_cs_track_validate_texture:854 texture bo too small (layer size 557056, offset 2785280, max layer 2, depth 1, bo size 3342336) (1024 272)
                      [ 2451.093948] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !

                      Using mpv with hwdec=vdpau shows no image and continously spams this error.