Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hello,
    first of all thanks for all the great work.
    I have a little issue with these drivers:
    I'm running Linux Mint 18 Xfce 64-bit, kernel: 4.4.0-57-generic, with an AMD Radeon R7 265. I hade zero problems during drivers' installation, but after rebooting computer and logging-in appears some issues in some colours on my system: examples are the mint menu logo is now pink, others icon in the program menu are pink, top bars of windows are red instead of black. And then coulour issues on terrain of some videogames.
    I'm pretty new to linux so i actually don't know what should i do.

    This is what i get from glxinfo | grep "OpenGL version":

    OpenGL version string: 3.0 Mesa 13.1.0-devel


    Comment


    • Hi all!
      This is my first post in this forum and it's for asking about a problem I have with the Oibaf packages
      under debian8 and with my Radeon HD8400E Kabini chip.

      I've recompiled the packages I get from Oibaf archive at december. Exactly the next versions:

      libclc 0.2.0+git20161219.1209.520743~gd~x
      libdrm 2.4.74+git1612241830.eebefa~gd~x
      libva 1.7.1-2~gd~x
      llvm-3.9 1:3.9.1-1~gd~x
      mesa 13.1~git1612270730.4d6d4f~gd~x
      xserver-xorg-video-amdgpu 1.2.99+git1612191933.b5c189~gd~x
      xserver-xorg-video-ati 1:7.8.99+git1612191933.720dd0~gd~x

      My kernel version is 4.7.8-1~bpo8+1. I have installed this firmware files:

      firmware-amd-graphics 20160824-1~bpo8+1
      firmware-linux-free 3.3


      I've defined the /usr/share/X11/xorg.conf.d/20-device.conf as:

      Section "Device"
      Identifier "Device0"
      Driver "radeon"
      Option "AccelMethod" "glamor"
      Option "DRI" "3"
      Option "TearFree" "on"
      EndSection

      I have a program using shaders working ok when I comment out DRI 3 option but my Xorg desktop is
      frozen when the same program is run with the Xorg configured with DRI 3. The glxgears works ok with
      both configurations.

      Where the problem should come from? kernel or mesa? Any hint where to look?
      Thanks a lot!

      Comment


      • Latest update causes problems for me. KDE greets me with a solid white screen. System is still responsive. I can launch individual programs no problem. Glxgears renders fine. Problem persists even when I boot in Ubuntu's fails-safe mode. Games present graphical issues like missing textures all around and colored scanlines across the screen. Using a Nitro+ RX480. Anyone is experiencing issues with these cards?

        Comment


        • oibaf Do you plan on compiling Vulkan drivers in at some point? I'd really appreciate it.

          Comment


          • Originally posted by LinuxID10T View Post
            oibaf Do you plan on compiling Vulkan drivers in at some point? I'd really appreciate it.
            Probably yes, as soon as I have some time and motivation.

            Comment


            • Upgraded LLVM to 4.0 rc1.

              Comment


              • Thanks for putting this together and maintaining it for so long, oibaf.

                Comment


                • Youre a wizard Oibaf! My pentium4 can run now HD videos!: https://www.youtube.com/watch?v=P3uzeQJT9WM
                  Gretting from Israel for your magic drivers!

                  Comment


                  • Originally posted by jorgefm View Post
                    Where the problem should come from? kernel or mesa? Any hint where to look?
                    Thanks a lot!
                    use Debian testing Xfce, OIbaf ppa yakkety version works out of box without recompilation. Also you can try the amdgpu driver by compiling a custom kernel. See:
                    https://www.phoronix.com/forums/foru...in-living-room


                    Comment


                    • Hi all.
                      I've been using the oibaf ppa since august of last year when, after upgrading Lubuntu 15.10 to 16.04 and Blender, the last stopped working with this message "Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.", which was solved by adding the repository and upgrading. THANKS!!! ^_^
                      The past Friday I made an apt upgrade and blender stopped working again, now with this message "Writing: /tmp/blender.crash.txt Segmentation fault (core dumped)". Also noticed mpv, only when started in fullscreen, gives also a segfault with this info in dmesg "mpv/vo[18230]: segfault at 234 ip 00007ff625ed96e8 sp 00007ff6277fd7b0 error 4 in i915_dri.so[7ff6259f5000+9c8000]".
                      I've purged the ppa and tried with the paulo-miguel-dias ppa with the same results.
                      The previous upgrade was from 2017-02-06 (17.0~git1701100730.17eac3~gd~x, 17.1~git1702040730.106a51~gd~x) and worked. Is there a way to downgrade to that version without compiling?

                      Comment

                      Working...
                      X