Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • let me think... ubuntu has nothing to do in this case. As i know, xserver-xorg-video-ati - 1:7.1.0 doesn't set glamor acceleration by default for radeonsi. no glamor no fun
    can you paste X log? in my distro: /var/log/Xorg.0.log
    Last edited by frosth; 07-17-2013, 01:57 PM. Reason: typo

    Comment


    • http://pastebin.com/iRV16UCP

      Comment


      • HTML Code:
        cat dmesg.mmstick | grep -i glamor
        [     6.279] (II) LoadModule: "glamoregl"
        [     6.280] (WW) Warning, couldn't open module glamoregl
        [     6.280] (II) UnloadModule: "glamoregl"
        [     6.280] (II) Unloading glamoregl
        [     6.280] (EE) Failed to load module "glamoregl" (module does not exist, 0)
        [     6.318] (**) RADEON(0): Option "AccelMethod" "glamor"
        [     6.318] (EE) RADEON(0): glamor requires Load "glamoregl" in Section "Module", disabling.
        Did You install "glamor-0.5-1~git20130313" package?
        Last edited by frosth; 07-17-2013, 02:17 PM. Reason: typo...

        Comment


        • What's the apt-get syntax for that? apt-get install glamor just says unable to locate package.

          Comment


          • i don't use ubuntu, but try: "find / | grep -i glamoregl" - it always work.

            or just install it(glamor package) from launchpad

            Comment


            • I ran sudo apt-get install glamor* and saw xserver-xorg-video-glamor and after rebooting it finally works. However, it does not work with kernel 3.11-rc1, back to llvmpipe, which I really want to get running thanks to all the radeonsi patches inside.

              Comment


              • Back on kernel 3.8, and now I'm faced with the age old problem before. There is no S3TC texture support, so I can't launch any Source games.

                Comment


                • i don't know why.. but maybe you didn't get latest firmware ?
                  http://people.freedesktop.org/~agd5f/radeon_ucode/

                  your Xlog said that you need files for "TAHITI" Chip

                  in my case firmware for radeon is here: /lib/firmware/radeon/, i hope ubuntu didn't change that in other case.. use google
                  ... or "find / | grep -i TAHITI" to find the right place.

                  and at last, for DPM use "radeon.dpm=1" as a boot parametr.

                  Comment


                  • [email protected]:~$ ls /lib/firmware/radeon | grep TAHITI
                    TAHITI_ce.bin
                    TAHITI_mc.bin
                    TAHITI_me.bin
                    TAHITI_pfp.bin
                    TAHITI_rlc.bin

                    Considering this is Ubuntu 13.04, and those files are last year, it's safe to say these are up-to-date as well.

                    Comment


                    • Okay I saw that smc.bin and uvd.bin wasn't there so I wgetted them and now I can get graphics rendering in kernel 3.11-rc1 and source games now launch...HOWEVER... all the text is corrupted and after a map loads the game crashes. The same is also happening with kernel 3.8. Something is borked.
                      Last edited by mmstick; 07-17-2013, 04:56 PM.

                      Comment

                      Working...
                      X