Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by oibaf View Post

    Restored llvm-18 in noble, now it properly builds again.
    I have a problem with llvm-18

    libgl1-mesa-dri:i386 : Depends: libllvm18:i386
    but libllvm18:i386 is incompatible with libllvm18

    ```
    dpkg: error processing archive /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb (--unpack):
    trying to overwrite shared '/usr/lib/llvm-18/lib/libLLVM.so.1', which is different from other instances of package libllvm18:i386​
    ```

    (I opened a bug about it https://bugs.launchpad.net/ubuntu/+s...8/+bug/2063207 )
    Last edited by guilhem; 23 April 2024, 08:12 AM.

    Comment


    • Originally posted by guilhem View Post

      I have a problem with llvm-18

      libgl1-mesa-dri:i386 : Depends: libllvm18:i386
      but libllvm18:i386 is incompatible with libllvm18

      ```
      dpkg: error processing archive /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb (--unpack):
      trying to overwrite shared '/usr/lib/llvm-18/lib/libLLVM.so.1', which is different from other instances of package libllvm18:i386​
      ```

      (I opened a bug about it https://bugs.launchpad.net/ubuntu/+s...8/+bug/2063207 )
      Yeah in my case llvm18 give errors too however if anyone stay interested i use Ernst Persson ppa:



      and now 24.2-dev work



      Last edited by pinguinpc; 08 May 2024, 08:42 AM.

      Comment


      • Added support for Ubuntu 24.10/oracular!

        I will remove support for Ubuntu 22.04/jammy and 23.10/mantic in a (not so distant) future.

        Comment


        • Next upload will disable rusticl, due to requiring newer meson which doesn't properly build.

          Comment


          • oibaf
            It would be really nice if the support for 22.04 could stay until 24.04.1 is out. This would allow to use this PPA until the release upgrade is official available. That makes it then also possible to switch directly after the upgrade back to the oibaf PPA.

            I tried to enforce a release upgrade (after purging all non standard PPAs) on a test system and the upgrade process crashed at some point. So it is currently absolutely not recommended to upgrade from 22.04 to 24.04.

            Comment


            • Originally posted by guilhem View Post

              I have a problem with llvm-18

              libgl1-mesa-dri:i386 : Depends: libllvm18:i386
              but libllvm18:i386 is incompatible with libllvm18

              ```
              dpkg: error processing archive /var/cache/apt/archives/libllvm18_1%3a18.1.3-1_i386.deb (--unpack):
              trying to overwrite shared '/usr/lib/llvm-18/lib/libLLVM.so.1', which is different from other instances of package libllvm18:i386​
              ```

              (I opened a bug about it https://bugs.launchpad.net/ubuntu/+s...8/+bug/2063207 )
              They are looking into it.
              In the meantime I just reverted again to llvm17 (building now).

              Comment


              • Originally posted by oibaf View Post

                They are looking into it.
                In the meantime I just reverted again to llvm17 (building now).
                Hehe yes, I did some investigation yesterday and pinged maintainer on Twitter

                Comment


                • Originally posted by guilhem View Post

                  Hehe yes, I did some investigation yesterday and pinged maintainer on Twitter
                  👍

                  Comment


                  • 23.10/mantic won't be updated anymore. I'll remove the package in some weeks.

                    Comment


                    • Hello I am on ubuntu 24.10 oracular. As soon as I enable your repo I am getting these errors

                      Get:10 https://ppa.launchpadcontent.net/oib...drivers/ubuntu oracular InRelease [24.4 kB]
                      Err:10 https://ppa.launchpadcontent.net/oib...drivers/ubuntu oracular InRelease
                      The following signatures were invalid: 5ABCE68FF4633EA42E219156957D2708A03A4626 (untrusted public key algorithm: rsa1024) The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 93F4D583494746C8

                      W: GPG error: https://ppa.launchpadcontent.net/oib...drivers/ubuntu oracular InRelease: The following signatures were invalid: 5ABCE68FF4633EA42E219156957D2708A03A4626 (untrusted public key algorithm: rsa1024) The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 93F4D583494746C8
                      E: The repository 'https://ppa.launchpadcontent.net/oibaf/graphics-drivers/ubuntu oracular InRelease' is not signed.
                      N: Updating from such a repository can't be done securely, and is therefore disabled by default.
                      N: See apt-secure(8) manpage for repository creation and user configuration details.

                      Comment

                      Working...
                      X