Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by oibaf View Post
    Radeon 7xxx requires glamor, but glamor doesn't work with newer xserver: http://www.freedesktop.org/wiki/Software/Glamor/
    Okay, thanks for this update. I thought glamor is only used for 2D acceleration, but apparently it does more than that. Maybe you could add this info to your PPA page, oibaf.

    I just bootet and upgraded my old Gentoo installation on the same machine and installed glamor-git. And voil?: it's working!

    Comment


    • Originally posted by oibaf View Post
      Radeon 7xxx requires glamor, but glamor doesn't work with newer xserver: http://www.freedesktop.org/wiki/Software/Glamor/
      Works fine on Fedora. (I run Rawhide)

      Comment


      • Also: http://phoronix.com/forums/showthrea...On-Newer-X-Org

        Comment


        • Nice news, if glamor get packaged in debian I'll backport it to the PPA, I don't have time to do it myself.

          Comment


          • Originally posted by direx View Post
            Is this supposed to give me 3D acceleration on my Radeon HD 7850? I just installed this PPA, but unfortunately I am stuck with softpipe:
            RadeonSI is now fully supported (only on Ubuntu 13.04), radeon driver being now compiled with glamor support (glamor packages courtesy from Cybjit PPA). Please test.

            Comment


            • Originally posted by oibaf View Post
              RadeonSI is now fully supported (only on Ubuntu 13.04), radeon driver being now compiled with glamor support (glamor packages courtesy from Cybjit PPA). Please test.
              After installing your ppa, my Radeon HD 7950 shows

              OpenGL vendor string: VMware, Inc.
              OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
              OpenGL version string: 2.1 Mesa 9.2.0-devel (git-1681bd7 raring-oibaf-ppa)
              OpenGL shading language version string: 1.30

              So glamor doesn't seem to be loading correctly. Did I do something wrong? I just added the ppa on a fresh install of Ubuntu 13.04 and ran upgrade/dist-upgrade.

              Comment


              • So glamor doesn't seem to be loading correctly....

                did you add somethings like that in /etc/X11/xorg.conf.d/...

                Code:
                Section "Module"
                    Load "dri2"
                    Load "glamoregl"
                EndSection
                
                Section "Device"
                    Identifier "HD7770"
                    Driver "radeon"
                    Option   "AccelMethod"      "glamor"
                    Option   "ColorTiling"      "on" 
                    Option     "ColorTiling2D"    "on"
                    Option   "EnablePageFlip"   "on"
                EndSection

                Comment


                • Originally posted by frosth View Post
                  did you add somethings like that in /etc/X11/xorg.conf.d/...

                  Code:
                  Section "Module"
                      Load "dri2"
                      Load "glamoregl"
                  EndSection
                  
                  Section "Device"
                      Identifier "HD7770"
                      Driver "radeon"
                      Option   "AccelMethod"      "glamor"
                      Option   "ColorTiling"      "on" 
                      Option     "ColorTiling2D"    "on"
                      Option   "EnablePageFlip"   "on"
                  EndSection
                  Elaborate, I don't have such a directory in my X11 directory.

                  Comment


                  • So glamor doesn't seem to be loading correctly....

                    so maybe you have xorg.conf file? if yes, you can add this code to xorg.conf file directly. if no... so i don't idea for this case i don't have *bunty but xorg.conf should be somewhere.


                    edit
                    sorry dude. for ubuntu 13.04 you better try in "/usr/share/X11/xorg.conf.d/" it's the right place.
                    Last edited by frosth; 07-17-2013, 05:38 AM.

                    Comment


                    • Originally posted by frosth View Post
                      so maybe you have xorg.conf file? if yes, you can add this code to xorg.conf file directly. if no... so i don't idea for this case i don't have *bunty but xorg.conf should be somewhere.


                      edit
                      sorry dude. for ubuntu 13.04 you better try in "/usr/share/X11/xorg.conf.d/" it's the right place.
                      I placed xorg.conf's there, in /usr/share/X11, in etc/X11, created a directory named xorg.conf.d in /etc/X11 and put xorg.conf in there -- nothing; it's intent on using llvmpipe. In Ubuntu we shouldn't need an xorg.conf anyway because it's supposed to be intelligent enough to select all the right parameters at boot.

                      Comment

                      Working...
                      X