Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi everyone! Does anyone else have problems running wine after the newest updates to the ppa?

    I started getting into this error text wineprob.txt whenever I ran wineboot or winecfg with no further output apart from the timeout message from wineboot until I killed the wineserver and after a couple of OS reinstalls, I discovered that the PPA was the problem by removing it and switching back to the default drivers. It worked and wine ran with no problems apart from the usual fixme texts.

    Afterwards I renabled the ppa, downloaded the drivers and the same errors came back when I ran wine.

    Wine was working perfectly under this ppa until just a couple of days ago until I found out the culprit.

    Currently my OS is on the default drivers but is there a fix for this oibaf ? What could be the reason for this?
    Thanks.

    Comment


    • Originally posted by Roza Edalb View Post
      Hi everyone! Does anyone else have problems running wine after the newest updates to the ppa?

      I started getting into this error text [ATTACH]n1405885[/ATTACH] whenever I ran wineboot or winecfg with no further output apart from the timeout message from wineboot until I killed the wineserver and after a couple of OS reinstalls, I discovered that the PPA was the problem by removing it and switching back to the default drivers. It worked and wine ran with no problems apart from the usual fixme texts.

      Afterwards I renabled the ppa, downloaded the drivers and the same errors came back when I ran wine.

      Wine was working perfectly under this ppa until just a couple of days ago until I found out the culprit.

      Currently my OS is on the default drivers but is there a fix for this oibaf ? What could be the reason for this?
      Thanks.
      The issue is tracked here: https://gitlab.freedesktop.org/mesa/mesa/-/issues/9598

      Comment


      • oibaf I see. Well if it's of any importance if you have the required libraries, wine 4.0 still works with your PPA and doesn't have the same error as 8.14.
        Is this fixable? Should we wait for Mesa themselves to fix it first?
        Thanks for the reply by the way.

        Comment


        • Iorn10 oibaf Any progress ?

          Comment


          • oibaf Is there anything I can do to help?

            Comment


            • oibaf Looks like there's even further problems with the ppa...
              I hope it gets fixed soon...
              Also I hope I can help if it's required regarding the wine problem...

              Comment


              • Yeah, for me the oibaf PPA started to work again on around the 17th September. Since then, everything is fine.

                And by the way regarding the upgrade of LLVM please don't jump directly to version 17 (which was finally released some time ago). It looks that regarding Mesa and especially the OpenCL stuff LLVM 16 is more stable. LLVM 17 has at the moment (the last week in September) still some problems and the overall compatibility with clover has worsened while LLVM 16 is okay.

                Comment


                • lorn10 that's great to hear, sorry for bothering you and oibaf back then perhaps I was a little too anxious, because there was no word back on how it was going to be fixed. I unfortunately can't test it I think, because I moved to Arch some time ago. I humbly apologize, I don't know if there is way to test the ppa on Arch though. Also I finally got DRI 3 support! Even though it's on Arch. Now I think the only issue is on how to fix the gallium driver error. Wish me luck!
                  Wishing you peace and happiness!

                  Comment


                  • mesa is now built with llvm-16, but only on ubuntu 23.10/mantic.
                    No plan to use llvm-16 on previous ubuntu (and no need to ask ).

                    Comment


                    • Originally posted by oibaf View Post
                      mesa is now built with llvm-16, but only on ubuntu 23.10/mantic.
                      No plan to use llvm-16 on previous ubuntu (and no need to ask ).

                      Just in case if their will be something wrong with mesa
                      i have stupid question how do i downgrade to the original ubuntu 23.10 pacakges?
                      because if i try to downgrade with this command:

                      Code:
                      $ sudo ppa-purge ppa:oibaf/graphics-drivers
                      [sudo] password for habernir:
                      Updating packages lists
                      PPA to be removed: oibaf graphics-drivers
                      Package revert list generated:
                       libdrm-amdgpu1:amd64/mantic libdrm-amdgpu1:i386/mantic libdrm-common/mantic
                      libdrm-intel1:amd64/mantic libdrm-intel1:i386/mantic
                      libdrm-nouveau2:amd64/mantic libdrm-nouveau2:i386/mantic
                      libdrm-radeon1:amd64/mantic libdrm-radeon1:i386/mantic libdrm2:amd64/mantic
                      libdrm2:i386/mantic libegl-mesa0:amd64/mantic libegl-mesa0:i386/mantic
                      libgbm1:amd64/mantic libgbm1:i386/mantic libgl1-mesa-dev:amd64/mantic
                      libgl1-mesa-dri:amd64/mantic libgl1-mesa-dri:i386/mantic
                      libglapi-mesa:amd64/mantic libglapi-mesa:i386/mantic libglx-mesa0:amd64/mantic
                      libglx-mesa0:i386/mantic libxatracker2:amd64/mantic
                      mesa-opencl-icd:amd64/mantic mesa-va-drivers:amd64/mantic
                      mesa-va-drivers:i386/mantic mesa-vdpau-drivers:amd64/mantic
                      mesa-vdpau-drivers:i386/mantic mesa-vulkan-drivers:amd64/mantic
                      mesa-vulkan-drivers:i386/mantic
                      
                      Updating packages lists
                      Reading package lists... Done
                      Building dependency tree... Done
                      Reading state information... Done
                      libdrm-amdgpu1 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-amdgpu1:i386 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-common is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-intel1 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-intel1:i386 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-nouveau2 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-nouveau2:i386 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-radeon1 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm-radeon1:i386 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm2 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libdrm2:i386 is already the newest version (2.4.116+git2309200500.6abc16~oibaf~m).
                      libegl-mesa0 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libegl-mesa0:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libgbm1 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libgbm1:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libgl1-mesa-dev is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libgl1-mesa-dri is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libgl1-mesa-dri:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libglapi-mesa is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libglapi-mesa:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libglx-mesa0 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libglx-mesa0:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      libxatracker2 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-opencl-icd is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-va-drivers is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-va-drivers:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-vdpau-drivers is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-vdpau-drivers:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-vulkan-drivers is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      mesa-vulkan-drivers:i386 is already the newest version (23.3~git2310090600.1e820a~oibaf~m).
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libdrm-amdgpu1'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libdrm-amdgpu1:i386'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [all]) for 'libdrm-common'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libdrm-intel1'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libdrm-intel1:i386'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libdrm-nouveau2'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libdrm-nouveau2:i386'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libdrm-radeon1'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libdrm-radeon1:i386'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libdrm2'
                      Selected version '2.4.116+git2309200500.6abc16~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libdrm2:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libegl-mesa0'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libegl-mesa0:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libgbm1'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libgbm1:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libgl1-mesa-dev'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libgl1-mesa-dri'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libgl1-mesa-dri:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libglapi-mesa'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libglapi-mesa:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libglx-mesa0'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'libglx-mesa0:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'libxatracker2'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'mesa-opencl-icd'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'mesa-va-drivers'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'mesa-va-drivers:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'mesa-vdpau-drivers'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'mesa-vdpau-drivers:i386'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [amd64]) for 'mesa-vulkan-drivers'
                      Selected version '23.3~git2310090600.1e820a~oibaf~m' (Updated Open Graphics Drivers - since 2011!:23.10/mantic [i386]) for 'mesa-vulkan-drivers:i386'
                      The following packages were automatically installed and are no longer required:
                        libllvm15 libllvm15:i386
                      Use 'sudo apt autoremove' to remove them.
                      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
                      PPA purged successfully
                      ‚Äč
                      you can see that it doesn't downgrade.
                      i know thats its a bug soo do you know easy way to downgrade?
                      thanks , nir
                      Last edited by nir2142; 09 October 2023, 11:29 AM.

                      Comment

                      Working...
                      X