Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gsedej looks like you using an old kernel. For Ubuntu you can get an newer kernel @ http://kernel.ubuntu.com/~kernel-ppa/mainline/

    Comment


    • Oh, thanks. Yes I installed because I am did this on my laptop (RV350) and it works. I will purge it and install your.

      My kernel:
      [email protected]:~$ uname -a
      Linux seraph 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

      (offtopic: how to edit posts?)

      Comment


      • Originally posted by gsedej View Post
        Oh, thanks. Yes I installed because I am did this on my laptop (RV350) and it works. I will purge it and install your.

        My kernel:
        [email protected]:~$ uname -a
        Linux seraph 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

        (offtopic: how to edit posts?)
        That's the latest natty kernel, but that bug may be fixed in a later kernel. Try compiling yourself latest 2.6.39.x (there are no newer kernel on http://kernel.ubuntu.com/~kernel-ppa/mainline/ for natty) or try upgrading to Ubuntu 11.10 (ships a 3.0.x kernel).

        Comment


        • Originally posted by oibaf View Post
          (there are no newer kernel on http://kernel.ubuntu.com/~kernel-ppa/mainline/ for natty) or try upgrading to Ubuntu 11.10 (ships a 3.0.x kernel).
          But the new version work without problems for me. 11.04 with 3.0.

          Comment


          • Originally posted by oibaf View Post
            I updated the package, try in a couple of hour, hopefully it should work (before they were installed in /usr/lib/amd64-linux-gnu/vdpau/).
            Perfect perfect. Thanks.

            Comment


            • /media/sda3$ VDPAU_DRIVER=r600 mplayer -vo xvmc prova.mp2
              mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
              MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
              mplayer: could not connect to socket
              mplayer: No such file or directory
              Failed to open LIRC support. You will not be able to use your remote control.

              Playing prova.mp2.
              AVI file format detected.
              [aviheader] Video stream found, -vid 0
              [aviheader] Audio stream found, -aid 1
              VIDEO: [] 720x480 24bpp 29.970 fps 6995.1 kbps (853.9 kbyte/s)
              Clip info:
              Software: MEncoder SVN-r34173-4.5.2
              Load subtitles in ./
              vo_xvmc: X-Video extension 2.2
              vo_xvmc: X-Video MotionCompensation Extension version 1.1
              ================================================== ========================
              Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
              Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
              ================================================== ========================
              ================================================== ========================
              Opening audio decoder: [pcm] Uncompressed PCM audio decoder
              AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
              Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
              ================================================== ========================
              AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
              Starting playback...
              Unsupported PixelFormat 61
              Unsupported PixelFormat 53
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.
              vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
              Could not find matching colorspace - retrying with -vf scale...
              Opening video filter: [scale]
              The selected video_out device is incompatible with this codec.
              Try appending the scale filter to your filter list,
              e.g. -vf spp,scale instead of -vf spp.

              FATAL: Could not initialize video filters (-vf) or video output (-vo).


              Exiting... (End of file)
              [email protected]:/media/sda3$

              HI, how configure VDPAU_DRIVER=r600 default?

              to play i write VDPAU_DRIVER=r600 mplayer -vo vdpau etc.
              can simply mplayer -vo vdpau etc.
              Thanks

              Comment


              • Originally posted by oibaf View Post
                I updated the package, try in a couple of hour, hopefully it should work (before they were installed in /usr/lib/amd64-linux-gnu/vdpau/).

                Same problem /usr/lib/dri /"only 1 files"

                but, i have only this problem?

                i extract deb and copy the files inside /usr/lib/dri

                :-)
                Last edited by Vincenzov; 10-17-2011, 09:20 AM.

                Comment


                • HI
                  I am the only one having this problem?
                  I am sorry to make you do extra work.
                  Thanks

                  Comment


                  • Originally posted by Vincenzov View Post
                    /media/sda3$ VDPAU_DRIVER=r600 mplayer -vo xvmc prova.mp2
                    You are mixing VDPAU and XvMC here, see the instructions at https://launchpad.net/~oibaf/+archive/graphics-drivers/ for how to use it.

                    Anyway I now also moved xvmc libs into /usr/lib/dri/ (new builds in a couple of hours). This means that multiarch will not be supported (probably not needed anyway...) but it should be a bit simpler to configure (i.e. i386 conf == amd64 conf == instructions on PPA page).

                    Comment


                    • Originally posted by oibaf View Post
                      You are mixing VDPAU and XvMC here, see the instructions at https://launchpad.net/~oibaf/+archive/graphics-drivers/ for how to use it.

                      Anyway I now also moved xvmc libs into /usr/lib/dri/ (new builds in a couple of hours). This means that multiarch will not be supported (probably not needed anyway...) but it should be a bit simpler to configure (i.e. i386 conf == amd64 conf == instructions on PPA page).
                      OK perfect (files).

                      Comment

                      Working...
                      X