Announcement

Collapse
No announcement yet.

Ubuntu 19.10 To 21.10: AMD Zen 2 + Radeon Performance On Linux Over Two Years

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by perpetually high View Post

    Yeah, /proc/config.gz is a config option that you have to turn on. Also, my bad, that was the old command. Keep reusing that one by accident in my history lol. zgrep is a a better way of searching that .gz file (if it existed) instead of gzip piped to grep

    Anyways, you can use the following:

    Code:
    $ grep -i 'cpufreq' /boot/config-$(uname -r)
    That one worked! In the output I see:

    Code:
    CONFIG_X86_PCC_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ_CPB=y
    Vistaus
    Senior Member
    Last edited by Vistaus; 14 October 2021, 08:52 AM.

    Comment


    • #32
      Originally posted by Vistaus View Post

      That one worked! In the output I see:

      Code:
      CONFIG_X86_PCC_CPUFREQ=y
      CONFIG_X86_ACPI_CPUFREQ=y
      CONFIG_X86_ACPI_CPUFREQ_CPB=y
      What happens when you type:

      Code:
      $ modprobe acpi-cpufreq
      Does it say any driver is loaded when you do "./phoronix-test-suite system-info" ?

      Also, try a different kernel. Either the distro default, xanmod, etc and see if you get different behavior. 100% tied to your kernel most likely.

      edit: also after you update-grub on intel_pstate=disable

      Try the following RedHat suggestion:

      Verify the presence of intel_pstate=disable parameter within the /proc/cmdline file:

      # grep intel_pstate /proc/cmdline
      perpetually high
      Senior Member
      Last edited by perpetually high; 14 October 2021, 01:08 PM.

      Comment


      • #33
        Originally posted by perpetually high View Post

        What happens when you type:

        Code:
        $ modprobe acpi-cpufreq
        Does it say any driver is loaded when you do "./phoronix-test-suite system-info" ?

        Also, try a different kernel. Either the distro default, xanmod, etc and see if you get different behavior. 100% tied to your kernel most likely.
        There's no output. I'm using Xanmod and it oughtta work, but I will keep using Xanmod no matter what, so it I can't get schedutil to work on Xanmod, then so be it. Thanks for your help so far.

        Comment

        Working...
        X