Announcement

Collapse
No announcement yet.

Ubuntu 19.10 To 21.10: AMD Zen 2 + Radeon Performance On Linux Over Two Years

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    How the hell is VP9 encoding THAT much slower than h265?! I thought I'd misread the labels at first, but nope: apparently it really is somwhere from 5x to 10x slower, to produce worse results.
    Horrible threading, very unoptimized reference encoder with no real mature alternatives.

    The most promising is SVT-VP9, which can do real-time encoding with comparable (arguably better) quality per bit. However, SVT is mostly focusing on AV1, so the VP9 encoder is an afterthought with a faction of the attention of the AV1 encoder. Still mostly an improvement over the reference encoder, though.

    Comment


    • #22
      Michael
      Phoronix
      Michael Ran into a couple of issues when going to run these tests last night. First one is because I don't have a root user installed, I use "sudo su", so the PTS wouldn't install the missing packages on Arch. No biggie, I installed them manually.

      The 2nd, more important one, was that the npb install script didn't work on my system, ran into an issue on line 64 with "if [ "$CCVERSION" -gt 9 ]; when my GCC is showing 11.1.0. I think it's the decimals. The hacky fix of removing the if/then and just passing CFLAGS="$CFLAGS -fallow-argument-mismatch" worked but then I got this error

      Code:
      cp: cannot create regular file 'NPB3.4/NPB3.4-OMP/config/make.def': No such file or directory
      That file or directory exists

      Not a bug, but line 95 just seems odd doing a cd into my home. I don't think that's the intention.

      Code:
      cd ~/NPB3.4.1/NPB3.4-MPI/
      The 3rd one, more annoying than anything, is it kept telling me I didn't have "vulkan-tools" or "vulkan-icd-loader" when I clearly do so I kept having to skip that.

      And it does scale. Told me an estimated finish time of 19 hours.

      And it keeps telling me I'm using the powersave governor...I know damn well I'm not.

      Code:
      [FONT=monospace][COLOR=#54ff54][B][Performance Tip] The powersave CPU scaling governor is currently in use. It's possible to obtain greater performance if using the performance governor.[/B][/COLOR][/FONT]
      I'm actually using ondemand there.

      EDIT:

      It is the decimals. Changing it to string comparison worked...double brackets and <. Still have the cp issue. I feel like some $PWD's and cat EOF's could be used.

      Code:
      if [[ "$CCVERSION" < 9 ]]; then
      skeevy420
      Senior Member
      Last edited by skeevy420; 12 October 2021, 09:18 AM.

      Comment


      • #23
        Originally posted by skeevy420 View Post

        cpupower on Arch, etc.
        Also on Debian and Deepin. cpufreq-info gives me nothing because it doesn't exist, but cpupower works fine.

        Comment


        • #24
          Originally posted by perpetually high View Post
          Vistaus
          Senior Member
          Vistaus check which scaling governor you're using

          You may be using (if I remember correctly) one of the Intel one's (intel_pstate or intel_cpufreq). Can play around with Intel_pstate=disable and intel_pstate=enable in your GRUB.

          The scaling governor acpi-cpufreq should show all of them. Double check with phoronix-test-suite by Michael Larabel of Phoronix fame:

          Code:
          $ ./phoronix-test-suite system-info|head -n 15
          
          PROCESSOR: Intel Core i5-4670K @ 4.30GHz
          Core Count: 4
          Extensions: SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE
          Cache Size: 6 MB
          Microcode: 0x22
          Core Family: Haswell
          Scaling Driver: acpi-cpufreq performance (Boost: Enabled)
          I also like the package cpufrequtils, which gives you cpufreq-info and cpufreq-set:

          Code:
          $ cpufreq-info|grep -E 'driver|governors'
          driver: acpi-cpufreq
          available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil
          Thanks. So I need to disable pstate. Is that something you would recommend?

          Comment


          • #25
            Originally posted by Vistaus View Post

            Thanks. So I need to disable pstate. Is that something you would recommend?
            I’ve personally been using acpi_cpufreq performance for a while on my Haswell (intel_pstate=disable) and have been very happy.

            Definitely give it a try. Maybe even run a couple of your favorite games or benches to see if you notice a difference, but at very least it will open up all the different choices instead of just powersave and performance

            Comment


            • #26
              Originally posted by perpetually high View Post

              I’ve personally been using acpi_cpufreq performance for a while on my Haswell (intel_pstate=disable) and have been very happy.

              Definitely give it a try. Maybe even run a couple of your favorite games or benches to see if you notice a difference, but at very least it will open up all the different choices instead of just powersave and performance
              Thanks, I'll be sure to give it a try ASAP!

              Comment


              • #27
                Originally posted by perpetually high View Post

                I’ve personally been using acpi_cpufreq performance for a while on my Haswell (intel_pstate=disable) and have been very happy.

                Definitely give it a try. Maybe even run a couple of your favorite games or benches to see if you notice a difference, but at very least it will open up all the different choices instead of just powersave and performance
                How do I properly disable p-state? I added the disable argument to the kernel command line and disabled SpeedStep in the BIOS, but p-state is still loaded after rebooting…

                Comment


                • #28
                  Originally posted by Vistaus View Post

                  How do I properly disable p-state? I added the disable argument to the kernel command line and disabled SpeedStep in the BIOS, but p-state is still loaded after rebooting…
                  It should fallback to acpi driver when you put intel_pstate=disable in GRUB

                  You can check if the kernel has acpi-cpufreq via the following:

                  $ gzip -cd /proc/config.gz | grep -i cpufreq
                  CONFIG_X86_PCC_CPUFREQ=y
                  CONFIG_X86_ACPI_CPUFREQ=y
                  CONFIG_X86_ACPI_CPUFREQ_CPB=y

                  Let me know if you don't get it working, but it shouldn't be too much extra work other than the above..

                  Comment


                  • #29
                    Originally posted by perpetually high View Post

                    It should fallback to acpi driver when you put intel_pstate=disable in GRUB

                    You can check if the kernel has acpi-cpufreq via the following:

                    $ gzip -cd /proc/config.gz | grep -i cpufreq
                    CONFIG_X86_PCC_CPUFREQ=y
                    CONFIG_X86_ACPI_CPUFREQ=y
                    CONFIG_X86_ACPI_CPUFREQ_CPB=y

                    Let me know if you don't get it working, but it shouldn't be too much extra work other than the above..
                    Thanks. It says:

                    Code:
                    ╰─$ gzip -cd /proc/config.gz | grep -i cpufreq
                    gzip: /proc/config.gz: No such file or directory

                    Comment


                    • #30
                      Originally posted by Vistaus View Post

                      Thanks. It says:

                      Code:
                      ╰─$ gzip -cd /proc/config.gz | grep -i cpufreq
                      gzip: /proc/config.gz: No such file or directory
                      Yeah, /proc/config.gz is a config option that you have to turn on. Also, my bad, that was the old command. Keep reusing that one by accident in my history lol. zgrep is a a better way of searching that .gz file (if it existed) instead of gzip piped to grep

                      Anyways, you can use the following:

                      Code:
                      $ grep -i 'cpufreq' /boot/config-$(uname -r)
                      perpetually high
                      Senior Member
                      Last edited by perpetually high; 14 October 2021, 06:17 AM.

                      Comment

                      Working...
                      X