Announcement

Collapse
No announcement yet.

Ubuntu 19.10 To 21.10: AMD Zen 2 + Radeon Performance On Linux Over Two Years

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vistaus
    replied
    Originally posted by perpetually high View Post

    What happens when you type:

    Code:
    $ modprobe acpi-cpufreq
    Does it say any driver is loaded when you do "./phoronix-test-suite system-info" ?

    Also, try a different kernel. Either the distro default, xanmod, etc and see if you get different behavior. 100% tied to your kernel most likely.
    There's no output. I'm using Xanmod and it oughtta work, but I will keep using Xanmod no matter what, so it I can't get schedutil to work on Xanmod, then so be it. Thanks for your help so far.

    Leave a comment:


  • perpetually high
    replied
    Originally posted by Vistaus View Post

    That one worked! In the output I see:

    Code:
    CONFIG_X86_PCC_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ_CPB=y
    What happens when you type:

    Code:
    $ modprobe acpi-cpufreq
    Does it say any driver is loaded when you do "./phoronix-test-suite system-info" ?

    Also, try a different kernel. Either the distro default, xanmod, etc and see if you get different behavior. 100% tied to your kernel most likely.

    edit: also after you update-grub on intel_pstate=disable

    Try the following RedHat suggestion:

    Verify the presence of intel_pstate=disable parameter within the /proc/cmdline file:

    # grep intel_pstate /proc/cmdline
    Last edited by perpetually high; 14 October 2021, 01:08 PM.

    Leave a comment:


  • Vistaus
    replied
    Originally posted by perpetually high View Post

    Yeah, /proc/config.gz is a config option that you have to turn on. Also, my bad, that was the old command. Keep reusing that one by accident in my history lol. zgrep is a a better way of searching that .gz file (if it existed) instead of gzip piped to grep

    Anyways, you can use the following:

    Code:
    $ grep -i 'cpufreq' /boot/config-$(uname -r)
    That one worked! In the output I see:

    Code:
    CONFIG_X86_PCC_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ_CPB=y
    Last edited by Vistaus; 14 October 2021, 08:52 AM.

    Leave a comment:


  • perpetually high
    replied
    Originally posted by Vistaus View Post

    Thanks. It says:

    Code:
    ╰─$ gzip -cd /proc/config.gz | grep -i cpufreq
    gzip: /proc/config.gz: No such file or directory
    Yeah, /proc/config.gz is a config option that you have to turn on. Also, my bad, that was the old command. Keep reusing that one by accident in my history lol. zgrep is a a better way of searching that .gz file (if it existed) instead of gzip piped to grep

    Anyways, you can use the following:

    Code:
    $ grep -i 'cpufreq' /boot/config-$(uname -r)
    Last edited by perpetually high; 14 October 2021, 06:17 AM.

    Leave a comment:


  • Vistaus
    replied
    Originally posted by perpetually high View Post

    It should fallback to acpi driver when you put intel_pstate=disable in GRUB

    You can check if the kernel has acpi-cpufreq via the following:

    $ gzip -cd /proc/config.gz | grep -i cpufreq
    CONFIG_X86_PCC_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ_CPB=y

    Let me know if you don't get it working, but it shouldn't be too much extra work other than the above..
    Thanks. It says:

    Code:
    ╰─$ gzip -cd /proc/config.gz | grep -i cpufreq
    gzip: /proc/config.gz: No such file or directory

    Leave a comment:


  • perpetually high
    replied
    Originally posted by Vistaus View Post

    How do I properly disable p-state? I added the disable argument to the kernel command line and disabled SpeedStep in the BIOS, but p-state is still loaded after rebooting…
    It should fallback to acpi driver when you put intel_pstate=disable in GRUB

    You can check if the kernel has acpi-cpufreq via the following:

    $ gzip -cd /proc/config.gz | grep -i cpufreq
    CONFIG_X86_PCC_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ=y
    CONFIG_X86_ACPI_CPUFREQ_CPB=y

    Let me know if you don't get it working, but it shouldn't be too much extra work other than the above..

    Leave a comment:


  • Vistaus
    replied
    Originally posted by perpetually high View Post

    I’ve personally been using acpi_cpufreq performance for a while on my Haswell (intel_pstate=disable) and have been very happy.

    Definitely give it a try. Maybe even run a couple of your favorite games or benches to see if you notice a difference, but at very least it will open up all the different choices instead of just powersave and performance
    How do I properly disable p-state? I added the disable argument to the kernel command line and disabled SpeedStep in the BIOS, but p-state is still loaded after rebooting…

    Leave a comment:


  • Vistaus
    replied
    Originally posted by perpetually high View Post

    I’ve personally been using acpi_cpufreq performance for a while on my Haswell (intel_pstate=disable) and have been very happy.

    Definitely give it a try. Maybe even run a couple of your favorite games or benches to see if you notice a difference, but at very least it will open up all the different choices instead of just powersave and performance
    Thanks, I'll be sure to give it a try ASAP!

    Leave a comment:


  • perpetually high
    replied
    Originally posted by Vistaus View Post

    Thanks. So I need to disable pstate. Is that something you would recommend?
    I’ve personally been using acpi_cpufreq performance for a while on my Haswell (intel_pstate=disable) and have been very happy.

    Definitely give it a try. Maybe even run a couple of your favorite games or benches to see if you notice a difference, but at very least it will open up all the different choices instead of just powersave and performance

    Leave a comment:


  • Vistaus
    replied
    Originally posted by perpetually high View Post
    Vistaus check which scaling governor you're using

    You may be using (if I remember correctly) one of the Intel one's (intel_pstate or intel_cpufreq). Can play around with Intel_pstate=disable and intel_pstate=enable in your GRUB.

    The scaling governor acpi-cpufreq should show all of them. Double check with phoronix-test-suite by Michael Larabel of Phoronix fame:

    Code:
    $ ./phoronix-test-suite system-info|head -n 15
    
    PROCESSOR: Intel Core i5-4670K @ 4.30GHz
    Core Count: 4
    Extensions: SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE
    Cache Size: 6 MB
    Microcode: 0x22
    Core Family: Haswell
    Scaling Driver: acpi-cpufreq performance (Boost: Enabled)
    I also like the package cpufrequtils, which gives you cpufreq-info and cpufreq-set:

    Code:
    $ cpufreq-info|grep -E 'driver|governors'
    driver: acpi-cpufreq
    available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil
    Thanks. So I need to disable pstate. Is that something you would recommend?

    Leave a comment:

Working...
X