Announcement

Collapse
No announcement yet.

High Resolution Scroll Wheel Support Being Worked On For Wayland

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I switched to Wayland again yesterday to check progress on Sway WM. Sway is really good but there are some big quirks depending on software you need.

    X based software like scrot, gcolor3 have to be replaced by grim and other counterparts, wine app dialogs glitch out on resize and app menus don't even show up :\, clipboard is inconcsistent but maybe that may just mean urxvt is X only, I tried to replace with Termite but there was a font horizontal spacing issue.

    Anyways, it's encouraging to see developments and progress but for some workflows it really is going to have some show stoppers for a while that need to be worked out.

    Comment


    • #12
      I don't even understand why would one need high resolution scroll wheel.

      Comment


      • #13
        Originally posted by aaahaaap View Post

        Apple's touchpad works fine/like a touchpad.
        I haven't tried the current model yet though, only the previous one.
        I can confirm that the 1st generation Apple external trackpad works great out-of-the-box on Linux. Using the 2-finger scroll gesture makes you really appreciate Wayland.

        The 2nd gen is supposed to be supported as well starting with Linux 5.0: https://www.phoronix.com/scan.php?pa...-2-Linux-Queue

        Comment


        • #14
          Originally posted by blueweb View Post
          Thanks for the reminder about solaar! I have it installed but haven't launched it in a while. I'm also on Fedora 29 and using a Logitech M720.

          Was the mouse wheel always slow after updating to kernel 5.0? For me it was normal and then suddenly becomes slow... not quite sure what the cause is. Maybe waking up after power saving idling.

          Even in kernel 4.20, solaar shows the "Wheel Resolution" option. "On" makes a big difference in scrolling speed/smoothness. Not sure if that option was there before. "Off" is the normal behavior I'm used to. The slow scrolling in 5.0 is far slower than the "Off" setting.

          I'll look into these settings next time I boot into 5.0. Thanks again!
          Kernel 4.20 - mouse wheel was always working OK - no sleep/unsleep/reboot/USB re-connect/etc. needed.

          The slowness started immediately after update and reboot to kernel 5.0 (but there was plenty of other packages also updated). I did not try PC sleep/USB reconnect/etc. - I immediately started solaar and changed option "Wheel Resolution" to "On" and it solved issue permanently.

          Now mouse wheel is working always OK - also after PC sleep/wake up or fresh reboot (no need to start solaar manually).

          Comment


          • #15
            Originally posted by amehaye View Post

            I can confirm that the 1st generation Apple external trackpad works great out-of-the-box on Linux. Using the 2-finger scroll gesture makes you really appreciate Wayland.

            The 2nd gen is supposed to be supported as well starting with Linux 5.0: https://www.phoronix.com/scan.php?pa...-2-Linux-Queue
            I didn't even think of using Apple's touchpad. It looks like it would work in Linux. The only problem is that the desktop is where I occasionally boot into Windows, and it looks like you have to install some 3rd party driver to make it work there.

            Comment


            • #16
              Originally posted by Chugworth View Post
              So high resolution scrolling still hasn't arrived in user-space yet? That's good to know. I was considering buying one of those high resolution mice, but I don't really like the choices. However, it appears that the high resolution support is hard-coded into the kernel on a per-device basis, so it might not be a good idea to wait for the release of some new mouse.

              When you move from using Linux on a laptop to using Linux on a desktop, the scrollwheel is just awful. Especially without autoscroll. I'm really hoping that high resolution scrolling will fix that.
              I have been using it for years. It requires solaar and manually configuring xinput. The problem is making it automatic.

              Comment


              • #17
                Originally posted by Danniello View Post

                Kernel 4.20 - mouse wheel was always working OK - no sleep/unsleep/reboot/USB re-connect/etc. needed.

                The slowness started immediately after update and reboot to kernel 5.0 (but there was plenty of other packages also updated). I did not try PC sleep/USB reconnect/etc. - I immediately started solaar and changed option "Wheel Resolution" to "On" and it solved issue permanently.

                Now mouse wheel is working always OK - also after PC sleep/wake up or fresh reboot (no need to start solaar manually).
                In kernel 4.20, Wheel Resolution = OFF was normal behavior while ON was very sensitive/fast. I kept it OFF. Since then the slowness hasn't happened even in kernel 5.0.

                Now in kernel 5.0 I took a look in solaar and Wheel Resolution was still OFF. Turning it ON maintained normal behavior, but setting it OFF results in the slowness! So now I'm keeping it ON and I'll keep using/upgrading kernel 5.0.

                I suspect that the settings shown in solaar have flipped/inverted somehow. For the Logitech k830 keyboard, solaar has the option to "Swap Fx functions" which is OFF by default. i.e. use the Function key to access the secondary F1-F12 keys while media keys are accessed directly, or "swap" = ON so the media keys are secondary with the Function key and F1-F12 are primary. Contrary to before, now with Swap = OFF, the behavior is inverted with the F keys being primary.

                My guess is that in kernel 5.0, solaar's settings have inverted and that there is a bug with the high resolution scrolling feature. Wheel Resolution = ON in kernel 5.0 is just the same behavior as always. But ON in kernel 4.20 was very noticeably smoother. Not sure how that could be experienced if the feature only showed up in kernel 5.0.

                Comment


                • #18
                  Spoke too soon. The slow scrolling returned in kernel 5.0 with Wheel Resolution having been set to ON. But launching solaar restored normal scrolling, without changing settings.

                  Danniello Do you keep solaar running? So far the slow scrolling hasn't happened while it runs.

                  Comment


                  • #19
                    Originally posted by blueweb View Post
                    Spoke too soon. The slow scrolling returned in kernel 5.0 with Wheel Resolution having been set to ON. But launching solaar restored normal scrolling, without changing settings.

                    Danniello Do you keep solaar running? So far the slow scrolling hasn't happened while it runs.
                    I do not start solaar manually, but yes - solaar is visible in gnome-system-monitor.

                    It looks like solaar is starting automatically:

                    ```
                    $ locate solaar
                    /etc/xdg/autostart/solaar.desktop
                    [...]
                    ```

                    Comment


                    • #20
                      Originally posted by Danniello View Post

                      I do not start solaar manually, but yes - solaar is visible in gnome-system-monitor.

                      It looks like solaar is starting automatically:

                      ```
                      $ locate solaar
                      /etc/xdg/autostart/solaar.desktop
                      [...]
                      ```
                      Ok, so you have the solaar process running. With that scenario, I have yet to encounter the slow scrolling problem.

                      I still think there may be an issue, with the inverted settings in solaar being a clue.

                      Btw, I think startup applications are controlled or overridden from files in `~/.config/autostart`, at least in MATE. If I uncheck solaar from Startup Applications, `~/.config/autostart/solaar.desktop` appears which has a line that sets autostarting it to false. Checking solaar to autostart makes that file disappear. So the existence of `/etc/xdg/autostart/solaar.desktop` or equivalent doesn't tell the whole story.

                      Comment

                      Working...
                      X