Announcement

Collapse
No announcement yet.

High Resolution Scroll Wheel Support Being Worked On For Wayland

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • High Resolution Scroll Wheel Support Being Worked On For Wayland

    Phoronix: High Resolution Scroll Wheel Support Being Worked On For Wayland

    The high resolution scrolling support in Linux 5.0 has been a headache to say the least. After being ejected from Linux 4.20 following early fall-out, the support was merged for Linux 5.0 but the user-space support has yet to stabilize...

    http://www.phoronix.com/scan.php?pag...-Res-Scrolling

  • retardxfce
    replied
    Originally posted by debianxfce View Post

    This wayland feature will not work fine after 10 years of development based on the history of wayland. This is why only IBM believers takes IBM-wayland seriously.
    Wayland compositors such as Mutter and Kwin have not had 10 years of development. XFeces has been in development for more than 20 years and it is still an unfinished piece of crap, this is why nobody uses XFeces or takes it seriously.
    Last edited by retardxfce; 05-16-2019, 04:12 PM.

    Leave a comment:


  • retardxfce
    replied
    XFCE has had this feature for at least 20 years. This is why nobody takes IBM-wayland seriously.

    Leave a comment:


  • blueweb
    replied
    Originally posted by intelfx View Post

    No. I assume it's all due to a disconnect between what hardware sends and how kernel interprets what the hardware sends. Specifically, kernels 4.20 and earlier (lacking high-resolution scrolling support) assumed that Logitech mice send low-resolution events, and kernels 5.0 and later (having gained the high-resolution scrolling support) now assume that Logitech mice only send high-resolution events. At the same time, the switches in Solaar control what the hardware will actually send.

    I suppose this is something to fix in the kernel, so that it will switch Logitech mice to high-resolution scrolling itself, without any help from 3rd party userspace.
    Plausible. Though it seems strange to assume something and then change that assumption on a later kernel.

    Even with Solaar running, sometimes the mouse gets "stuck" in slow scrolling mode, and after a few seconds scrolling becomes normal again. Without Solaar, it would stay in the slow mode until turning the device off/on. I hope these kinks get ironed out.

    Leave a comment:


  • rbmorse
    replied
    Originally posted by aaahaaap View Post

    Apple's touchpad works fine/like a touchpad.
    I haven't tried the current model yet though, only the previous one.
    One and two finger functions work well with the Apple Magic Touchpad II on the 5.x kernel. Still no three or four finger functions or pinch resizing, either, at least out of the box. I haven't had the inclination to seek out the docs to see if they might be something the user could enable and configure.

    The current version default for the threshold of tap recognition is a little high for my liking, but changing the AtttrPressureRange= setting in /etc/libinput/local-overrides.quirks to 4:0 fixed that.

    Leave a comment:


  • intelfx
    replied
    Originally posted by blueweb View Post
    In kernel 4.20, Wheel Resolution = OFF was normal behavior while ON was very sensitive/fast. I kept it OFF. Since then the slowness hasn't happened even in kernel 5.0.

    My guess is that in kernel 5.0, solaar's settings have inverted and that there is a bug with the high resolution scrolling feature. Wheel Resolution = ON in kernel 5.0 is just the same behavior as always. But ON in kernel 4.20 was very noticeably smoother. Not sure how that could be experienced if the feature only showed up in kernel 5.0.
    No. I assume it's all due to a disconnect between what hardware sends and how kernel interprets what the hardware sends. Specifically, kernels 4.20 and earlier (lacking high-resolution scrolling support) assumed that Logitech mice send low-resolution events, and kernels 5.0 and later (having gained the high-resolution scrolling support) now assume that Logitech mice only send high-resolution events. At the same time, the switches in Solaar control what the hardware will actually send.

    I suppose this is something to fix in the kernel, so that it will switch Logitech mice to high-resolution scrolling itself, without any help from 3rd party userspace.

    Leave a comment:


  • blueweb
    replied
    Originally posted by Danniello View Post

    I do not start solaar manually, but yes - solaar is visible in gnome-system-monitor.

    It looks like solaar is starting automatically:

    ```
    $ locate solaar
    /etc/xdg/autostart/solaar.desktop
    [...]
    ```
    Ok, so you have the solaar process running. With that scenario, I have yet to encounter the slow scrolling problem.

    I still think there may be an issue, with the inverted settings in solaar being a clue.

    Btw, I think startup applications are controlled or overridden from files in `~/.config/autostart`, at least in MATE. If I uncheck solaar from Startup Applications, `~/.config/autostart/solaar.desktop` appears which has a line that sets autostarting it to false. Checking solaar to autostart makes that file disappear. So the existence of `/etc/xdg/autostart/solaar.desktop` or equivalent doesn't tell the whole story.

    Leave a comment:


  • Danniello
    replied
    Originally posted by blueweb View Post
    Spoke too soon. The slow scrolling returned in kernel 5.0 with Wheel Resolution having been set to ON. But launching solaar restored normal scrolling, without changing settings.

    Danniello Do you keep solaar running? So far the slow scrolling hasn't happened while it runs.
    I do not start solaar manually, but yes - solaar is visible in gnome-system-monitor.

    It looks like solaar is starting automatically:

    ```
    $ locate solaar
    /etc/xdg/autostart/solaar.desktop
    [...]
    ```

    Leave a comment:


  • blueweb
    replied
    Spoke too soon. The slow scrolling returned in kernel 5.0 with Wheel Resolution having been set to ON. But launching solaar restored normal scrolling, without changing settings.

    Danniello Do you keep solaar running? So far the slow scrolling hasn't happened while it runs.

    Leave a comment:


  • blueweb
    replied
    Originally posted by Danniello View Post

    Kernel 4.20 - mouse wheel was always working OK - no sleep/unsleep/reboot/USB re-connect/etc. needed.

    The slowness started immediately after update and reboot to kernel 5.0 (but there was plenty of other packages also updated). I did not try PC sleep/USB reconnect/etc. - I immediately started solaar and changed option "Wheel Resolution" to "On" and it solved issue permanently.

    Now mouse wheel is working always OK - also after PC sleep/wake up or fresh reboot (no need to start solaar manually).
    In kernel 4.20, Wheel Resolution = OFF was normal behavior while ON was very sensitive/fast. I kept it OFF. Since then the slowness hasn't happened even in kernel 5.0.

    Now in kernel 5.0 I took a look in solaar and Wheel Resolution was still OFF. Turning it ON maintained normal behavior, but setting it OFF results in the slowness! So now I'm keeping it ON and I'll keep using/upgrading kernel 5.0.

    I suspect that the settings shown in solaar have flipped/inverted somehow. For the Logitech k830 keyboard, solaar has the option to "Swap Fx functions" which is OFF by default. i.e. use the Function key to access the secondary F1-F12 keys while media keys are accessed directly, or "swap" = ON so the media keys are secondary with the Function key and F1-F12 are primary. Contrary to before, now with Swap = OFF, the behavior is inverted with the F keys being primary.

    My guess is that in kernel 5.0, solaar's settings have inverted and that there is a bug with the high resolution scrolling feature. Wheel Resolution = ON in kernel 5.0 is just the same behavior as always. But ON in kernel 4.20 was very noticeably smoother. Not sure how that could be experienced if the feature only showed up in kernel 5.0.

    Leave a comment:

Working...
X