Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Fiora View Post
    hey,

    my card is i5 3230, intel hd 4000
    ubuntu 13.04

    after a lot of test, with all i could find with google, I found your page, waited for 13.04 support.
    And I'm sad to say, for what i need it's not working, I might be missing something, but for now I can't launch my game.

    The game i try to play is everquest2 through wine 1.5.31
    Game is launching but totally unplayable cause of graphic.

    Any idea ? anything i could change to make it work ?
    Read the section about "problems" on the PPA page or the first post of this thread.

    Comment


    • libg3dvl-mesa with hardware-accelerated adobe-flash

      Thank you for your work providing this ppa.

      With ATI 4200 HD on a M3A785GMH/128M mainboard and Ubuntu 13.04 Raring, libg3dvl-mesa installed, I notice random pop-outs to the right or underneath (depending on the video) when I watch flash videos with hardware-acceleration enabled in the flash control panel. This happens embedded, windowed on a youtube page and fullscreen as well. When I disable the acceleration the video stays in its aspect-ratio, but is barely watchable in fullscreen (makes sense). When enabled, it takes a few seconds for the acceleration to kick in watching fullscreen videos, the difference is positively huge but again barely watchable with these random pop-outs. Is this something you can work on, or provide a solution for?

      Thanks!

      Comment


      • Originally posted by jefdebruges View Post
        Thank you for your work providing this ppa.

        With ATI 4200 HD on a M3A785GMH/128M mainboard and Ubuntu 13.04 Raring, libg3dvl-mesa installed, I notice random pop-outs to the right or underneath (depending on the video) when I watch flash videos with hardware-acceleration enabled in the flash control panel. This happens embedded, windowed on a youtube page and fullscreen as well. When I disable the acceleration the video stays in its aspect-ratio, but is barely watchable in fullscreen (makes sense). When enabled, it takes a few seconds for the acceleration to kick in watching fullscreen videos, the difference is positively huge but again barely watchable with these random pop-outs. Is this something you can work on, or provide a solution for?

        Thanks!
        Report it here: https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa

        Comment


        • I am having some issues with the Champions of Regnum Game....

          I am using Linux Mint 15 and out of the box everything was working fine... but you know as a linux user wanted to have the latest drivers ...

          So I first have installed the latest xorg/edgers/ppa ati graphic drivers , every game is running ok + playonlinux except Champions of Regnum which it doesnt display any characters in game , it displays them as invisble chars ><

          I have removed the xord/edgers ppa and installed oibaf's ppa but the same thing as xorg edgers......

          I have an ATI HIS 5970x2 2GB DDR5

          Any solution to this?
          Last edited by wolfyrion; 06-13-2013, 01:51 AM.

          Comment


          • Hmm? Binutils update? From this repo? Why?

            Hi! It has come to my attention that this repo attempts to provide newer Binutils - version 2.23.52.20130611-1ubuntu2~r~gd

            Binutils are system-wide thing, it don't have to be touched without reasons as it could be used by other people to build some software. I have no idea why "uptated drivers" should anyhow mess with this part of system. Are there any good reasons to do so? Basically, attempt to update such packages seems to be BAD idea unless there is some uber-reason to do so. And if there is such reason, you should put a BIG RED WARNING about this behavior, IMHO.

            Comment


            • Raring mesa packages now built with LLVM 3.3

              I uploaded new raring mesa packages now built using LLVM 3.3. Quantal and precise still use LLVM 3.2 and I plan to remove them someday.

              Updated binutils (just a straight backport from saucy) is needed to build llvm 3.3 (also backported from debian), see here.
              Last edited by oibaf; 06-13-2013, 07:28 AM.

              Comment


              • Originally posted by wolfyrion View Post
                I am having some issues with the Champions of Regnum Game....
                ...
                Any solution to this?
                Read my post previous to yours .
                Last edited by oibaf; 06-13-2013, 07:28 AM.

                Comment


                • Problem updating drivers

                  Hi,
                  i'm trying to update the drivers for my Intel HD 4000, as the external monitor on my laptop doesn't work properly (I'm only allowed 1024x768 or 800x600 resolutions).

                  I followed this instructions in this post:
                  sudo add-apt-repository ppaibaf/graphics-drivers
                  sudo apt-get update
                  sudo apt-get dist-upgrade
                  However, it doesn't seem to have done anything, as "glxinfo | grep OpenGL" gave the same results before and after.
                  ~$ glxinfo | grep OpenGL
                  OpenGL vendor string: Intel Open Source Technology Center
                  OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
                  OpenGL version string: 3.0 Mesa 9.0.3
                  OpenGL shading language version string: 1.30
                  OpenGL extensions:
                  Am I missing something?

                  Comment


                  • now works with radeon 7000???. Thanks

                    Comment


                    • Originally posted by adamf321 View Post
                      Hi,
                      i'm trying to update the drivers for my Intel HD 4000, as the external monitor on my laptop doesn't work properly (I'm only allowed 1024x768 or 800x600 resolutions).

                      I followed this instructions in this post:


                      However, it doesn't seem to have done anything, as "glxinfo | grep OpenGL" gave the same results before and after.


                      Am I missing something?
                      You are using quantal? You still appears to be using mesa 9.0.3 which is quantal version and not the PPA one. Check you PPA configuration.

                      Comment

                      Working...
                      X