No announcement yet.

"Ask ATI" dev thread

  • Filter
  • Time
  • Show
Clear All
new posts

  • Dear ATI-devs,

    do I have to start my post with "Dear ATI-devs"?
    No, my question ist regarding your HD video acceleration library and when it is usable under Linux.
    I've build a HTPC with a 790GX board and run XBMC. For months now I have to read in the XBMC forums that everybody jumps on the Atom+Ion platform where high definition video with Nvidias VDPAU works.
    What is AMD waiting for?



    • Originally posted by rafi View Post
      Dear AT Devs

      Some weeks ago you released an update, the catalyst 9.3.1, for your legacy products, the radeon Dx9, that run on windows xp. Ubuntu is one of the distributions you officially support, and Ubuntu 8.04 is a LTS. Since it's long term support, is it reasonable to hope for a 9.3.1 update on linux?

      Also, about the power management in the open source drivers (radeon & radeonhd): which technology is concerned by these implementaions? Is it Powerplay from the mobility cards (three states, no other clock/voltage available) or is it the dynamic clock you introduced on the radeon HD3800 (which is also named Powerplay)?
      I am not an ATi dev, but wasn't it the case that Windows drivers are only updated for legacy products to keep WHQL certification for old products? Not sure about this, perhaps the AMD/ATi devs can provide some insight?


      • HD 4890 Debian testing installation help proprietary drivers

        Dear Devs

        I've been trying to install my brand new HD 4890 in Debian testing AMD64 without success. Can anybody point me to anything that I'm missing?

        After googling a lot, I've tried a lot of paths to install the proprietary drivers (free drivers are not available yet). With each way, I've come to almost the same results: at minimum no X at all, at most, 1920x1200 resolution with no 2D or 3D acceleration (2D is in fact way slower than the default xorg VESA driver).

        1) I've tried to install the debian package fglrx 9.2. There is a broken package (libc6-i386 requires fglrx-glx-ia32 9-5). If I ignore it, instead of only not having 3D, I end up with no acceleration at all.

        2) I've tried to install the sid (unstable) 9-8-1 fglrx version. Because lots of unstable code (xorg etc) would be installed I tried to just manually recompile the packages to change some dependencies. Could'nt install because of dependencies so (step 3)

        3) I've got the 9-8-1 backported code - thanks for the guys at debian for that (all dependencies correctly adjusted) - and installed that version. I ended up with no 2D and no 3D acceleration (it seems worse than pure VESA code).

        4) Again I removed everything and tried harder at google. I've read that the kernel 2.6.30 was not supported by earlier catalyst versions, so I've concentraded on 9.8. First I've installed it directly, without generating deb packages. I got no error messages during installation. After regenerating xorg.conf, I finally had the same results: no acceleration at all.

        Some info:

        My system:
        Asus P6T motherboard
        Intel i7 920
        6GB RAM
        Seagate sata HD.
        XFX Radeon HD 4890 1GB

        My kernel is debian stock (testing):
        2.6.30-1-amd64 #1 SMP x86_64 GNU/Linux

        It seems that the kernel module was correctly compiled and installed:
        $ lsmod |grep fglrx
        fglrx 2293612 0

        The Xorg.0.log file shows some fglrx messages and errors, though. I couldn't figure out what to enable or disable to get it to work. Could anyone post some clues on what to do/try? Maybe a step-by-step guide? (example: install this, run that, etc).

        During some of those attempts, I've used module-assistant to compile and load the kernel module. I always try to make as sure as possible to be in a clean state before trying again (bringing the system back to a pure debian testing state, removing ati directories, files, etc).

        I'm almost hairless now. My brand new GPU that was supposed to be very fast is worse than my FX5200 nvidia GPU from eons ago, in my old Atlhon XP system! I have no video, no 2d Acceleration and absolutely no 3D. I can't barely move a window on the screen.

        Thanks in advance,


        Xorg log, (relevant fglrx lines)


        LoadModule: "fglrx"
        (II) Loading /usr/lib/xorg/modules/drivers//
        (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        (II) fglrx(0): pEnt->device->identifier=0x1ee4270
        (II) fglrx(0): === [atiddxPreInit] === begin
        (II) fglrx(0): PCI bus 2 card 0 func 0
        (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
        (--) fglrx(0): Chipset: "ATI Radeon HD 4800 Series " (Chipset = 0x9460)
        (WW) fglrx(0): Hasn't establisted DRM connection
        (WW) fglrx(0): No DRM connection for driver fglrx.
        (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
        (II) fglrx(0): driver needs 7.1.x.y with x.y >= 0.0
        (WW) fglrx(0): could not detect X server version (query_status=-1)
        (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
        (WW) fglrx(0): ***********************************************
        (WW) fglrx(0): * DRI initialization failed! *
        (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
        (WW) fglrx(0): * 2D acceleraton available (MMIO) *
        (WW) fglrx(0): * no 3D acceleration available *
        (WW) fglrx(0): ********************************************* *
        (WW) fglrx(0): Failed to set up write-combining range (0xd0000000,0x10000000)
        (WW) fglrx(0): Textured Video not supported without DRI enabled.
        (II) fglrx(0): GLESX enableFlags = 78
        (II) fglrx(0): Acceleration enabled
        (EE) fglrx(0): XMM failed to open CMMQS connection.
        (II) fglrx(0): XMM failed to initialize!
        (II) fglrx(0): Enable composite support successfully
        (**) fglrx(0): Using software cursor


        • Can you start a new thread on this and pastebin xorg log and dmesg output ? You're not getting acceleration because the kernel module is not loading.
          Test signature


          • What bridgman said + the /usr/share/ati/fglrx-install.log could also be useful.


            • I'd like to know if there is some hope for a FreeBSD ATi driver.

              Is it at least "planned"?


              • @soeiro

                have you tried smxi?


                • Originally posted by CNCFarraday View Post
                  I'd like to know if there is some hope for a FreeBSD ATi driver.

                  Is it at least "planned"?
                  Does planned cover "idea was thought over and dropped"? Seriously though, FreeBSD is getting ports of the Linux open drivers, I'd have my hopes up on that front.
                  disclaimer: I'm in no way affiliated with ATi. :3


                  • Originally posted by CNCFarraday View Post
                    I'd like to know if there is some hope for a FreeBSD ATi driver. Is it at least "planned"?
                    There are no plans to port the Catalyst driver to FreeBSD, but rnoland has been really busy porting the latest open source driver code to FreeBSD, including 3d support for 6xx/7xx, and those drivers are going to keep evolving pretty fast.
                    Test signature


                    • Thank you.

                      I've been following the open source driver since the started again with the new documentation released by AMD/ATi. I have no doubt that next year we'll have a good open source ATi driver for *BSD too, albeit only 2D and basic 3D.