Announcement

Collapse
No announcement yet.

ATI R600g Gains Mip-Map, Face Culling Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Well, found a bug, hope Glisse reads this thread sometimes

    Comment


    • Originally posted by netkas View Post
      Well, found a bug, hope Glisse reads this thread sometimes
      Seems to be broken in classic Mesa as well. *Eek*

      Comment


      • Yeah, right now I think something like 96% of the 3D driver is common Mesa code and 4% is classic HW driver for whatever HW you are running.

        After the move to Gallium3D I guess that will become more like 98% common and 2% hardware-specific

        Comment


        • Actually it looks a bit odd with Software Rasterizer as well. Could someone check whether or not geartrain polygons are valid? (edges not allowed to intersect, region must be convex) If some are invalid, it would explain strange rendering. I'm not experienced enough to just see validity by scanning through the code.

          Comment


          • Originally posted by netkas View Post
            Well, found a bug, hope Glisse reads this thread sometimes
            This is most probably not a driver bug. swrast, llvmpipe, softpipe, r300c, and r300g render it the same as is on your screenshot.

            Comment


            • Originally posted by marek View Post
              This is most probably not a driver bug. swrast, llvmpipe, softpipe, r300c, and r300g render it the same as is on your screenshot.
              My eyes claimed swrast rendering differed a bit but was still incorrect. Hence why I started wondering about invalid polygons since rendering is undefined there and might even be unexpected in a different way in all drivers.

              Comment


              • Yeah, we are damned lucky that the hardware doesn't lock up (that's what usually "undefined" means).

                Comment


                • somebody need to check it on nvidia linux drivers.

                  Comment


                  • Originally posted by netkas View Post
                    somebody need to check it on nvidia linux drivers.
                    This would prove nothing. Someone (more competent in OpenGL than I) needs to read geartrain.c and check the vertices.

                    Comment


                    • (and otherwise too, vertices were just my first guess)
                      ps. I hate the one-minute edit window.

                      Comment

                      Working...
                      X