Announcement

Collapse
No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by gbeauche View Post
    It's working for me but I am using MPlayer 2009/12/07 and fglrx 8.69. Not tried with older versions yet.
    Hm, I still see the issue with mplayer-vaapi-20091209. Perhaps you don't see overscan with vaapi output due to a newer fglrx driver. I'm using the 9-10 release (8.661), and my understanding is that 9-11 release (8.671) is incompatible with mplayer-vaapi. Is the 8.69 driver expected for public release in January '10? Any links to beta versions would be much appreciated.

    Comment


    • Well i dislike that the 1209 update was done too early, even on the same day it was not possible to use the -1 script which calls "svn up" to get uptodate code - the shortest time till a snapshot borke: the same day Basically it is not really worth the time to wait for updated drivers - they are not supported for endusers anyway as everybody from ati wants to tell you. You can feel lucky that you can use it as it. Just buy something else...

      Comment


      • cant build mplayer

        I can't build mplayer with kano script. I get some errors like this : undefined reference to swapGlBuffers. I did build mplayer with that script cca month ago, what had changed?

        Comment


        • Thats because it broke the same day the last mplayer vaapi update was released. Use the script without svn up. Added Ubuntu detection btw. to increase the version in that case that it would not be in d-u everytime.

          http://kanotix.com/files/fix/mplayer-vaapi-latest.txt

          Comment


          • thank you.........

            Comment


            • xvba_decode.c error

              Dear Vighy

              Thank you for reading .
              I have same question with you.

              The Mplayer File download with
              http://www.splitted-desktop.com/~gbe...9-FULL.tar.bz2

              That is mplayer report :

              How can i help you to debug .

              Best Regards

              seal



              [email protected]:~/mplayer-vaapi-20091209/mplayer-vaapi$ ./mplayer -vo
              vaapi -va vaapi '/home/seal/Downloads/The Simpsons Movie -
              Trailer.mp4'
              MPlayer SVN-r29978-4.4.1 (C) 2000-2009 MPlayer Team
              mplayer: could not connect to socket
              mplayer: No such file or directory
              Failed to open LIRC support. You will not be able to use your remote control.

              Playing /home/seal/Downloads/The Simpsons Movie - Trailer.mp4.
              libavformat file format detected.
              [lavf] Video stream found, -vid 0
              [lavf] Audio stream found, -aid 1
              VIDEO: [H264] 1280x544 24bpp 23.976 fps 4221.4 kbps (515.3 kbyte/s)
              Clip info:
              major_brand: isom
              minor_version: 1
              compatible_brands: isomavc1
              libva: libva version 0.31.0-sds4
              libva: va_getDriverName() returns 0
              libva: Trying to open /usr/lib/va/drivers/fglrx_drv_video.so
              libva: va_openDriver() returns 0
              ================================================== ========================
              Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
              [VD_FFMPEG] VA API accelerated codec.
              Unsupported PixelFormat -1
              Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
              ================================================== ========================
              ================================================== ========================
              Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
              AUDIO: 48000 Hz, 2 ch, s16le, 64.1 kbit/4.17% (ratio: 8016->192000)
              Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
              ================================================== ========================
              [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file
              or directory
              AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
              Starting playback...
              [VD_FFMPEG] Trying pixfmt=0.
              Unsupported PixelFormat -1
              Movie-Aspect is undefined - no prescaling applied.
              VO: [vaapi] 1280x544 => 1280x544 H.264 VA API Acceleration
              [vo_vaapi] Using 1:1 VA surface mapping
              [VD_FFMPEG] XVMC-accelerated MPEG-2.
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              [vo_vaapi] vaPutSurface(): the requested function is not implemented
              xvba_video: error: Assertion failed in file xvba_decode.c at line 774


              MPlayer interrupted by signal 6 in module: decode video
              - MPlayer crashed. This shouldn't happen.
              It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
              gcc version. If you think it's MPlayer's fault, please read
              DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
              won't help unless you provide this information when reporting a possible bug.










              Originally posted by Vighy View Post
              no they don't!

              mplayer crashes 1-2 sec after launched.
              And while trying to take a snapshot of what shows in that window for a while (because it shows something scrambled) it crashed my Xorg

              the error it gives is:
              Code:
              xvba_video: XVBA_CreateDecode(): status 2
              [vo_vaapi] vaCopySurfaceGLX(): unknown libva error
              xvba_video: XVBA_CreateDecode(): status 2
              [vo_vaapi] vaCopySurfaceGLX(): unknown libva error
              xvba_video: error: Assertion failed in file xvba_decode.c at line 774
              vainfo (just in case):
              Code:
              vainfo 
              libva: libva version 0.31.0-sds3
              libva: va_getDriverName() returns 0
              libva: Trying to open /usr/lib64/va/drivers/fglrx_drv_video.so
              libva: va_openDriver() returns 0
              vainfo: VA API version: 0.31
              vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA API - 0.5.1
              vainfo: Supported profile and entrypoints
                    VAProfileMPEG2Simple            :	VAEntrypointIDCT
                    VAProfileMPEG2Main              :	VAEntrypointIDCT
                    VAProfileH264High               :	VAEntrypointVLD
                    VAProfileVC1Advanced            :	VAEntrypointVLD
              and libva is the last (4 nov 2009) 0.31.0+1-sds7

              if you need something, just tell me.

              Comment


              • you have to use

                mplayer -va vaapi -vo vaapi:gl movie

                What you tried works only with mpeg2 on intel g4x or with nvidia (when the wrapper works fine for the tested file). The ONLY driver to use is 9-10 FINAL.

                Comment


                • Originally posted by Kano View Post
                  Thats because it broke the same day the last mplayer vaapi update was released. Use the script without svn up.
                  Nothing broke. What I release is what was tested. If you really want to svn update, be prepared to fix any problem with API changes in MPlayer or whatever and don't complain or wait for the next release... It's Open Source, you know.

                  Comment


                  • New version of xvba released (0.6.0):

                    http://www.splitted-desktop.com/~gbeauchesne/xvba-video/

                    No need to use gl as output anymore.

                    Comment


                    • Just to be sure.
                      Both fglrx 9.10 (inluded in Ubuntu) and fglrc 9.12 hotfix works with xvba?

                      Comment

                      Working...
                      X