No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Qaridarium

    R900 will fix this stupid people problem.
    because you will stop posting?


    • Originally posted by d2kx View Post
      Having a great mixture of information and entertainment, this thread seriously wins. Anyone wants some popcorn?
      Just don't drop the popcorn everywhere, it's a nightmare to clean up.


      • Hi there,

        I've got a ATI Technologies Inc Mobility Radeon HD 3450 Series here (is it the RV620?), and I can say that UVD works here. I didn't really expect that, but it works

        There are however a few glitches when playing files in mplayer:

        1. OSD is working, but the fonts aren't antialiased
        2. Subtitles are working, but they're displayed from left to right instead of centered. Also the leftmost 100-150px is cut off (not displayed) when OSD is turned off. With OSD turned on, the subtitles display correctly
        3. The colors are messed up in some of the videos. In one category of incorrect videos, the picture is ok, but then the colors slowly drift towards the reds and then suddenly they're correct again. In other films, half of the picture has correct colours and the other half incorrect, and these halves switch along with playback. Mind you, I've only tested h264.

        My config:
        Arch Linux, pacakges:
        libva-sds 0.31.0_1_9-2
        mplayer-vaapi 20091127-2
        xvba-video 0.5.3-1
        catalyst 9.10-1

        Is this thread the right place to report problems or is there some sort fo a bug tracker available?

        Also, someone asked: No, catalys 9.11 doesn't work with the new liva, xvba-video.


        • Did somebody get vlc git running with ati? I compilied it (using a small build fix to disable same dxva things in video.c) and --enable-libva with ffmpeg vaapi patched globally installed. But with vlc --ffmpeg-hw all i get is a segfault.


          • Wow. I started programming on an 8086, and it was already ancient by that time.

            Originally posted by bridgman View Post
            Well... let's just say that I had been programming for a while when the Intel 8080 came out...

            ... but then again I started pretty young. I do remember trading in the teletype for a DecWriter and being able to program a lot faster


            • It's funny how things work out. I originally started designing graphics hardware because I got tired of loading paper into the DecWriter
              Test signature


              • Btw. for the ones who want to try vlc yourself and already executed my other scripts (best to use nvidia however to test):

                the script MUST be run as user with all 3 command as comment as root before. it will install ffmpeg and, hwdecode-demos and vlc git in the home. vlc with the option mentioned shows something with vaapi on nvidia (but red + blue swapped) and just green with xvba error on ati. if you dont like vlc just add a exit after the hwdecode-demos. They are interesting to test - that way without global install. --glx option is needed vor vaapi_h264 and vaapi_vc1 with ati.


                • I tried to playback some 720p50 material - for example the loop on EinsfestivalHD (Astra 19.2) causes lots of nasty pictures freezes. Can someone double check that? Arte HD, is affected as well. Mpeg4 AVC L4.0 in use. Here is the output of mediainfo:
                  ID                               : 1601 (0x641)
                  Menu ID                          : 132 (0x84)  
                  Format                           : AVC         
                  Format/Info                      : Advanced Video Codec
                  Format profile                   : [email protected]
                  Format settings, CABAC           : Yes
                  Format settings, ReFrames        : 5 frames
                  Duration                         : 7mn 2s
                  Bit rate                         : 7 180 Kbps
                  Width                            : 1 280 pixels
                  Height                           : 720 pixels
                  Display aspect ratio             : 16:9
                  Frame rate                       : 50.000 fps
                  Resolution                       : 24 bits
                  Colorimetry                      : 4:2:0
                  Scan type                        : Progressive
                  Bits/(Pixel*Frame)               : 0.156
                  Stream size                      : 362 MiB (87%)
                  Color primaries                  : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
                  Transfer characteristics         : BT.709-5, BT.1361
                  Matrix coefficients              : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177


                  • You could try

                    -demuxer lavf

                    Also the signal must be really good - with bad input even vdpau crashed the system after some time - was some time ago i tested it with xine-vdpau+kaffeine+anixe hd which had a really bad signal quality here.

                    ARTE HD works fine here with the lavf demuxer - over vdr 1.7.10 streamdev:

                    mplayer -va vaapi -vo vaapi:gl -demuxer lavf http://localhost:3000/C-1-1011-11120.ts

                    PS: there are framedrops when i switch to fullscreen or back using f.
                    Last edited by Kano; 02 December 2009, 08:37 AM.


                    • Hi Kano, thanks for helping out

                      It didn't help, but I realized this problem I have is rendering related: those freezes won't occur if I keep the original window size, problems start when I change into fullscreen (1920x1080 resolution)

                      780G GPU, fglrx 9.10 in use, I run mplayer like this:

                      mplayer -vo vaapi:gl -va vaapi -framedrop <filename>

                      Can you watch your 720p50 recordings in fullscreen?

                      edit: now our postings double crossed ;-) but your editing remarks answer my question: you seem to have these freezes as well when you switch into fullscreen.
                      Last edited by Tuxoholic; 02 December 2009, 08:49 AM.