Announcement

Collapse
No announcement yet.

Compiz Running With Mesa On R600/700 GPUs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compiz Running With Mesa On R600/700 GPUs

    Phoronix: Compiz Running With Mesa On R600/700 GPUs

    Just about three weeks ago the AMD developers working on the open-source ATI drivers had reached the milestone in their open-source 3D support for the R600/700 GPUs of having glxgears running on these two latest generations of ATI graphics processors. glxgears running itself isn't much, but it's an important step...

    http://www.phoronix.com/vr.php?view=NzQyNg

  • #2
    That's interesting, is there a live image with that mesa+drm code already?

    Comment


    • #3
      This is indeed excellent news, my next mobo will have an AMD IGP for sure
      Originally posted by Kano View Post
      That's interesting, is there a live image with that mesa+drm code already?
      There is little point in providing live images of some development code snapshot. And besides, if you use a proper distro, then upgrading to latest mesa and drm from git is just two commands away (and I am not referring to the commands mentioned here)

      Comment


      • #4
        Great news indeed

        Comment


        • #5
          Originally posted by chithanh View Post
          This is indeed excellent news, my next mobo will have an AMD IGP for sure
          That's funny. IGP has mostly been the only thing I've heard people having good performance with the current memcpy buffer swaps...
          Originally posted by chithanh View Post
          There is little point in providing live images of some development code snapshot. And besides, if you use a proper distro, then upgrading to latest mesa and drm from git is just two commands away
          Very true. Even if it was more than two commands though (as it is in my case, I wouldn't be installing from ebuilds even if I was using Gentoo since I like to know exactly what I'm doing), I'd still be rather be installing to hard disk than using LiveCD's.

          Comment


          • #6
            Originally posted by chithanh View Post
            There is little point in providing live images of some development code snapshot.
            Kororaa did exactly that with the first AIGLX code and compiz, I don't see why someone couldn't do the same for R600 now...

            Comment


            • #7
              Seriously? I didn't expect Compiz support before Mesa 7.7 and didn't expect Mesa 7.6 before November/December. Would be amazing to have it in the October-distribution-refreshes. Out of the box simple 3D for *all* AMD cards, remember!

              Great work, devs!

              Comment


              • #8
                Great! Things are progressing faster than I imagined.

                I doubt the 3d code for R600/700 will be stable enough for the October round of releases, but the distros might decide to enable it by default at this pace.

                Comment


                • #9
                  Originally posted by chithanh View Post
                  There is little point in providing live images of some development code snapshot. And besides, if you use a proper distro, then upgrading to latest mesa and drm from git is just two commands away (and I am not referring to the commands mentioned here)
                  I think the idea is to have a simple way to test the new code without risking your current installation.

                  Comment


                  • #10
                    Originally posted by d2kx View Post
                    Seriously? I didn't expect Compiz support before Mesa 7.7 and didn't expect Mesa 7.6 before November/December. Would be amazing to have it in the October-distribution-refreshes. Out of the box simple 3D for *all* AMD cards, remember!

                    Great work, devs!
                    I would have liked to be that enthusiast but this won't happen.
                    To get a proper 3D support on r6xx/r7xx, you'll need the 2.6.32 (assuming the ATI devs would be in time to merge it to it next month).
                    Ubuntu should use the 2.6.31 when release, so, there will be no 3D support for r6xx/r7xx cards on Ubuntu 9.10.

                    That being said, I would like to tell that advanced users should use rolling distro so as more users could contribute to bug reporting.

                    Comment

                    Working...
                    X