Announcement

Collapse
No announcement yet.

Where is Catalyst 9-1??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I keep hitting f5 on the AMD site when I'm at home.
    I want to see if some of the bugs are resolved.
    The good performance bug is not a priority for me, they can address that one later.
    I want doom3 to play smoothly, I do get over 100fps in demo1 at 1600*1200 Ultra, max filtering. But for whatever reason, it just doesn't seem so smooth.

    Comment


    • #12
      [QUOTE=BlueKoala;59395]I keep hitting f5 on the AMD site when I'm at home.{QUOTE]

      Yah me to... i'm such a optimist (read: sucker).

      Comment


      • #13
        Hey guys, while im waiting (being a sucker) for the official drivers, should i go for the 9.1 or the 9.2 betas? Are those any stable? Im using 8.12 @ Ubuntu 8.10.

        Thanks and please excuse me for my french

        Comment


        • #14
          It it unlikely that a fglrx driver is really stable, but just try the newer ones, usually the system still runs 9-1 fixed a bug with nexuiz screen res change and 9-2 can render gl2benchmark correctly. At least finally some improvements - an error which was in there from 10/07 to 01/09. Well in 02/09 you get the immediate fix for this issue

          Comment


          • #15
            Originally posted by BlueKoala View Post
            I keep hitting f5 on the AMD site when I'm at home.
            I want to see if some of the bugs are resolved.
            The good performance bug is not a priority for me, they can address that one later.
            I want doom3 to play smoothly, I do get over 100fps in demo1 at 1600*1200 Ultra, max filtering. But for whatever reason, it just doesn't seem so smooth.
            I don't think this is ATI/AMD specific. I get the same thing on my RadeonHD 4850 and Geforce 7950GX2. It seems to be some odd timing issue, for example if you disable frame-independent physics simulation with com_fixedTic 1 (i.e. one simulation 'tick' per frame) I get a really smooth 200+ FPS, unfortunately this makes the game run faster/slower depending on how high your FPS happens to be (you could turn on vsync, but that will cause a high amount of input lag (3+ frames) with ATI/AMD cards for some reason). with the default setting of com_fixedTic I get an FPS jumping wildly from 40 to 60 making everything very jerky. I've had this for nearly a year now I think, I'm not sure when it started happening, maybe something in the linux kernel changed that made Doom3's (and Quake4's for that matter, it suffers from the same issue) timing mechanism not work right. I had initially suspected it was because of the new 'tickless' feature (http://kerneltrap.org/node/6750) but turning that off made no difference :/

            I had kind of given up on finding a solution for it because google yielded absolutely nothing on the matter.. in fact you're the first person I found that is having the same issue

            EDIT: Just to clarify though, normally doom3's FPS is limited to 60 (since that is what the physics simulation and everything runs at, and there's no point rendering the same frame twice), this isn't the problem here though (for me anyway) since 60 FPS is something I'd still call smooth. The problem seems to be that there are frequent jerks or pauses that make it very much not-smooth. using com_showFPS 1 it'll show a framerate varying between 40-60 (though it's normal for the FPS shown by showFPS to vary a little of course)
            Last edited by Aphax; 01-22-2009, 07:31 PM.

            Comment


            • #16
              Originally posted by BlueKoala View Post
              I keep hitting f5 on the AMD site when I'm at home.
              I've been hitting that button for a year+ now
              I thought I could stop that when support for xv with compositing came, but noooooo...
              I have to wait for xserver 1.6 support too to try jaunty... *sigh*
              f5f5f5f5f5f5f5f5f5f5f5f5f5

              Comment


              • #17
                Originally posted by Vighy View Post
                new amazing bugs
                those are called "features"

                Comment


                • #18
                  I had stuttering in ut2004 with my 8600GT - framerate war great, but FPS aren't everything.
                  Reducing the FPS via cranked up AA/AF made the stutter go away... found that hint in the windows part of nvnews - obviously I was not alone.
                  With my HD3870 I have seen stuttering too - but this time it was caused by PAT. If you are not using a very recent kernel - like 2.6.27 or 2.6.28, try the nopat boot option and see if it goes away. It did for me - and it is fixed anyway for a while now.

                  About the late driver: I can't wait. I want it so badly, but there were christmas AND Sylvester/NewYear. That mean almost two weeks lost. So it should be pretty normal to see it a bit late. 8-12 was early, 9.1 will be a bit late. Until then - the leaked ones are pretty promising and very nice to play with.

                  Comment


                  • #19
                    Originally posted by energyman View Post
                    I had stuttering in ut2004 with my 8600GT - framerate war great, but FPS aren't everything.
                    Reducing the FPS via cranked up AA/AF made the stutter go away... found that hint in the windows part of nvnews - obviously I was not alone.
                    With my HD3870 I have seen stuttering too - but this time it was caused by PAT. If you are not using a very recent kernel - like 2.6.27 or 2.6.28, try the nopat boot option and see if it goes away. It did for me - and it is fixed anyway for a while now.

                    About the late driver: I can't wait. I want it so badly, but there were christmas AND Sylvester/NewYear. That mean almost two weeks lost. So it should be pretty normal to see it a bit late. 8-12 was early, 9.1 will be a bit late. Until then - the leaked ones are pretty promising and very nice to play with.
                    Yeah I had already disabled PAT on my 2.6.28 kernel to solve some MTRR-related errors (though I guess I might've had the same problems you mention here but never noticed).

                    Anyway, I just spent nearly 5 hours trying dozens of things to get rid of the stuttering in Doom 3, and I *finally* got rid of it by downgrading to 2.6.20. I'll have to try a few more kernels and see where the issue appears and maybe pinpoint exactly what changed.

                    I can also not rule out that it might be some obscure kernel config option I happened to configure differently for 2.6.20 that may have caused it.. (I guess I could try testing on a default Ubuntu install) oh well. I'm glad I have something to go on now, this has been bugging me for well over a year.

                    Comment


                    • #20
                      To those with Doom3 stuttering, it might most probably be due to alsa. Get the latest doom3 1.3.1.1304 which has sound fixes. The timedemo runs fine as there is no sound, but after few minutes of playing, both the audio and video used to annoyingly stutter. The updated doom3 (and playing around with sound options) fixed it.

                      Also, regarding quake3, ioquake3 (by icculus) is much better than idsoft's quake3, especially with sound as it uses openal.

                      Comment

                      Working...
                      X