No announcement yet.

Canonical Reveals The Aquaris M10 Ubuntu Tablet

  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Originally posted by edwaleni View Post
    My BQ Ubuntu Touch tablet arrived from Spain today. Comes with 15.04 release. Interesting touch parameters....still getting used to it as this is my first work with Ubuntu Touch.

    I will run PTS as soon as it finishes updating.
    Thanks, please keep us posted! Interesting to know that they drop the VAT charge for orders outside Europe, this brings the price down a whopping 20% ! I was wondering about this myself.


    • #52
      OK, here is my first take on running PTSI on the BQ tablet. A couple of issues came up quickly that I will need to address.

      First, the entire PTSI suite won't install on the tablet as the eMMC after the OS, just isn't large enough. I will have to reinstall it to the mSD card for the next run.
      Second, even though the tablet has a Mediatek Quad Core, it keeps reporting otherwise.
      Processor: AArch64 rev 3 @ 1.50GHz (2 Cores), Motherboard: MT8163, Memory: 2048MB, Disk: 16GB 016G70 + 16GB SU16G
      OS: Ubuntu 15.04, Kernel: 3.10.93+ (aarch64), Display Server: SurfaceFlinger, File-System: ext4, Screen Resolution: 1216x5760

      I ran
      cat /proc/cpuinfo and get the following:

      Processor : AArch64 Processor rev 3 (aarch64)
      processor : 0
      BogoMIPS : 26.00
      Features : fp asimd aes pmull sha1 sha2 crc32 wp half thumb fastmult vfp edsp neon vfpv3 tlsi vfpv4 idiva idivt
      CPU implementer : 0x41
      CPU architecture: 8
      CPU variant : 0x0
      CPU part : 0xd03
      CPU revision : 3
      Hardware : MT8163

      Needless to say, the PTSI results reek pretty badly, less performance than most of the ARM tests Mike has run, obviously due to the fact only 2 of the 4 cores seem to be in flight.

      So I will take some time to re-examine the settings, see if there is anything I did wrong.

      As far as the tablet use overall, it works fine even though I am still getting used to the interface. The Ubuntu application manager is pretty sparse so if you want to install a range of apps you will need to use the ADB method Mike referred to earlier in Phoronix. I have yet to get the micro-HDMI port to work so I can use it in "desktop" mode.

      The bluetooth keyboard and mouse work great, but until I can get that HDMI port to activate, desktop mode will have to stare at the tablet for now. It just doesn't detect any of the monitors I use.

      Since this tab is designed for consumer use, it really isn't setup as a traditional Linux workstation you would install yourself, even though they advertise it as such, so don't go thinking this is the ultimate Linux tablet. This is Ubuntu running like Android in basic terms.

      i will post more as I work through it.


      • #53
        Well, looks like my life with this BQ Ubuntu Edition tablet may be over. It refused to install the latest OTA update from Canonical. Since I had downloaded a lot of apps (but did not root it), I thought I would follow the "Reset to Factory" option to clear it out and open space and try the OTA updates again. That was a no go. It reboots showing the "Powered by Ubuntu" splash screen, turns on the back light and just sits there.

        I will see if i can revive it using ADB, if not i will open a ticket with BQ support and see what happens. With the support based in Spain, here is hoping I can revive it. Doing a return shipping to Spain would be interesting.


        • #54
          Well, my life with the BQ and Ubuntu Edition have come to a close.

          With Ubuntu pretty much shutting down Tablet and Phone work and the final OTA that came through, I reflashed my Aquaris M10 FHD to Android Marshmellow tonight.

          Honestly, I couldn't get the Ubuntu version to work to my satisfaction. I understood the concept of Scopes and such, but the restrictions on software were just to limiting.

          Everytime I tried to sideload a Linux app, the next OTA would fail and brick the tablet. I would revive it back with a reflash. The fact that Ubuntu restricts root to such a degree to make it work and many of the apps in the appstore were merely HTML5 front ends. When I would update the file system for sideload, it would overwrite a critical file which would screw the next OTA. It just wasn't worth it.

          Oddly, BQ advertises it as a "quad core", Ubuntu only detected 2 cores and now that Android is on it, it now reports as 1 core.

          I learned alot about Ubuntu Touch. Unfortunately all for naught.


          • #55
            FWIW: It really does have a quad core ARM, the power management is fairly aggressive. I ran some Android based tools and it is indeed a quad. Ubuntu Touch seemed to keep only 2 cores active. Android is less impacting as one core seems to idle at 600Mhz and the others shut off. Only a serious benchmark seems to activate the remaining cores. In Ubuntu Touch, even PTS couldn't get the last 2 cores to come up and so the results looked really bad.