Announcement

Collapse
No announcement yet.

Forums Upgraded, Now More Friendly Towards HTTPS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forums Upgraded, Now More Friendly Towards HTTPS

    Phoronix: Forums Upgraded, Now More Friendly Towards HTTPS

    Apologies for the brief downtime this evening of the forums with upgrading to the latest major release of the forum software...

    http://www.phoronix.com/scan.php?pag...-Forum-Upgrade

  • #2
    Not sure if it was the recent upgrade to FF44 or the forum software, but the big forum navigation buttons are now working again in Firefox . One less reason to use Chrome.

    Comment


    • #3
      Michael . you might wanna follow this thread to http://www.vbulletin.com/forum/forum...-functionality

      Comment


      • #4
        Ugggh... vBulletin. Anyhow, good to know HTTPS is applied more thoroughly now, might also mean better functionality in conjunction with HTTPS Everywhere. And, never mind any downtime. It's for a good cause so I'm sure most people would be with me in thanking you for staying on top of things.

        Comment


        • #5
          Not quite there yet. I did a cache flush and forced reload and still had these. These are probably from vBulletin, but in case they're not...

          Code:
          22:37:04.605 Blocked loading mixed active content "http://www.phoronix.com/forums/css.php?styleid=22&td=ltr&sheet=css_reset.css,css_unreset.css,css_utilities.css&ts=1455326213"[Learn More] forums
          22:37:04.607 Blocked loading mixed active content "http://www.phoronix.com/forums/css.php?styleid=22&td=ltr&sheet=css_imgareaselect-animated.css,css_jquery-ui-1_8_14_custom.css,css_jquery_qtip_min.css,css_jquery_selectBox.css,css_global.css,css_fonts.css,css_b_link.css,css_b_layout.css,css_b_button.css,css_b_button_group.css,css_b_dropdown.css,css_b_icon.css,css_b_tabbed_pane.css,css_b_form_control.css,css_b_form_input.css,css_b_form_select.css,css_b_form_textarea.css,css_b_media.css,css_b_divider.css,css_b_avatar.css,css_b_ajax_loading_indicator.css,css_b_topicpreview.css,css_b_menu.css,css_responsive.css&ts=1455326213"[Learn More] forums
          22:37:04.608 Blocked loading mixed active content "http://www.phoronix.com/forums/js/header-rollup-520.js"[Learn More] forums
          22:37:04.609 Blocked loading mixed active content "http://www.phoronix.com/forums/css.php?styleid=22&td=ltr&sheet=css_b_top_background.css&ts=1455326213"[Learn More] forums
          22:37:04.611 Blocked loading mixed active content "http://www.phoronix.com/forums/css.php?styleid=22&td=ltr&sheet=css_b_module.css&ts=1455326213"[Learn More] forums
          22:37:04.612 Blocked loading mixed active content "http://www.phoronix.com/forums/css.php?styleid=22&td=ltr&sheet=css_b_post_sm.css&ts=1455326213"[Learn More] forums
          22:37:04.612 Blocked loading mixed active content "http://www.phoronix.com/forums/css.php?styleid=22&td=ltr&sheet=css_additional.css&ts=1455326213"[Learn More] forums
          22:37:04.630 Loading mixed (insecure) display content "http://www.phoronix.com/forums/core/images/default/default_avatar_thumb.png" on a secure page[Learn More] forums
          22:37:04.633 Loading mixed (insecure) display content "http://www.phoronix.com/phxcms7-css/phoronix.png" on a secure page[Learn More] forums
          22:37:04.634 GET
          http://www.phoronix.com/forums/core/images/default/default_avatar_thumb.png [Mixed Content]
          [HTTP/1.1 200 OK 158ms]
          22:37:04.636 GET
          http://www.phoronix.com/phxcms7-css/phoronix.png [Mixed Content]
          [HTTP/1.1 200 OK 157ms]
          22:37:04.653 Loading mixed (insecure) display content "http://www.phoronix.com/forums/favicon.ico" on a secure page[Learn More] ContentLinkHandler.jsm:169:8
          22:37:04.669 Blocked loading mixed active content "http://www.phoronix.com/forums/js/footer-rollup-520.js"[Learn More] forums
          22:37:04.688 Loading mixed (insecure) display content "http://www.phoronix.com/forums/core/images/default/default_avatar_medium.png" on a secure page[Learn More] forums
          22:37:04.689 GET
          http://www.phoronix.com/forums/core/images/default/default_avatar_medium.png

          Comment


          • #6
            Clicking in forums link from the home page while in HTTPS resulted in broken forum page, leading me to think that CSS file is missing.

            Google Chrome version 48.0.2564.97 (64-bit)

            Comment


            • #7
              The favicon of the forum is back to the default vbulletin favicon. I'm pretty sure you had a personalized one before, but I could be wrong.

              Comment


              • #8
                The forum browsing experience using https has actually worsened for me.

                As GraysonPeeddie said, CSS and other resources are loaded through http and thus will be blocked by Chrome and Mozilla browsers. Also there are still many links which lead out of https and back into http.

                Code:
                $ curl "https://www.phoronix.com/forums/forum/phoronix/latest-phoronix-articles/851870-forums-upgraded-now-more-friendly-towards-https" | grep -c "https://www.phoronix.com/forums/"
                0                                                                               
                $ curl "https://www.phoronix.com/forums/forum/phoronix/latest-phoronix-articles/851870-forums-upgraded-now-more-friendly-towards-https" | grep -c "http://www.phoronix.com/forums/"                          
                63
                It really should be the other way round.

                Comment


                • #9
                  Originally posted by dEnigma View Post
                  The favicon of the forum is back to the default vbulletin favicon. I'm pretty sure you had a personalized one before, but I could be wrong.
                  This. The vBulletin favicon shows itself in Chrome whereas Firefox seems to load the correct one. Might need to look into this one.

                  Comment


                  • #10
                    Originally posted by Awesome Donkey View Post
                    This. The vBulletin favicon shows itself in Chrome whereas Firefox seems to load the correct one. Might need to look into this one.
                    At first when uploading the new vB, accidentally uploaded the VB one. So in Chrome it must be stuck in your browser cache. Should then be cleared soon when your cache clears.
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment

                    Working...
                    X