Announcement

Collapse
No announcement yet.

HTTPS For Phoronix.com

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HTTPS For Phoronix.com

    Phoronix: HTTPS For Phoronix.com

    Thanks to the new and much more powerful web server for Phoronix.com, if you've tried to access the site in the past few hours, there's proper HTTPS support...

    http://www.phoronix.com/scan.php?pag...-Phoronix-Site

  • #2
    I've disabled ABP on this site for example because you use the ads to pay the bills and in this case it's ok for me.

    I suggest you to put somethings under the ads so if someone uses an ads blocker maybe can read a message to sensitize the users.

    Comment


    • #3
      Originally posted by Talos View Post
      I've disabled ABP on this site for example because you use the ads to pay the bills and in this case it's ok for me.
      Many thanks!
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Originally posted by Michael View Post
        Many thanks!
        You are welcome, thank you for your articles etc!

        Have you ever thought to use services like "patreon.com" to get extra money every month? I've just heard, I don't know if there are any downsides.

        Comment


        • #5
          Originally posted by phoronix View Post
          Phoronix: HTTPS For Phoronix.com

          Thanks to the new and much more powerful web server for Phoronix.com, if you've tried to access the site in the past few hours, there's proper HTTPS support...

          http://www.phoronix.com/scan.php?pag...-Phoronix-Site
          Don't you have AES-NI? That makes the encryption basically free for the server performance-wise. The cert is not free but it's also not *that* expensive

          Comment


          • #6
            To cut certificate costs you should consider using https://letsencrypt.org/ the next time you have to renew your certificate. I think it'll be standard once that day comes for you (in 3 years).

            Also, your SSL configuration is rather bad[1]. Please consider adopting Mozillas TLS guidelines: https://wiki.mozilla.org/Security/Server_Side_TLS
            It's a simple copy&paste into the Apache configuration. Having IDEA and SEED ciphers enabled in 2015 is rather bad. RC4 should go too.

            [1] https://www.ssllabs.com/ssltest/anal...d=phoronix.com

            Comment


            • #7
              No adblock, just scriptblock

              I just wanted to comment on the addblock thing quick. I know that many sites rely on adds to pay for hosting, and so I disabled addblock long ago. However, I do run noscript, because most internet attacks these days can be traced directly back to flash or some other scripting extension. While I trust sites like yours, I'm not comfortable trusting third party scripts. Unfortunately, it seems that not trusting them kills most adds on your site.

              Back on topic. that's a pretty nice server. I suppose that power is part of the colo bundle, but the newer processors are making leaps and bounds in their efficiency. I think that's the most exciting thing for me upgrading to newer generation equipment; it gets faster, and as often as not the power consumption goes down too.

              Comment


              • #8
                You caught me at a good time and I'm now a subscriber

                Can't guarantee I can keep being one as I'm a student for now, but at least I've got a year!

                Comment


                • #9
                  Originally posted by Talos View Post
                  I've disabled ABP on this site for example because you use the ads to pay the bills and in this case it's ok for me.
                  Ive done the same. Even from time to time check advertisements and spent abount 1 min there (do u get money for clicking?)

                  Comment


                  • #10
                    Forums still look like plain text with hyperlinks because Chrome refuses to load "unsafe scripts". Have to click shield icon and force-load them everytime I visit forums. Please fix.

                    Comment

                    Working...
                    X