No announcement yet.

AGP X1950 PRO Black(Locked) Screen

  • Filter
  • Time
  • Show
Clear All
new posts

  • AGP X1950 PRO Black(Locked) Screen

    Hi to everyone
    I've got a problems with latest AMD drivers from 7-11 to 8-02: a black screen appears after "install/configure/reboot"
    I'm running nforce 2 motherboard and Sapphire RadeOn X1950PRO AGP 512 MB
    nvidia_agp,fglrx(kernel module + gart) are loaded and it result black screen (x-server hangs on loading). Xorg.0.log does not contain any error. "# sax2 -r" producing same result.
    Disabling nvidia_agp (modeprobe.d -> blacklist blacklist agpgart & blacklist nvidia_agp) and using fglrx agpgart results:
    (EE) fglrx(0): [agp] unable to acquire AGP, error -1023
    (EE) fglrx(0): cannot init AGP
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized

    Help please. Tell me what i am doing wrong
    If need any output, just write...

    PS. Sory for my english

  • #2
    IIRC some people were able to get around this by using the BIOS config screen and setting the AGP aperture to a smaller value. With some of the earlier drivers you needed an aperture the same size as the video memory on the card, but with the later drivers a smaller aperture seems to work better.

    Worth a try anyways.
    Test signature


    • #3
      Is it posible that "X.Org X Server 1.4.0" version cause this problem ? driver determines xorg "7.1 and later" (i'm runing SuSE 10.2 with updated kernel- + kernel-source- and xorg 7.3)
      I've tried 128 and 256 MB AGP aperture size (in BIOS) also different combinations of fglrx "Option" like:
      "UseInternalAGPGART" "yes"#/"no"
      "AGPv3Mask" "0x00000001"
      "BusType" "AGP"
      "KernelModuleParm" "locked-userpages=0"
      "KernelModuleParm" "agplock=1"
      "KernelModuleParm" "agp_try_unsupported=1"
      "MaxGARTSize" "256"#/"128"
      "UseFBDev" "true"
      "EnablePrivateBackZ" "no"
      "backingstore" "true"
      "mtrr" "off"
      "UseFastTLS" "2"#/"0"
      "BlockSignalsOnLock" "on"
      "ForceGenericCPU" "no"
      Also i have Composite and AIGLX disabled. Different combinations sometimes cause different "hold line" of Xorg.0.log, but with same major result: black screen and completely hanged keyboard, so i can't even unload x-server by Ctrl+Alt+Backspace.
      Installing from [generated_by_sh_*.run].rpm or [].rpm's does not make difference
      Disabling acceleration by "Option no_dri/no_accel" removes x-server hangs, but that is not good.
      At least it would be good to knew what exactly could cause the problem, what fglrx "options" could help and what does they mean.
      screen resolution 1280x1024 and 1024x768
      /dev/shm mounted 258112 1K-blocs
      according to Yast
      glibc version 2.5-34.7 (is this version ok ?)
      xorg-x11-server version 7.3-59.1
      libdrm version 2.3.0-1.1
      Just where to start ?

      Thanks for response.


      • #4
        AGP X1950 PRO Black(Locked) Screen

        I've tried 128 and 256 Mb aperture size (in bios) and various options in Device section of xorg.cong
        Right now i'm running at catalyst(?) 8.2 version
        SuSE 10.2 with updated kernel + kernel-source to,
        X.Org X Server 1.4.0 (xorg-x11-server 7.3-59.1)
        glibc 2.5-34.7
        libdrm 2.3.0-1.1
        /dev/shm mounted

        If someone have AGP X1950Pro(RV570/0x7280) please write how did you make it work. May be i have some bad versions of something, or it is a misconfigured driver...

        Thanks for reply.


        • #5
          Yes, I have one of those cards working;

          X Protocol Version 11, Revision 0, Release 1.3
          PCLinuxOS / Mandriva

          How I made it work? I ran the install binary. You want to see a copy of my xorg.conf?

          Section "Device"
          Identifier "aticonfig-Device[0]"
          Driver "fglrx"
          Option "DesktopSetup" "clone"
          Option "VideoOverlay" "on"
          Option "OpenGLOverlay" "off"
          Option "XAANoOffscreenPixmaps" "True"
          Option "TexturedVideo" "True"
          Option "TexturedVideoSync" "True"
          Option "Textured2D" "True"
          Option "TexturedXrender" "True"
          Option "UseFastTLS" "2"
          Option "BackingStore" "True"
          Option "EnableMonitor" "crt1,crt2"
          BusID "PCI:1:0:0"

          Section "Extensions"
          Option "RENDER" "Enable"
          Option "DAMAGE" "Enable"
          Option "Composite" "Enable"
          Option "XVideo" "Enable"

          I'm using a bios aperture setting of 256MB. I have used 512MB, but I read somewhere that over 256 is more drag than help.

          I've read that other distros have trouble with ATI drivers. Perhaps you can google for susi forum?


          • #6
            AGP X1950 PRO Black(Locked) Screen

            Still no luck.
            I've tried many solutions, upgrading/downgrading libs, x-server etc. It seems that other "suse people" also doesn't understand what is wrong.
            I think to stay at older drivers (pre 7.11) for now. May be next release will be lucky.

            Bridgman, if AMD team need an additional report of this problem write what exactly... And i have a question: on my card, AGP support made by some kind of PCIe-to-AGP-bridge chip. There are rumors that such chips could cause many problems including for developing drivers. Does that true ?

            Thanks for help anyway.


            • #7
              Just hit this one myself - X1600 pro on an nforce 2 mobo.

              I've been building a new LFS, current BLFS svn uses xorg 7.2 and installs everything in /usr /usr/lib/X11 - which meant alot of messing around as 8-2 puts everything in ..../xorg.

              Found this thread while googling for the AGP error -1023 tried the GART size but it didn't work.

              Finally got it working by -

              Section "Device"
              Option "UseInternalAGPGart" "no"
              Identifier "aticonfig-Device[0]"
              Driver "fglrx"

              just doing this is not enough you need to reboot and before X starts make sure /arrange for your chipset agp module to be loaded - this is not just agpgart (though it should load and use it).

              For me on an nforce 2 mobo I need to

              modprobe nvidia-agp

              then startx.

              I don't know if it matters but I ended up with 256m in bios.

              HTH - andy.

              Edit - I know it seems like you tried this already, but if the only error you get is the AGP when you grep for EE in the logs, try the config exactly like mine (I see you wrote UseInternalAGPGART rather than UseInternalAGPGart) and reboot and make sure nvidia-agp loaded OK and loaded agpgart)

              Make sure you don't have other errors - I needed <alt><sysreq><f><u><b> alot just because of the locations and nvidia agp + fglrx internal on also crashes.
              Last edited by legume; 23 February 2008, 09:33 PM.


              • #8
                I don't know if it matters but I ended up with 256m in bios
                I tried reverting to 128MB GART and it failed so it looks like it does matter.

                I also tried some real 3d tests rather than just looking at glxinfo/logs and both glxgears and fgl_glxgears fail to draw to screen :-( - nice framerates, though!. Q3demo also fails, I don't know whether these are just down to more LFS/udev tweaking needed or if it's the driver.