Announcement

Collapse
No announcement yet.

Can't Disable Vsync

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Disable Vsync

    I can't seem to be able to turn off vsync on my machine. SwapBuffersWait is set to off in my xorg.conf and my xorg log says it's disabled. I even set vsync off in driconf. Still, glxgears reports vsync is on. Is there something else I need to switch? Ubuntu Maverick, xorg-edgers (r300g), 2.6.38.3.

  • #2
    glxgears' text output is buggy for me too, been a while. If you get above 60fps, just ignore the console output. I get some 1300 fps.

    Comment


    • #3
      Frames are locked at 60 with glxgears. The chip is just too slow to hit more than 60fps on many games, so I can't really tell that way.

      Comment


      • #4
        http://kanotix.com/files/fix/oss-test/ati-oss-test.sh

        look at that, the script disables the option directly without xorg.conf when you add any option. you dont need to use it but you should get the idea.

        Comment


        • #5
          Best remove all configfiles you created.

          Comment


          • #6
            You need to manually create a dri2 setting in drirc. Something like:

            <driconf>
            <device screen="0" driver="dri2">
            <application name="Default">
            <option name="vblank_mode" value="0" />
            </application>
            </device>
            </driconf>

            See https://bugs.freedesktop.org/show_bug.cgi?id=34401

            Comment


            • #7
              Thanks. Setting the driver in .drirc to "dri2" instead of "r300" did the trick.

              Comment


              • #8
                Well .drirc does nothing on my squeeze system with updated libdrm (and rest of the oss stack). Looks that it is somehow incompatible. Maybe i heed to check a system with newer libdrm by default. Basically even natty has a too old libdrm to compile every mesa driver - maybe not for ati, but if you want to compile every driver it wants 2.4.24+. Debian sid would be new enough however... I also checked some basic packages contents on natty, it still has got a ia32-libs package in universe, but i don't get why the libdrm libs are at a differnet position compared to debian sid. The problem is that you need those to compile 32 bit mesa libs on a 64 bit system. natty however would in theory allow to forget about ia32-libs(-dev) and use multiarch single lib packages. Did anybody try that? I do not really like just to replace libdrm code with self compiled libs because it usally affects other packages like plymouth too. Thats better handled with correct packageing. Btw. ia32-libs-dev on sid is outdated and does not contain the files from libdrm-dev (just like on natty, thats why i needed a hack to extract em...)

                Comment


                • #9
                  Code:
                  $ vblank_mode=0 glxgears
                  should do the trick. You have to set the environment variable vblank_mode to 0.

                  Comment

                  Working...
                  X