Announcement

Collapse
No announcement yet.

Catalyst 10.12 Released for Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    pvtcupcakes
    Senior Member

  • pvtcupcakes
    replied
    That new crash had to do with SELinux. It only happens if I run amdcccle from the command line as root. If I run it from System->Preferences, it doesn't crash. And I finally got dual screen to work now.
    I don't know what vodoo amdcccle does, but no matter what I did to xorg.conf I couldn't get it to work.

    Leave a comment:

  • pvtcupcakes
    Senior Member

  • pvtcupcakes
    replied
    Originally posted by The IceMan View Post
    Works for me, on Fedora 14 / 64bit
    Using the amdccc tool

    i had the same problem, but then i run the amdccc tool from the terminal and saw the error message about some display.xml file, i deleted the file, and now it's working for me.
    I did that, but it just got me a step further and CCC crashes in another place.

    This is my new crash:
    Code:
    GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
    Aborted (core dumped)
    As for the crash you mentioned, it's pretty astonishing that the "professional" Ati developers didn't account for monitors.xml being empty because it causes Qt to crash and takes CCC with it.

    Leave a comment:

  • The IceMan
    Junior Member

  • The IceMan
    replied
    Originally posted by pvtcupcakes View Post
    Same problem here. Dual monitors just simply don't work at all on Fglrx.
    I can get both screens running at 1280x1024 in clone mode, but god forbid I try doing 1280x1024 on one and 1680x1050 on the other in Xinerama.
    Works for me, on Fedora 14 / 64bit
    Using the amdccc tool

    i had the same problem, but then i run the amdccc tool from the terminal and saw the error message about some display.xml file, i deleted the file, and now it's working for me.

    Leave a comment:

  • pvtcupcakes
    Senior Member

  • pvtcupcakes
    replied
    Originally posted by mibo View Post
    After restarting the computer without my old monitor connected - amdccc listed the 1920x1080 mode and I could select it.
    Why didn't it work when my old tft was still connected?
    Same problem here. Dual monitors just simply don't work at all on Fglrx.
    I can get both screens running at 1280x1024 in clone mode, but god forbid I try doing 1280x1024 on one and 1680x1050 on the other in Xinerama.

    Leave a comment:

  • mibo
    Senior Member

  • mibo
    replied
    Originally posted by mibo View Post
    I installed 10.12 on my openSUSE 11.3 64bit system last night. Then I connected a new monitor via DVI to my HD3850 (my old monitor was still connected to the other DVI output). amdccc doesn't let me choose 1920x1080 resolution for my new monitor :-( What can I do about it?
    After restarting the computer without my old monitor connected - amdccc listed the 1920x1080 mode and I could select it.
    Why didn't it work when my old tft was still connected?

    Leave a comment:

  • Death Knight
    Senior Member

  • Death Knight
    replied
    Originally posted by Dandel View Post
    Found another bug... The 64-bit copy of the World of Goo crashes (Linux Demo v1.41) on this driver, however, the 32-bit binary is unaffected. (Tested with Compiz/desktop effects enabled).

    Source of game: http://2dboy.com/games.php
    My OpenSUSE x86_64 11.3 crashes If I tried to run GIMP.
    (Tested with Compiz/desktop effects enabled).

    Leave a comment:

  • PsynoKhi0
    Senior Member

  • PsynoKhi0
    replied
    Quick check with Guild Wars and latest Wine dev version:
    Text/GUI seems back to normal (worked in 10.10 though 10.11 re-introduced the garbled GUI issue).
    Footprints still incorrectly displayed without GLSL
    Still random slowdowns - BTW if you want to check this out for yourself, you don't need to own the game, download the online installer, get to the login screen and let the camera pan; there is an Ping monitor/FPS counter at the bottom right of the screen, above the "Options" button. However it's kind of hidden at the login screen. Hover with your mouse in that area (there should be a lightning icon for a few seconds at the correct location) and the FPS should appear.

    openSUSE 11.3 64 bit, HD4670 PCIe.

    Leave a comment:

  • Dandel
    Senior Member

  • Dandel
    replied
    Found another bug... The 64-bit copy of the World of Goo crashes (Linux Demo v1.41) on this driver, however, the 32-bit binary is unaffected. (Tested with Compiz/desktop effects enabled).

    Source of game: http://2dboy.com/games.php

    Leave a comment:

  • mirv
    Senior Member

  • mirv
    replied
    Originally posted by tball View Post
    Ohh btw. Do you know if that is also true for non uniform variables within the shader code?
    I think so. Normally you'll just need to put "precision highp float;" after your #version, and that takes care of it. At least that's what I do, and I've not had any problems.

    Leave a comment:

  • tball
    Senior Member

  • tball
    replied
    Originally posted by mirv View Post
    Well it's a "bug" in my mind - that's one thing I think should be handled better, as I'm sure there's plenty of "old" shader code out there without such things. Defaulting to some xyz precision, but spitting out a compiler warning message would be more appropriate in my opinion - but then I'm sure I'll find people to disagree there.
    Ohh btw. Do you know if that is also true for non uniform variables within the shader code?

    Leave a comment:

Working...
X