Announcement

Collapse
No announcement yet.

Slamd64 (64 Bit slackware) and ATI Radeon (catalyst) driver problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mounty
    replied
    Originally posted by ljones View Post
    weird! I rebooted, and after logging in as non-root (from cold) and starting X went in ok. But leaving X as non-root and then attempting to go back in again (as non root) failed as in my previous post (no screen, errors etc). Prehaps this is a bug in the drivers?
    This fixes X for me; I can run fgl_glxgears as a normal user:
    Section "dri"
    Group "video"
    Mode 0666
    EndSection
    Then add myself to group video.

    Leave a comment:


  • ljones
    replied
    I managed to solve some of the other problems such as the missing file, fixed with ' ln -s /usr/X11R6/lib64/modules/dri/fglrx_dri.so /usr/lib64/xorg/modules/dri/fglrx_dri.so ' .

    X starting still seems to be a bit of a problem -- it gets even more weird! I rebooted, and after logging in as non-root (from cold) and starting X went in ok. But leaving X as non-root and then attempting to go back in again (as non root) failed as in my previous post (no screen, errors etc). Prehaps this is a bug in the drivers?

    Weird, not sure why that would happen!

    ljones

    Leave a comment:


  • Kano
    replied
    Well I only needed a dri hack for an older ati-driver, usually it is controlled by this xorg.conf section, which seems to be default in newer xservers:

    Section "DRI"
    Mode 0666
    EndSection

    Leave a comment:


  • ljones
    replied
    x.x

    There still seems to be just one more problem!

    If I run X and (let's say) fgl_glxgears as root, no problems.

    But as a normal (non-root) user, X crashes on first run with a blank screen, I have to stop it and restart it then it works. But then fgl_glxgears fails as non-root;

    Code:
    libGL error: open DRM failed (Operation not permitted)
    libGL error: reverting to (slow) indirect rendering
    X Error of failed request : GLXBadDrawable
     Major opcode of failed request:  144 (GLX)
     Minor opcode of failed request:  5 (X_GLXMakeCurrent)
     Serial number of failed request: 45 
     Current serial number in output stream: 45
    BTW I used the slamd64-current kernel.

    I don't get the error message as root, and direct rendering works - but only as root!

    EDIT
    Ok, I've half solved the one with the fgl_glxgears not working as root with the following:

    Code:
    Section "DRI"
     Mode 0666
    EndSection
    Though X as non root still fails first time as non-root!

    Looks like there's something wrong in dmesg; (look at lines 360 onwards);

    dmesg --
    http://pastebin.ca/1370762

    And even when X was working, I noticed this:

    (from /var/log/Xorg.0.log)
    Code:
    AIGLX error: dlopen of /usr/lib64/xorg/modules/dri/fglrx_dri.so failed (/usr/lib64/xorg/modules/dri/fglrc_dri.so : cannot open shared object file : no such file or directory)
    But I managed to fix that missing file with ' ln -s /usr/X11R6/lib64/modules/dri/fglrx_dri.so /usr/lib64/xorg/modules/dri/fglrx_dri.so !

    X Still died on 1st run though as non root.....

    ljones
    Last edited by ljones; 24 March 2009, 03:05 PM.

    Leave a comment:


  • ArTourter
    replied
    yes because simply typing lilo is really hard and complicated.

    listen, you use what you want and let every body else use what works for them, ok? your arrogant attempt at evangelism is out of place.

    as I said earlier, troll somewhere else.

    Leave a comment:


  • Kano
    replied
    Well best install grub if possible lilo is really outdated. You have to reinstall it everytime, grub only needs config file updates.

    Leave a comment:


  • ArTourter
    replied
    @Kano
    go and troll somewhere else, will ya?

    Leave a comment:


  • Kano
    replied
    You really use lilo? I currently switched over to grub2 for next system and you do not even use grub? With something like update-grub to integrated kernels automatically... Wow, that is really a legacy system.

    Leave a comment:


  • ArTourter
    replied
    I have a reply to prior your edit somehow stuck in moderation (probably due to a url I included)

    but if fgl_glxgears actually runs, that means that the fglrx driver is running which seems to be a huge improvement to your previous situation.

    regarding the framerate, I would not know as it is not something I really care about myself.

    Out of interest, did you recompile your kernel at all or this is still the stock slamd64-current kernel where you only recompile the AMD driver and initialised it?

    BTW, to explain the version difference between slackware and slamd64, the changes appear first in slack and are then ported to slamd64. 2.6.28.8 should appear in slamd64-current at the next batch of changes unless .9 or newer is released since then and slackware has it in the tree.

    Leave a comment:


  • ArTourter
    replied
    Originally posted by ljones View Post
    Yep looks like I'll have to compile a kernel. I checked the normal slackware current version (it is currently 2.6.28.8 as you say) however the slamd64 kernel current appears to be different (example here - ftp://ftp.gtlib.gatech.edu/pub/slamd...t/slackware/a/ ), they are using 2.6.28.7 . I tried installing this on the offchance that PSI_MSI would be enabled, but no luck, installing the newer kernel made no difference, no accelration.

    Guess its time to download a kernel and compile it !
    Hmm, if the 2.6.28.7 in slamd64 does not work, then I am not quite sure what else needs to be done as from the config file
    CONFIG_PCI_MSI=y
    Do you actually get the same error, or do you get something else?

    Leave a comment:

Working...
X