Announcement

Collapse
No announcement yet.

Slamd64 (64 Bit slackware) and ATI Radeon (catalyst) driver problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    ljones
    Junior Member

  • ljones
    replied
    :-( Damn! I thought I had it ....

    Now glxinfo is telloing me "Direct rendering: No" x.x !

    What could be wrong?

    Tried running aticonfig --initial, but it didn't seem to work, still direct rendering = no !

    ?? Does anyone know why direct rendering won't work ??

    ljones
    ljones
    Junior Member
    Last edited by ljones; 22 March 2009, 04:53 PM.

    Leave a comment:

  • ljones
    Junior Member

  • ljones
    replied
    I may have an answer! Or maybe - 99% of one!

    After a lot of poking about on this forum, and I forget which thread I read this on (d'oh) -- the thread was discussing problems regarding 64 bit systems, southbridge chips and 4GB of memory. It appears I may have this problem.

    I have in the bios of my motherboard (ASUS M3A78EM) enabled "Memory hole remapping" as someone on the thread I was reading suggested this, but it didn't seem to work. Still the system locked up, no X, no response to keyboard or mouse, having to hit reset!

    However there is another option, "Internal Graphics". I changed primary video controller from "GFX0-GPP-IGFX-PCI" to "IGFX-GFX0-GPP-PCI", not sure if that will make much difference. But more importantly changing another option "Frame buffer location" does seem to make a difference. Set it to "Above 4G" and it's crash and lock-up time. But set it to "Below 4G" and it works (it is set to this right now).

    Only odd thing now is if I drop back out of X, the system restarts. However X seems to be running -- I'm running the default install of XFCE 4 that Slamd64 uses, and the (admittidaly mimimal) 3D functions that can be enabled in 'window manager tweaks' and then 'compositor'.

    Glxgears seems to be a bit odd though - leave it at its default window size and I get 1424 FPS, make it twice as big and it drops to 241 FPS! No idea on that one ............

    EDIT: I also had to set the graphics cards' memory to either "auto" or "256M" (as it is on board). I don't have a 512M option. Setting it (in the bios) to 64M caused crashes again x.x .

    Just hope I'm right! :-)

    ljones
    ljones
    Junior Member
    Last edited by ljones; 22 March 2009, 04:52 PM.

    Leave a comment:

  • ljones
    Junior Member

  • Slamd64 (64 Bit slackware) and ATI Radeon (catalyst) driver problem

    Hello all !

    I'm trying to figure out how to install ATI's catalyst drivers into my install of slamd64 (that's a 64-bit version of slackware) 12.2 . Unforunatly I don't seem to be getting very far, so far I've had no success at doing this.

    Here's the system I am currently using (specs);

    * Memory - 4 GB Ram

    * Motherboard - ASUS M3A78EM

    * CPU - AMD Phenom II x4 940

    * Graphics - Onboard ATI Radeon HD 3200

    Linux kernel version = 2.6.27.7

    Unfortunatly I can't get the driver to even install properly let alone run. If I try to install the latest 9.2 catalyst driver from here ( http://support.amd.com/us/gpudownload/Pages/index.aspx ) and install it from the command line (outside of X) I get this strangeness at the end of installation;

    Code:
    n_US/LC_ADDRESS
            7f1e95a3d000-7f1e95a3000 r--p 0000000 08:01 40566
       /usr/lib64/locale/en_US/LC_TELEPHONE
                                          7f1e95a3000-7f1e95a3f000 r--p 000000
    000 08:01 40570
    5a3f000-7f1e95a40000 r---p 000000 08:01 40573              /usr/lib
    64/locale/en_US/LC_IDENTIFICATION
                              7f1e95a40000-7f1e95a4200 rw-p 7f1e95a40000 00:00 /lib64/ld-2.7.so
    And right at the bottom of the screen;

    Code:
    ./at-installer.sh: line 39:  11447 Aborted                       ./setup.data/bin/${ARCH_DIR}/setup 2>/dev/null
                                                 Removing temporary directory: fglrx-install.hxzQfq3
                                   [email protected]:~#
    BTW that's not a formatting error above in what I'm guessing are error messages, the text actually looks like that on-screen, all messed up and out of line. I get the same results from the 9.2, 9.1 and 8-12 driver.

    If I try to start X after this, it dosen't work -- I either get a completely blank screen, no X cursor or maybe some red lines or dots on the screen. The system then locks up hard; no response from mouse or keyboard - the only way out is to power off or hit the reset button.

    Even after trying 'aticonfig --initial' I get the same problem, in fact the system went to a blank screen then reset itself!

    xorgsetup also dosen't seem to work properly after installing the ATI drivers, it just crashes with these messages;

    Code:
    ast
    apm
    neomagic
    newport
    fbdev
    vesa
    vga
    
    Backtrace:
    0: /usr/X11R6/bin/X(xf86Sighandler+0x6a) [0x48666a]
    1: /lib64/libc.so.6 [0x7f764663df70]
    2: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxProbeMain+0x8fd) [0x7f764129b1bd]
    3: /usr/X11R6/bin/X(DoConfigure+0x1fa) [0x47efca]
    4: /usr/X11R6/bin/X(InitOutput+0x6a5) [0x4615f5]
    5: /usr/X11R6/bin/X(main+0x29f) [0x43017f]
    6: /li64/libc.so.6(__libc_start_main+0xf4) [0x7f764662a164]
    7: /usr/X11R6/bin/X [0x42f699]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    
    /usr/bin/xorgsetup: line 170 : 24548 Aborted      /usr/X11R6/bin/X -configure
    I've tried reinstalling slamd64 (so I'm working off a clean install) and redownloading the drivers (just in case I got a bad download) but no luck, same problem every time.

    Has anyone had any luck with the 9.2 ATI drivers at all? After googling a *lot* I'm finding most people are having *lots* of trouble x.x .... (add one to the list now!).

    Can anyone think what is wrong? Thanks

    ljones
    ljones
    Junior Member
    Last edited by ljones; 22 March 2009, 01:28 PM.
Working...
X