Announcement

Collapse
No announcement yet.

Struggle with ATi 9200M

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FreeFly
    started a topic Struggle with ATi 9200M

    Struggle with ATi 9200M

    Hi,

    I have trouble getting my Mobility Radeon 9200 to work well with recent xf86-video-ati. Before v6.8 everything were autodetected and run fine. Since then the screen just go black. I manage to work around with option "CPPIOMode" "True". However with xf86-video-ati 6.9.0, laptop completely freez with black screen. Only way I found is to disable dri, but this result in very poor performance. I will appreciate any suggestion how to fix this. Also any optimized xorg.conf for this or close videocard is wellcome.
    Computer is Sony VAIO PCG-K415S /Pentium(R) 4 CPU 3.06GHz/1GB RAM
    Card ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)] (rev 01) with 64Mb VRAM.
    Software is current Arch Linux i686, kernel 2.6.27.
    One bug report from onother user: https://qa.mandriva.com/show_bug.cgi?id=40374

    Current xorg.conf:

    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	#RgbPath      "/usr/share/X11/rgb"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/misc"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/TTF"
    	FontPath     "/usr/share/fonts/Type1"
    EndSection
    
    Section "Module"
    	Load  "glx"
    	Load  "extmod"
    	Load  "xtrap"
    	Load  "record"
    	Load  "GLcore"
    	Load  "dbe"
    	Load  "dri"
    	Load  "freetype"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "Dac8Bit"            	# [<bool>]
            Option     "BusType"            	"AGP"
            Option     "CPPIOMode"          	"True"
            #Option     "CPusecTimeout"      	# <i>
            #Option     "AGPMode"            	# <i>
            #Option     "AGPFastWrite"       	# [<bool>]
            #Option     "AGPSize"            	# <i>
            #Option     "GARTSize"           	# <i>
            #Option     "RingSize"           	# <i>
            #Option     "BufferSize"         	# <i>
            #Option     "EnableDepthMoves"   	# [<bool>]
            #Option     "EnablePageFlip"     	# [<bool>]
            #Option     "NoBackBuffer"       	# [<bool>]
            #Option     "DMAForXv"           	# [<bool>]
            #Option     "FBTexPercent"       	# <i>
            #Option     "DepthBits"          	# <i>
            #Option     "PCIAPERSize"        	# <i>
            #Option     "AccelDFS"           	# [<bool>]
            #Option     "DDCMode"            	# [<bool>]
            #Option     "IgnoreEDID"         	# [<bool>]
            #Option     "DisplayPriority"    	# [<str>]
            #Option     "PanelSize"          	# [<str>]
            #Option     "ForceMinDotClock"   	# <freq>
            #Option     "ColorTiling"        	# [<bool>]
            #Option     "VideoKey"           	# <i>
            #Option     "RageTheatreCrystal" 	# <i>
            #Option     "RageTheatreTunerPort" 	# <i>
            #Option     "RageTheatreCompositePort" 	# <i>
            #Option     "RageTheatreSVideoPort" 	# <i>
            #Option     "TunerType"          	# <i>
            #Option     "RageTheatreMicrocPath" 	# <str>
            #Option     "RageTheatreMicrocType" 	# <str>
            #Option     "ScalerWidth"        	# <i>
            #Option     "RenderAccel"        	# [<bool>]
            #Option     "SubPixelOrder"      	# [<str>]
            #Option     "ShowCache"          	# [<bool>]
            #Option     "DynamicClocks"      	# [<bool>]
            #Option     "VGAAccess"          	# [<bool>]
            #Option     "ReverseDDC"         	# [<bool>]
            #Option     "LVDSProbePLL"       	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            Option     "DRI"                	"False"
            #Option     "ConnectorTable"     	# <str>
            #Option     "DefaultConnectorTable" 	# [<bool>]
            #Option     "DefaultTMDSPLL"     	# [<bool>]
            #Option     "TVDACLoadDetect"    	# [<bool>]
            #Option     "ForceTVOut"         	# [<bool>]
            #Option     "TVStandard"         	# <str>
            #Option     "IgnoreLidStatus"    	# [<bool>]
    	Identifier  "Card0"
    	Driver      "ati"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "M9+ 5C61 [Radeon Mobility 9200 (AGP)]"
    	BusID       "PCI:1:5:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection

  • FreeFly
    replied
    I rebuild new package for fun, driver now works with clean configuration. Thank you very much and happy new year .

    Leave a comment:


  • agd5f
    replied
    Originally posted by FreeFly View Post
    Here is: lshwlist
    thanks! pushed:
    c39ca66a7e216b7492fc5e3680ac535831cfb9a1

    Leave a comment:


  • FreeFly
    replied
    Here is: lshwlist

    Leave a comment:


  • agd5f
    replied
    Sorry, the log doesn't print the subsystem pci ids anymore. Can you pastebin 'lspci-vn'?

    Leave a comment:


  • FreeFly
    replied
    Done: xorg.0.log

    Thank You!

    Leave a comment:


  • agd5f
    replied
    Originally posted by FreeFly View Post
    AGPMode=1 work with dri enabled. It is a lot better now. I also try 2,3,4,6,8 which doesn't. Is there anything more I can do?
    That should do it. Older versions of the driver used to default to the lowest AGP mode (1 or 4 depending on the AGP version). Newer versions of the driver default to whatever mode was set by the bios. The latter method has proven more reliable, but there are still cases where this doesn't work. Unfortunately AGP chipsets tend to be broken in various ways so it's hard to get it to work reliably in all cases. If you can pastebin your xorg log I can add a quirk to set the proper AGP mode for your card/chipset combo so you won't have to add the option in the future.

    Leave a comment:


  • FreeFly
    replied
    AGPMode=1 work with dri enabled. It is a lot better now. I also try 2,3,4,6,8 which doesn't. Is there anything more I can do?

    Leave a comment:


  • bridgman
    replied
    I assume starting with "1" is a good idea ?

    Leave a comment:


  • agd5f
    replied
    try adjusting the agp mode, e.g.,

    Option "AGPMode" "i"

    where i = 1 or 2 or 4 or 8.

    Leave a comment:

Working...
X