Announcement

Collapse
No announcement yet.

Problems with fglrx (F10, rpmfusion)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with fglrx (F10, rpmfusion)

    I'm running the F10 preview+fixes, which isn't of course necessarily supported by the ati driver just yet (I gave up waiting on F9), but I get the following issues.... has anyone got this combo working at all?

    I used the prebuilt module, and driver from rpmfusion -- based on 8.11 beta. I did also try the new ATI driver, doing a regular install, but had the same issue with interrupts.

    II) Reloading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (==) fglrx(0): Capabilities: 0x00000000
    (==) fglrx(0): CapabilitiesEx: 0x00000000
    (==) fglrx(0): cpuFlags: 0x8000001d
    (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
    (**) fglrx(0): ATI GART size: 255 MB
    (II) fglrx(0): [pcie] 261120 kB allocated
    (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
    (==) fglrx(0): UseFastTLS=0
    (==) fglrx(0): BlockSignalsOnLock=1
    (II) fglrx(0): Direct rendering enabled
    (EE) fglrx(0): Failed to enable interrupts.
    (--) Depth 24 pixmap format is 32 bpp

    ... then...
    drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
    (II) fglrx(0): [drm] DRM interface version 1.3
    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0xf8a65000
    (II) fglrx(0): [drm] mapped SAREA 0xf8a65000 to 0xb7e84000
    (II) fglrx(0): [drm] drmAddMap failed
    (EE) fglrx(0): DRIScreenInit failed!
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0x0 FBMappedSize: 0x10000000
    (EE) fglrx(0): FB pci_device_map_range error!(EE) fglrx(0): Failed to map FB mem
    ory
    (II) fglrx(0): === [atiddxScreenInit] === end

    Fatal server error:
    AddScreen/ScreenInit failed for driver 0

    (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.
    .. and in the system log....

    Nov 17 00:16:31 snowdon kernel: [fglrx] Maximum main memory to use for locked dm
    a buffers: 2894 MBytes.
    Nov 17 00:16:31 snowdon kernel: [fglrx] vendor: 1002 device: 71c4 count: 1
    Nov 17 00:16:31 snowdon kernel: [fglrx] ioport: bar 1, base 0x2000, size: 0x100
    Nov 17 00:16:31 snowdon kernel: pci 0000:01:00.0: setting latency timer to 64
    Nov 17 00:16:31 snowdon kernel: [fglrx] Pat entry 2 is already configured
    Nov 17 00:16:31 snowdon kernel: [fglrx] PAT is enabled successfully!
    Nov 17 00:16:31 snowdon kernel: [fglrx:firegl_init_module] *ERROR* firegl_stub_r
    egister failed
    Nov 17 00:16:31 snowdon kernel: [drm:drm_buffer_object_create] *ERROR* Illegal b
    uffer object size 0.
    Nov 17 00:16:31 snowdon kernel: [drm:drm_buffer_object_create] *ERROR* Illegal b
    uffer object size 0.
    Nov 17 00:16:31 snowdon gdm-binary[16246]: WARNING: GdmDisplay: display lasted 2
    .465200 seconds

  • #2
    Have you tried using 8.11?
    Edit: Oops, those aren't in the repo yet... I've submitted them for building, they should be available soon.
    firewing1
    Junior Member
    Last edited by firewing1; 17 November 2008, 01:31 PM.

    Comment


    • #3
      I've tried using the new 8.11 drivers from the repo (with F10) and upon the point of launching X, the machine hard locks with a blank screen. Keyboard doesn't respond (even the num/cap/scroll lock lights) and am unable to SSH in.

      This didn't happen with the previous drivers (the 8.11beta). I could get X to launch it just had EXTREMELY POOR 2D performance and 3D was broken.

      I just installed the drivers this morning before leaving for work, and haven't had a great deal of time trying to troubleshoot other than hitting the reset button a couple times and trying to SSH in from another box.

      Comment


      • #4
        I didn't think we supported F10 at this point; AFAIK a lot of the F10 internals are "newer than upstream" right now.
        Test signature

        Comment


        • #5
          @planetf1

          always compile the fglrx kernel module - you can not use an old one. If you don't know how to unload it then reboot.

          Comment


          • #6
            Originally posted by bridgman View Post
            I didn't think we supported F10 at this point; AFAIK a lot of the F10 internals are "newer than upstream" right now.
            At the moment F10 is using the standard 1.5.2 Xserver, so it should be similar to Ubuntu Intrepid. I've narrowed down the black screen problems to libfglrxdrm.so. While you can't ssh after X hangs, it seems to work fine if you ssh before... I ran "startx -- :1" and this was the result:
            Code:
            /usr/bin/X: symbol lookup error: /usr/lib64/xorg/modules/drivers//fglrx_drv.so: undefined symbol: firegl_QueryMCRange
            I've compared my logs to those of users running Intrepid and the difference is that libfglrxdrm.so isn't loaded by Xorg, so this is why DRM fails and it also explains the undefined symbols.
            Firewing1

            Comment


            • #7
              bridgman,

              Are there plans to have FC10 support in 8.12? I would be more than happy to keep using the radeon driver but on my 9800 pro and my mobile x700 any time I start up a 3d app my machines lock up hard.

              Comment


              • #8
                I doubt it. Our official support is for RHEL not Fedora.

                Are your systems AGP or PCIE ? I'm guessing AGP -- and I believe there are some known issues with AGP boards in F10 being worked through now.

                For the short term I believe forcing AGP 1X or PCI helps a lot, and the #radeon IRC channel lets you watch the F10 AGP issues being debugged in real time
                Test signature

                Comment


                • #9
                  My son has fedora 10 and needs a fast card for 3D games.
                  Should I wait or buy a nvidia?

                  Comment


                  • #10
                    Is there an email to contact ATI support or sales?
                    There is no way to do it from their website unless I have a product number: I am getting quite upset at AMD and just about to go elsewhere!

                    Comment

                    Working...
                    X