No announcement yet.

USB Wireless Adapters

  • Filter
  • Time
  • Show
Clear All
new posts

  • USB Wireless Adapters

    I was wondering if Phoronix is ever going to tests of usb wireless devices. I think it would be a very useful test as these devices are often used in desktops and even some laptops. But, the reason that it's most useful is that so many usb wireless devices have manufacturers that have a chipset change in a new version. So, two people will discuss the same wireless adapter but later discover that one of them have a different version than the other (and also discover that the chipset is changed and not supported).

    Okay, with that said, my question is about which chipset and usb wireless adapter brand would be good to buy? I have a Belkin USB Wireless adapter w / model F5D7050 ver. 4000. It was initially a good decision and worked okay. But, I've since discovered that it doesn't work all that well and has connection freezes or other issues. I googled and discovered that oher people have problems with the device. It has a Zydas chipset (that uses zd1211rw driver and now the MAC driver) but that isn't the problem. I learned that other intangibles are involved such as antenna and other hardware.

    So, which brand and chipset should I buy? I googled and researched and for Linux (and I guess it could apply to Windows somewhat as some manufacturers have better Windows-oriented software than others) and figure the best chipsets to obtain are:
    Zydas (re-named some Atheros chipset)

    I've narrowed it down to 4 different adapters:
    TRENDnet TEW-429UB Zydas - zd1211rw or Mac driver
    Airlink AWLL3026 54Mbps 802.11g Wireless USB Adapter - Zydas (ditto)
    D-Link WUA-1340 - Ralink - rt73
    Linksys WUSB54GC - Ralink - rt73

    I listed the device brand, chipset and probable driver (used)

    Comments? Advice? Recommendations?

    I'm considering buying one of each, one Zydas-based device and one Ralink-based and then testing it out.

    One other caveat. It seems the devices with the Ralink chipset only get better supported with later kernels. I believe I have read that the Ralink-based chipset which use the rt73 driver have the drivers built into the 2.6.24 (24) kernel and on. Any distro that uses a previous kernel would require some tweaking to get the device to work properly.

    As for the Zydas-based chipset, those devices work (supposedly) from kernel 18 and on. But, I read that there is some sort of 'bug' existing in the later kernels for Zydas-based devices but it's a doable fix. This was reported, in particular, in Ubuntu.

    With all that said, which brand/chipset do you recommend? ;-)

  • #2
    Not one person cares about this (hardware)?

    Or it was a badly constructed message/post? Hmmm...


    • #3

      Originally posted by Panix View Post
      With all that said, which brand/chipset do you recommend? ;-)
      You have a list here:


      • #4
        I only had experience with Zydas chipset, and it wasn't too cheering...
        I found 2 open-source drivers: "official" and the modified one - neither worked further than detecting the device.
        With ndiswrapper device was properly detected and initialized, but strangely, USB disconnect was occuring with device still being plugged in the port.

        Maybe I just had wrong firmware for the open-source driver, but I also tested a few and none of them worked...


        • #5
          what you want is a zd1211 device..

          the driver included in the kernel works excellently..

          the belkin one is weird, not all of those fd 7050 have zydas.


          • #6
            This was a couple years ago, and I'm sure support has gotten better since then, but I was none too impressed with a Zydas USB wireless adapter I got for my desktop. When it worked, it worked wonderfully (using the aforementioned zd1211 drivers), but the driver didn't successfully build for all the distro kernels I tried, and caused some seemingly random hard lockups on ones that did. Again, this was a couple years ago, and hopefully things have improved since then.

            After that, I got an Atheros-based wireless PCI card. Worked much better, and I used that for a while. Atheros-based PCMCIA cards (and probably also ExpressCard devices) are also widely available for laptops, and that is what I would recommend. Since then, I've moved the router closer to the desktop so I could hook it up wired, but that's my experience.


            • #7
              I think I'm going to get one of the devices I listed in my original post. But, I think the zydas/zd1211rw has major issues. I believe they are using a MAC driver now. I can't get my Belkin adapter to work as it is rare that it works out of the box even though the drivers are supposedly built into the kernel (2.6.22+).

              I messed with it for so long in the past and just don't want to spend time doing that again. For this reason, I don't want to use ndiswrapper. I think that these should work out of the box, it's 2008 and wireless is required and very common. I know most manufacturers have to reverse-engineer since most of them are configured with Windows drivers but then the Linux developers should work on better network manager software. Why has Network Manager worked like utter crap for over 7 kernel updates/upgrades and why hasn't there been any decent alternatives? I think WICD is now part of some distro packages, I'm not sure. But, will that solve anything?

              I was frustrated with the Belkin although it did work at times but it seemed it always by chance. I will try another zydas/zd1211rw-based device and a device based on the Ralink rt73 chipset. I think for distros with the more recent kernels, those r73 chipsets are built in so maybe they work better?


              • #8
                networkmanager isnt a kernel thing..


                • #9
                  I never said 'Network Manager' is a kernel thing. Read what I posted.

                  I have now tried TWO (can you read that?!?) zydas/zd1211-based devices and neither work (out of the box). But, it's claimed it does work on the box on the Linux wireless site. Why that site is trying to promote devices/chipsets that don't work (without major tweaking is beyond me). I also don't know why sites like these don't do tests on usb wireless devices. I guess Linux users don't use them or don't care.

                  I know the ubuntu forums and other busy Linux-oriented forums have tons of posts of people having troubles with their usb wireless devices. So many claim this and this works but there are NO instructions or evidence that 'DEVICE/CHIPSET A' works. How do I know this? Because everyone would be buying chipset/device A and announcing 'hey, easy as pie, buy this! And support Linux.'

                  I've already been down this road before and if I had to rely only on Wireless like I did before, I would give up on the zydas/zd1211 chipset for good. What a sham.

                  I don't know whether it's worth it to try the Ralink-based chipset devices. It just seems that NO ONE in the Linux world cares about making wireless work especially when it comes to usb-based adapters. USB wireless adapters are already in 'N' technology and you can't even find 'G' adapters that work. Sure, you can spend hours tweaking or hours upon hours fiddling with ndiswrapper but at least stop with claims that chipset XYZ works.

                  I know it has worked before but it's inconsistent and it's not clear when and why it works.


                  • #10
                    Well... I have an A-link WL54USB wifi adapter, detected as "Zydas USB2.0 WLAN", and I have never have had any problems with it. Worked out of the box with Mandriva 2008.0 and 2008.1, and worked perfect with OpenSUSE 11.0 KDE4 Live CD, too. Didn't have to do anything but choose the network to connect to. It's odd that yours doesn't work...

                    I have also used a USB-stick with r2500-chipset if I remember correctly, and can't get it to work. Except once with ndiswrapper, but even then it was very unreliable.