Announcement

Collapse
No announcement yet.

X-Plane 11 Realistic Flight Simulator Now Available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • simonalsn
    replied
    Originally posted by wagaf View Post

    ... I wonder if NASA pilots could actually use X-Plane for training.
    Well since the space shuttle has been retired, probably not :-P If that was not the case it might be a good place to start, but they would need the entire cockpit to train properly.
    Last edited by simonalsn; 01 April 2017, 11:48 AM.

    Leave a comment:


  • niner
    replied
    Originally posted by wagaf View Post
    Yes the Space Shuttle in X-Plane is amazing, it's very realistic. You can see YouTube videos of the actual Shuttle approach and it's really the same thing. I wonder if NASA pilots could actually use X-Plane for training.
    It appears to me that the Space Shuttle simulation in FlightGear has become much more advanced than the one in X-Plane even though X-Plane has had it for much longer. For example in FlightGear you cannot just land the Shuttle but actually do the full flight from lift off to orbital insertion, to orbital operations to de-orbit and finally the landing. And not just on Edwards Airforce base but on all the Shuttle landing sites. You can also perform launch abort operations and land the shuttle at a launch abort site. The documentation for FlightGear's Space Shuttle is NASA's Space Shuttle crew manual which you can find online. The goal is that if NASA's manual describes it, that's the way it should be simulated. The shuttle is a much more complicated beast than you see in the X-Plane videos. E.g. there's different control modes for the Reaction Control System which actually allow you to chose the compromise between accuracy of keeping your attitude and fuel usage.

    Trying to get the shuttle into a good, circular orbit is quite a challenge and finally pushed me to replace my inaccurate joystick with a high quality Flightstick

    And the best thing about FlightGear is that it's free software and works very well with AMD's free drivers, too.

    Leave a comment:


  • shmerl
    replied
    Originally posted by Ehvis View Post

    X-Plane needs compatibility profiles, which are not officially supported by the open source drivers. This will be the case until XP11 switches to a Vulkan based renderer. IIRC, there is an option to force it to run anyway.
    Why are they using compatibility profiles? That's a huge no go.

    Leave a comment:


  • mczak
    replied
    Originally posted by mlau View Post

    I think this is due to the developers targeting Macs as well, and apple has a woefully outdated opengl stack.
    Macs may have a outdated opengl stack, but what they share with mesa is that they do not support compatibility profiles. So, if you can run on macs, this should pretty much guarantee you won't need any features not available with mesa based drivers.

    Leave a comment:


  • schmidtbag
    replied
    It's a bit ridiculous to prevent something from being installed because you're using unsupported GPUs. Giving the user a warning saying something along the lines of "Warning: your graphics drivers are unsupported. Compatibility profiles, stability, and performance may be compromised. We are not responsible for any issues you encounter. Continue at your own risk" and just leave it at that. They could always do what Feral does and only help those who supply system logs. If you have a request and you're using unsupported drivers, they don't have to continue any further with helping you.

    Leave a comment:


  • Ehvis
    replied
    I think this is due to the developers targeting Macs as well, and apple has a woefully outdated opengl stack.
    The most important reason is probably the plugin interface. The whole 3rd party addon stuff is based on allowing plugins to render directly. This is not possible with the core profiles. Since 3rd party products are far more important to X-Plane than supporting open source drivers, it was an easy choice.

    They have already posted some things about changing the way plugins render and this will eventually happen to make sure the engine can switch to Vulkan/Metal.

    Leave a comment:


  • mlau
    replied
    Originally posted by [email protected] View Post
    X-Plane needs compatibility profiles.
    That's a big red sign on my book.
    I think this is due to the developers targeting Macs as well, and apple has a woefully outdated opengl stack.

    Leave a comment:


  • M@GOid
    replied
    Originally posted by Ehvis View Post

    X-Plane needs compatibility profiles.
    That's a big red sign on my book.

    Leave a comment:


  • Ehvis
    replied
    Originally posted by debianxfce View Post
    X-Plane does not support the Gallium driver stack.
    X-Plane needs compatibility profiles, which are not officially supported by the open source drivers. This will be the case until XP11 switches to a Vulkan based renderer. IIRC, there is an option to force it to run anyway.

    Leave a comment:


  • mike44
    replied
    Yes, Michael at your age you were a Privatpilot? Why you stopped flying?

    @debianfxce Check x-plane.org forums. Some users reported success with opensource drivers and with the --force_run argument.
    http://forums.x-plane.org/index.php?...rivers/&page=3

    Leave a comment:

Working...
X