Announcement

Collapse
No announcement yet.

R600g+SI Dota 2 Benchmarks With Mesa 11.2, Linux 4.5 Show Open Driver Progress

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • humbug
    replied
    Originally posted by Dukenukemx View Post
    It's been well known that DOTA2 likes Open Source drivers.
    The new game engine seems to have a really good openGL implementation. Most linux players in the Dota2 community reported an improved experience with the engine switch. Apart from the new Fiji results performance seems to scale very well across the different GPUs according to the capabilities of the hardware.

    Leave a comment:


  • Michael
    replied
    Originally posted by ernstp View Post
    Btw I don't think AMDGPU supports SwapBuffersWait at all? vblank_mode works however.
    PTS unconditionally always sets vblank_mode=0. I hadn't checked to see if SwapBuffersWait is used by AMDGPU but have always kept it set whenever testing since usually when I do Radeon tests, generally doing AMDGPU tests too.

    Leave a comment:


  • ernstp
    replied
    Btw I don't think AMDGPU supports SwapBuffersWait at all? vblank_mode works however.

    Leave a comment:


  • ernstp
    replied
    Originally posted by Kano View Post
    Why do you need a PCI ID for modesetting? That's a generic driver! You don't need to install the amdgpu ddx.
    https://cgit.freedesktop.org/xorg/xs...f96238eecf2c3e

    Leave a comment:


  • Kano
    replied
    Why do you need a PCI ID for modesetting? That's a generic driver! You don't need to install the amdgpu ddx.

    Leave a comment:


  • ernstp
    replied
    Michael: I made a build of xorg-modesetting for 15.10 that has Fury in it's list of PCI IDs, if you're interested: https://launchpad.net/~ernstp/+archi...es_filter=wily

    Leave a comment:


  • Michael
    replied
    Originally posted by abu_shawarib View Post
    I had this error when running the test:

    LoadSystemDependencies():
    AppSystemDict: Error in Connect() of interface 'GameUI011'!

    Missing dependency?
    Yeah it's a weird one... I hit it initially as well. Unrelated to PTS, others have ran into it too: https://github.com/ValveSoftware/Dota-2/issues/105

    The fix from that thread did work: sudo ln -s /lib/x86_64-linux-gnu/libudev.so.1 /lib/x86_64-linux-gnu/libudev.so.0

    Leave a comment:


  • abu_shawarib
    replied
    I had this error when running the test:

    LoadSystemDependencies():
    AppSystemDict: Error in Connect() of interface 'GameUI011'!

    Missing dependency?

    Leave a comment:


  • Michael
    replied
    Originally posted by duby229 View Post

    hmm, Can't wait to hear more about this discovery!
    At first it looked like it was a regression in DRI3 as during that second run, still had accidentally had my xorg.conf.d of DRI3 (enabled) +SwapBuffersWait (disabled) set to the radeon DDX rather than the amdgpu ddx as I was testing some other non-AMDGPU hardware in between there... So I thought that was it, but now in going back through and trying out different DDX options for AMDGPU, not yet able to figure out if it was just a fluke or what.

    Leave a comment:


  • smitty3268
    replied
    So I guess the 4.5 rc3 kernel fixed your Fury powerplay issues?

    Leave a comment:

Working...
X