Announcement

Collapse
No announcement yet.

Radeon Linux Drivers Now Only Officially Support Smart Access Memory On Zen 3 + RDNA2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon Linux Drivers Now Only Officially Support Smart Access Memory On Zen 3 + RDNA2

    Phoronix: Radeon Linux Drivers Now Only Officially Support Smart Access Memory On Zen 3 + RDNA2

    While many Linux users were excited when finding out the open-source AMD Radeon Linux drivers were allowing Smart Access Memory (Resizable BAR) support on older motherboards/CPUs and older Radeon GPUs rather than basically the very latest AMD products as seen on Windows, there is a change of course due to bugs. Now, officially, Mesa 21.0 is just enabling Smart Access Memory for systems with AMD Zen 3 processors and RDNA 2 graphics cards though if you have other hardware you can force-enable it...

    http://www.phoronix.com/scan.php?pag...AM-Zen-3-RDNA2

  • #2
    Fresh Mesa 21.0 benchmarks coming up soon on Phoronix.
    Please test OpenGL and make sure to include the just merged commit for https://gitlab.freedesktop.org/mesa/..._requests/8111
    A few other optimizations were also merged in before that one benefitting core Mesa but mostly OpenGL drivers.
    It seems Mesa 21.0 will be a great release with emphasis on optimizations.

    Comment


    • #3
      I understand that radv will do the opposite thing compared to RadeonSi? Have it enabled by default with the flag to disable it if it causes problems in a certain game. Imo this approach makes more sense because 4g decoding / resizable bar is disabled in bios by default anyway and users are willingly enabling it to have SAM support.

      Comment


      • #4
        That means Radeon 5700 XT which I bought recently, especially with Linux in mind, will have this feature enabled by default Yay!

        Comment


        • #5
          Originally posted by piorunz View Post
          That means Radeon 5700 XT which I bought recently, especially with Linux in mind, will have this feature enabled by default Yay!
          The 5700XT is RDNA1, not RDNA2. It won't have this feature enabled by default - but it should soonTM be default once the bugs are exterminated.

          Comment


          • #6
            While I have seen and reported an issue with SAM on hardware I no longer own, I cannot reproduce it any longer on my new hardware and users on the problematic platform reported that a new BIOS solved the issue they have seen on AM4: https://gitlab.freedesktop.org/drm/amd/-/issues/1039

            My conclusion would be that it wasn't a user-space issue to begin with, and having an environment variable to turn it off would be better suited to make widespread use of the feature and the ability to turn it off where it hurts.

            Comment


            • #7
              Originally posted by Shevchen View Post

              The 5700XT is RDNA1, not RDNA2. It won't have this feature enabled by default - but it should soonTM be default once the bugs are exterminated.
              Oh no! I searched specifically to determine first what is that RDNA, my card seemed to qualify on the first look, I have it enabled right now:
              Code:
              [drm] Detected VRAM RAM=8176M, BAR=8192M
              Hopefully it will stay that way

              Comment


              • #8
                Originally posted by piorunz View Post

                Oh no! I searched specifically to determine first what is that RDNA, my card seemed to qualify on the first look, I have it enabled right now:
                Code:
                [drm] Detected VRAM RAM=8176M, BAR=8192M
                Hopefully it will stay that way
                Yes, you enabled it in the BIOS and did UEFI boot your system. That is an requirement to get the extended BAR support up and running.
                Next, you need a graphics driver that actually uses the extended BAR for faster/more efficient memory transfers. And this is what the AMDGPU driver and the MESA driver on top of it need to provide. So, you manually need to tell MESA to use SAM because your GPU is RDNA1 and not RDNA2.

                On a side note.
                The German computerbase.de forum members did some SAM tests (under Windows) with different (non Zen3) CPUs and (non RDNA2) GPUs. And SAM did work for many of them even with old GPUs (R9 390)...
                https://www.computerbase.de/2020-12/...20-12-30T10:14

                Comment


                • #9
                  ms178 6827 commit from Bas fixed it even if your BIOS would set it wrongly.
                  mibo SAM requires a certian motherboard, the GPU is irrelevant, although users who didn't get a new BIOS will still see poor performance if they turn it on, at least on windows.
                  Fun fact: 5 years after release Battlefield 1 works well on DX12 without any stutter.

                  Comment


                  • #10
                    [QUOTE=fenixex;n1230325... the GPU is irrelevant[/QUOTE]
                    ???
                    I disagree.
                    1. The GPU decides (according to the article we discuss) whether SAM will be activated by the MESA driver (RDNA2) or not (different GPU).
                    2. AMDs argument to do so is that they do not verify the correct behaviour of older GPUs with SAM enabled. So, depending on the GPU (generation) it might work or trigger bugs.

                    What is (IMHO) interesting is that many (non RDN2) GPUs seem to have a driver code-path (under Windows, see my computerbase link) to support extended BAR and benefit from activating SAM. Therefore, I hope that we also can use extended BAR with non RDNA2 GPUs under Linux and get some additional performance.



                    Comment

                    Working...
                    X