No announcement yet.

Radeon Linux Drivers Now Only Officially Support Smart Access Memory On Zen 3 + RDNA2

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by fenixex View Post

    That was a BIOS issue leading to miserable 1% lows on Windows as the game would only use 256MS of VRAM. On linux the issue got fixed in mesa by the commit I mentioned previously. With a new BIOS which explicitly enabled extended BAR support this should also be fixed on windows. I can confirm that in bf1 where previously i would get around 50fps, but moving the camera would cause a hard fps drop. With the new BIOS all runs smoothly.
    EDIT: on rx480
    BIOS for the motherboard, or video card?

    I have a PRIME X470-PRO, 2700X, and RX 580. On Windows and Linux, I can do above 4G decode no problem.

    On Windows, if I do Resizable BAR, all VRAM reporting gets broken seemingly. Radeon's control panel reports infinity VRAM (lol). Anything using Vulkan breaks (most things with DXVK just flickered; Dota 2 ran incredibly slow, Oculus Link's dash stops working). I think a D3D11 game worked fine though with quick testing. This happens with 20.11.1 and ASUS 5809 BIOS (latest).

    On Linux, I haven't done any actual gaming or testing, but dmesg reports a 8192M BAR with Resizable BAR enabled, which I assume means it's fine.


    • #22
      Although it appears I was wrong.
      So Unigine Heaven reports my card as "Unknown GPU (256MB) x1" and the 1% lows and just like artivision described , but running it through Wine reports "AMD RADV POLARIS10 (ACO) 1.0 (3072MB) x1" ?
      Witcher 3 is capped at 2GB VRAM and the fps is down.
      DOOM on openGL shows some ridiculous size, but on Vulkan it displays 8GB and it has a higher fps.
      Mesa version is 20.2.4


      • #23
        The article is about MESA 21.x getting SAM support.
        Could you try if that fixes the problems you see?


        • #24
          Originally posted by fenixex View Post
          So Unigine Heaven reports my card as "Unknown GPU (256MB) x1"
          That's probably a default value, because Unigine doesn't support any of the OpenGL extensions Mesa provides for determining the real value.


          • #25
            Originally posted by Shevchen View Post

            The 5700XT is RDNA1, not RDNA2. It won't have this feature enabled by default - but it should soonTM be default once the bugs are exterminated.
            Hahaha, this is AMD. They'll never fix those bugs. "We removed it because of bugs" and then they never work on fixing those bugs.

            "We're totally not doing this for artificial restriction, totally. It's just that there are bugs in the code for older hardware that we'll conveniently never fix. So I guess we are artificially restricting it"


            • #26
              Originally posted by fenixex View Post
              ms178 6827 commit from Bas fixed it even if your BIOS would set it wrongly.
              mibo SAM requires a certian motherboard, the GPU is irrelevant, although users who didn't get a new BIOS will still see poor performance if they turn it on, at least on windows.
              Fun fact: 5 years after release Battlefield 1 works well on DX12 without any stutter.
              What about crashes though? That thing was pretty unstable on DX12 on an AMD card, for me. A shame, since enabling the DX12/Vulkan renderer for a game almost always results in performance improvements in my experience.


              • #27
                I didn't have any cashes in bf1 nor swbf2.Both dx12.
                mibo will try it soon.


                • #28
                  Been running my main OS with SAM enabled for a while now and no problems with any of my games. RX480, so don't know. To be honest I haven't looked at the reported "many people experience performance degradation on some systems" so I may just be lucky with my particular hardware configuration. At least they are leaving the option to enable it.


                  • #29
                    Originally posted by sandy8925 View Post
                    Hahaha, this is AMD. They'll never fix those bugs. "We removed it because of bugs" and then they never work on fixing those bugs.
                    You are aware that the bugfixing is done by the MESA Devs and not by AMD? Good job shitting in your own bed.


                    • #30
                      I have 5700 XT.
                      Experienced very low fps under Wine games on Linux, so I tested Unigine Superposition benchmark on Windows. Benchmark score 6000. Turned off Above 4GB Decoding in BIOS again, everything went back to normal = score 17400.
                      I installed Superposition on Linux as well.
                      Above 4GB Decoding=On and BAR=8192 = result 10000 in benchmark.
                      Above 4GB Decoding=Off and BAR=256 (default) = result 15300 in benchmark.

                      Mobo: Gigabyte model: AB350-Gaming 3-CF
                      UEFI: American Megatrends v: F51b date: 07/02/2020 (latest version)

                      OpenGL:renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0 5.10.2-2-MANJARO
                      LLVM 11.0.0)
                      v: 4.6 Mesa 20.3.1 direct render: Yes

                      So this is AMD drivers on Windows, and Mesa on Linux which needs to impove, or is it Gigabyte mobo BIOS?
                      I understand what AMD said there is bugs and it will be disabled on my GPU by default, but I didn't anticipated 66% drop.
                      Last edited by piorunz; 09 January 2021, 12:43 PM.