No announcement yet.

Trying Out Wayland With Rebecca Black

  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying Out Wayland With Rebecca Black

    Phoronix: Trying Out Wayland With Rebecca Black

    For those that may have extra time this weekend and have been meaning to try out the experimental Wayland Display Server, one of the easiest ways to try out this eventual X.Org Server replacement is by using a Wayland LiveCD that's dubbed Rebecca Black. Besides including a recent snapshot of Wayland, it also integrates the support for various tool-kits and other applications...

  • #2
    Was it released on Friday?


    • #3
      Awesome! But just a clearification, XWayland, the nested xserver for Wayland IS built, it's just that xwayland doesn't seem to be in a fully working state yet. (the contents of the windows don't refresh)

      Also I am working on trying to make an updated, more recent ISO soon, so don't worry about the Febuary date.


      • #4

        When will we see Jock Linux?


        • #5
          Originally posted by allquixotic View Post
          Was it released on Friday?
          Tomorrow is monday and the day after thursday is friday and saturday comes afterwards.


          • #6
            In the mean time, atleast I have the jockstick. That is all I say.


            • #7
              kids react!


              aww, I like rebecca, but me like annoying orange bettar!

              Last edited by madjr; 26 March 2012, 08:39 AM.


              • #8

                I like Heroin Day better.

                Heroin day, heroin day.
                Where I tweak and listen to 3rd order distortion on my tubeamp.
                Heroin day, heroin day.


                • #9
                  I was trying it out earlier when, after starting another instance of Wayland (that's what it was as far as I could tell), the screen froze. I then rebooted (Ctrl+Alt+Del worked) and ever since that it won't boot up properly. It hangs either with a bunch of "?" characters in the upper left corner of the screen, or just with a black screen. I've tried re-writing the ISO to the USB stick, but still same deal. I don't really understand why it could work one time and then now it doesn't work even though I've rewritten the image to make sure nothing had changed on my USB stick.

                  Any ideas on what I could do to solve this? Are there any logs stored anywhere that could be useful?


                  • #10
                    Wrote the image to my USB stick a third time and now it works! (until it hangs. but I suspect this is a GPU driver bug and not Wayland's fault as it happens here in Natty as well (though Natty recovers after 10 seconds or so)).

                    I tried running programs in /usr/local/bin and it seems the demos work. I'm not sure which are demos and which are "normal" applications that aren't expected to work. I get a lot of "Segmentation fault (core dumped)" and errors that say this (usually the two errors are combined, if I recall correctly):
                    Failed to load platform plugin "wayland". Available platforms are: 
                    It's really cool to see, for example, the sample-egl program and the ability that I'm able to rotate anything (via Super+Alt+Right Mouse). Looks *really* smooth.

                    Thanks for your work on this distro!