Announcement

Collapse
No announcement yet.

Memory speed on the R9 290 is only 150mhz????

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Memory speed on the R9 290 is only 150mhz????

    Well, I discovered something funny about my R9 290 and its memory speed...

    I was playing with the Gallium HUD and noticed that...

    The memory speed of the R9 290 is stuck at 150mhz according to gallium, this is with the low power profile, let's set it to performance:

    Shader clock now changes... however memory clock remains at 150mhz!

    Wait a moment! I have a 7970 on the computer upstairs, let's have a look:

    Oooh the 7970 which is performing much, much faster doesn't clock the memory at 150mhz, instead it is 1.55Ghz! on the low power profile!!!

    I have tried many games with the HUD and in the 290 no matter what; the memory speed remains constant at 150Mhz, the shader clock also exhibits a different behavior in the 290 than in the 7970, in low profile is stuck, and very low in performance profile, however let's concentrate on the memory clock first.

    I'm wondering, is there a way that I can manually force the frequency of the memory on the R9 290?

    Can anybody help me with this?

    I know Michael also has a 290 that doesn't perform well, Michael, can you please, (or anybody else's affected by an slow 290) check if your 290 exhibits the same behavior?

    My card flies on Windows by the way, I'm afraid something is wrong when handling the memory clock speed in the 290 in Linux, if there was a way to force the speed to be I do now know 1Ghz at least I would be able to test if my suspicions are correct.

    I'm using Ubuntu 16.04.2 Mesa dev and Kernel 4.8.x

    GALLIUM_HUD="fps+cpu,VRAM-usage,shader-clock+memory-clock" glxgears

    can show the shader and memory clocks.

  • #2
    Use a rolling release distribution, mesa master git and a custom agd5f/linux/?h=drm-next-4.12-wip kernel. Use the amdgpu kernel driver and enable CIK and SI support, see:
    https://www.phoronix.com/forums/foru...in-living-room

    Comment


    • #3
      Update your firmware:
      https://git.kernel.org/pub/scm/linux...x-firmware.git

      Comment


      • #4
        Originally posted by agd5f View Post
        Nope... that was the very first thing I tried. :-( My impression is that the dpm code is f***ed for the 290

        I have read somewhere that due to a bug in the dpm if you plug a second monitor it makes the memory clock run at the highest frequency, I'm going to try find another monitor to test if something happens, I can observe that behavior on my 7970 already so...
        Last edited by JPFSanders; 03-20-2017, 05:59 PM.

        Comment


        • #5
          Originally posted by debianxfce View Post
          Use a rolling release distribution, mesa master git and a custom agd5f/linux/?h=drm-next-4.12-wip kernel. Use the amdgpu kernel driver and enable CIK and SI support, see:
          https://www.phoronix.com/forums/foru...in-living-room
          Tried to use the AMDGPU driver a couple of times and all I managed was a black screen, I prefer to wait until it is done.

          Comment


          • #6
            Originally posted by JPFSanders View Post

            Tried to use the AMDGPU driver a couple of times and all I managed was a black screen, I prefer to wait until it is done.
            Did you use a rolling release distribution, mesa master git and a custom agd5f/linux/?h=drm-next-4.12-wip kernel? Otherwise you get a black screen when your software is not in sync.

            Comment


            • #7
              Originally posted by JPFSanders View Post

              Nope... that was the very first thing I tried. :-( My impression is that the dpm code is f***ed for the 290

              I have read somewhere that due to a bug in the dpm if you plug a second monitor it makes the memory clock run at the highest frequency, I'm going to try find another monitor to test if something happens, I can observe that behavior on my 7970 already so...
              If you are using an initrd, make sure you update that with the latest ucode as well. Some distros have older uvd firmware which caused the problem.

              https://bugs.freedesktop.org/show_bug.cgi?id=97260

              Comment


              • #8
                I think the lock to 150MHZ was done to prevent some R9 390 cards from crashing when the mclk changes.

                Comment


                • #9
                  Nothing seems to improve the performance, I have updated the kernel to 4.10.5 I have installed the latest firmware, also upgraded the bios of the card... nothing has improved on the Linux side, however the performance in Windows has improved at least 10fps with the bios upgrade :-/

                  I'm tired of the 290 not cooperating I use Linux now 99.99999% of the time, I detest having to run Windows to have some performance.

                  I have thrown the towel and this morning ordered a Rx 480... lets hope I can get more than 27fps, otherwise AMD is over for me on the gaming department.

                  Comment


                  • #10
                    Originally posted by debianxfce View Post

                    Did you use a rolling release distribution, mesa master git and a custom agd5f/linux/?h=drm-next-4.12-wip kernel? Otherwise you get a black screen when your software is not in sync.
                    I do not fancy trashing the living room computer at this moment, so I ordered a 480, I'm sick of the disappointment of the 290.

                    Comment

                    Working...
                    X