Announcement

Collapse
No announcement yet.

Ubuntu 16.04 with AMD R9 285 (Tonga): no video

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 16.04 with AMD R9 285 (Tonga): no video

    I read that this GPU should be supported by the open source amdgpu driver in the Linux 4.4 kernel on Ubuntu 16.04, but both the Live USB and a migrated 15.10 -> 16.04 installation suffer the same problem: the video goes off as soon as grub loads.

    The workaround is to use 'nomodeset' as a boot parameter, but this disables the amdgpu driver and mesa falls back to software rending using LLVMpipe:
    Code:
    sudo glxinfo | grep OpenGL
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.0
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 11.2.0
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.2.0
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:
    So, what's the deal? Has anyone got this working in Ubuntu 16.04? Should I try a newer kernel using some PPA? Please avise!

  • #2
    Here's the dmesg in case it can provide any useful information: pastebin.com/t78VmAS6

    I've also scanned the files under /etc/modprobe.d for blacklisted entries such as radeon or amdgpu but found nothing suspicious.

    Comment


    • #3
      nomodeset is not interesting... there was issues earlier with that Tonga:

      But with the Radeon R9 285 Tonga graphics card that's natively supported by AMDGPU, that didn't even end up working on Ubuntu 16.04... Once booting Ubuntu 16.04 with its default kernel, I didn't end up getting a display and when remotely connecting to the system it was quickly noticed that their AMDGPU driver went berserk:
      http://www.phoronix.com/scan.php?pag...1604-amd&num=1

      But few days later it worked

      http://www.phoronix.com/scan.php?pag...04-tonga&num=1

      No idea what happened there, just to note might be you hit something like that

      Comment


      • #4
        Is there a way to drop to a tty or get some sort of basic video mode fallback when the grub loaded kernel fails to initialize the gpu with kms? I'd like to see the actual error messages...

        Comment


        • #5
          Try to remove "quiet splash" from the kernel cmdline.

          Comment


          • #6
            puleglot, unfortunately I'm already not using "quiet" nor "splash". I think some messages may get printed very briefly before the screen turns off... I will try to capture those with a camera. Is there a way to reproduce this once the system is booted?

            Here are other things I will try in order to reproduce the problem in a more debugging friendly environment (with SSH access!):
            1) Boot with 'nomodeset', then in a terminal, issue 'sudo modprobe amdgpu'
            2) If the previous doesn't work to reproduce the issue, I can also try to: make sure 'amdgpu' is a module, make sure its not in the initramfs, and then I should'nt need nomodeset, and I should be able to just modprobe it (thanks to [R] from the #ubuntu freenode channel for contributing this idea).

            I'll give an update as soon as I have the opportunity to experiment with the problematic machine (it's not mine). Hopefully until then an Ubuntu update will auto-magically resolve this issue...

            Comment


            • #7
              Originally posted by debianxfce View Post
              Use kernel 4.7 and mesa from padoka ppa, because 4.4 is very old kernel.
              4.4 in ubuntu comes with amdgpu/radeon drivers backported from 4.5 and should work just fine with Tonga. But you are right, trying newer kernel doesn't hurt.

              Originally posted by debianxfce View Post
              Your dmesg shows that you are using vesa driver.
              Because it is captured with "nomodeset" in the kernel cmdline. =P

              Originally posted by debianxfce View Post
              For amdgpu driver, you need to have firmware package and /etc/X11/xorc.conf.
              No need for a xorg.conf.

              Comment


              • #8
                Have a look in the Ubuntu "Kernel Mainline PPA". You'll get readily packaged Kernelversions there. Also think to use linux-firmware package from yakkety.

                Comment


                • #9
                  These are no debug Kernels

                  Comment


                  • #10
                    After checking, just to be sure:

                    CONFIG_DEBUG_KERNEL is enabled for every Ubuntu Release Kernel. I checked some Versions to whom I had quick access, and that option is enabled for every single one I checked. The Kernels are working well. There is nothing wrong with those.

                    Comment

                    Working...
                    X