No announcement yet.

AMD Catalyst 8.3 Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by djdoo View Post
    I cannot download the file guys... It sais it doesn't exist...
    Check the posts above.

    I'm still getting segmentation faults in fgl_glxgears and corruption (whole screen flickers and framerate is ~30x too slow!) in glxgears with my 2900.
    Last edited by phyrko; 05 March 2008, 07:23 PM.


    • #12
      Originally posted by djdoo View Post
      I cannot download the file guys... It sais it doesn't exist...
      look the posts above

      I HAVE A PROBLEM: I am running gutsy amd64. When I try to install "xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb" it gives an error. It says that this package tries to delete /usr/lib32/ from ia32-libs (or something like that).

      PLZ FIX IT. I really want to try this release. I wanna see the Xv fixes.


      • #13
        Well, seems like the name for the driver can be "Duke Nukem For Never" - I hope it doen't remain that way forever.


        • #14
          I gotta say, I'm really happy with this release. First of all, XVideo is finally there where it should have been a long time ago: no tearing, no blocky scaling, just plain working.

          AIGLX/compiz before 8.2 was way to slow on my x1400 with a 1400x1050 display, and nonworking with my 1680x1050 display attached (via BigDesktop). 8.2 got rid of the slow Firefox scrolling, but slowed down to a crawl with the external display attached. With 8.3, compiz is perfectly usable even with the external display.

          With the earlier releases, I never got BigDesktop really working, it always used the same resolution on both displays, either 1400x1050 or 1680x1050 (with the first, the bigger display was distorted, with the second, there was a nonvisible area right of the smaller display). With the new driver, I was able to setup the BigDesktop just right with a few clicks in the ATI Control Panel.

          I was this close to giving up and buy a laptop with an nVidia card a few days ago, but with this driver, my old laptop got a breath of fresh air. Thanks, ATI and AMD.

          I can't wait to see what the fglrx driver and the OSS drivers will bring to us in the next months


          • #15
            Do the "image brightness and gamma correction issues" mean that changing the brightness in ID software engine games works now?


            • #16
              Yes you re right guys! My mislook! Downloading now...

              I cannot wait to see Textured Video finally working on my RS690!!


              • #17
                Suspend/hibernate still not working with Compiz enabled...



                • #18
                  Originally posted by SledgeHammer_999 View Post
                  look the posts above

                  I HAVE A PROBLEM: I am running gutsy amd64. When I try to install "xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb" it gives an error. It says that this package tries to delete /usr/lib32/ from ia32-libs (or something like that).

                  PLZ FIX IT. I really want to try this release. I wanna see the Xv fixes.
                  ls -l /usr/lib32/*
                  and check that you get something like
                  /usr/lib32/ ->
                  /usr/lib32/ -> /usr/lib/
                  I had to redo the link from to with
                  $ cd /usr/lib32
                  $ sudo ln -s /usr/lib32/


                  • #19
                    This time ati managed to fix at least 1 bug of the things I always test with a new driver:

                    + gl2benchmark does not segfault with sid/amd64 anymore

                    but all other errors are still the same

                    - last pointsprite was seen with driver 8.40.4, that was now 6 driver releases ago (to verify just use gl2benchmark test 3/4)

                    - black screen with modelines (it was only a joke in the release notes that these would work some time ago, a bad one however)

                    - kills vesa framebuffer with some kernels and my x700se (release notes are incorrect)

                    I can not test any issues with X1300+ cards as I do not own em and nobody wanted to send me a test card. But this releases really states how much better are NV cards...


                    • #20
                      Uchi's 8.03 driver rundown
                      Quick summary: It works for pretty much everything. Including hibernate and suspend.

                      Broken down into

                      - Machine configuration
                      - Installation
                      - Fglrxinfo/glxinfo/xvinfo
                      - glxgears/powerplay
                      - Compiz
                      - Compiz & Video (Xv)
                      - Video (Xv)
                      - Suspend/Hibernate
                      - Remarks

                      Machine details

                      Machine: Dell Inspiron 6400
                      Card: ATI Mobility x1400 256MB Hypermemory (PCI-Ex)
                      RAM: 1 GB
                      Distro: OpenSUSE
                      State: Clean-install, no previous ATI driver
                      Xorg: 7.3


                      So, we start off this test by attempting to install via the installer. The installer is now text-based! This makes it possible to run it in console. Starting off:

                      sudo chmod a+x
                      sudo ./
                      The first command to make it runnable, the second to run it. The installer successfully detected the distro, Xorg version range, and that I was in a 32bit x86 environment. Mm. Nothing out of the ordinary so far. It then presents the choice of generating a distro-specific package or doing the 'easy way'. I chose the easy way. Watch it do its thing and success! (Ensure that you have the kernel source and all the tools needed else you'll get an error message and a log saying that it failed to generate the kernel module).

                      Next up, ran the following commands (since I just recently installed actually, great timing huh?):

                      sudo aticonfig --initial
                      sudo aticonfig --overlay-type=Xv
                      Restarted X and my resolution is now nice and proper. Let's verify that life is good.


                      tachikoma@n198-239:~> fglrxinfo
                      display: :0.0  screen: 0
                      OpenGL vendor string: ATI Technolgies Inc.
                      OpenGL renderer string: ATI Mobility Radeon X1400
                      OpenGL version string: 2.1.7412 Release
                      tachikoma@n198-239:~> glxinfo
                      name of display: :0.0
                      display: :0  screen: 0
                      direct rendering: yes
                      server glx vendor string: SGI
                      server glx version string: 1.2
                      [server extensions listed below]
                      client glx vendor string: SGI
                      client glx version string: 1.4
                      [client glx extensions listed below]
                      Xvinfo reports two image formats YV12 (0x32315659), type: YUV (planar) and I420 (0x30323449), type: YUV (planar). Powerstates gives me the usual three states:

                      Powerstates, glxgears average (non-compiz)

                      tachikoma@n198-239:~> aticonfig --list-powerstates
                           core/mem       [flags]
                        1: 209/135 MHz      [low voltage]
                        2: 392/252 MHz     
                      * 3: 432/396 MHz      [default state]
                      Glxgears gives me an average of about 2600ish FPS.

                      Next up. Compiz.

                      Installed compiz and added the necessary flags to xorg.conf and then gave it a whirl. Ran it manually in console using "compiz-manager&". Emerald window manager, and it works just fine.

                      Scrolling is decent, glxgears gives me an average of about 2423-2600 FPS. So, not bad at all. Dragged the glxgears window around and it was fine. All the effects work decently well (rotate workspace, fading windows, wobbly drag, alt+tab). Resizing a window tends to be slow and jerky. Mm...further tries and I get a blank window issue. Not usable, but I still need to test video in moving on...

                      Video in compiz!

                      In Xv mode no less. Lets see what hapepns. The video is a music video (Nana Mizuki - Astrogation, Xvid(MPEG-4 ASP), MP3 (audio)) and played in the default video player in OpenSUSE.

                      Default size: Works
                      Resize: Works
                      Fullscreen: Works
                      CPU Utilization (resized fullscreen, 1280x800): 5-25% CPU utilization for each CPU (CPU 1 and 2)

                      Video not in compiz!

                      Same video.

                      Default size: Works
                      Resize: Works
                      Fullscreen: Works
                      CPU Utilization (non fullscreen): 20-25%, 5-10% alternating between CPU's

                      [as reported by system monitor]
                      [idle is about 5%]

                      Hibernation and suspend!

                      Settings are OpenSUSE 10.3 defaults.

                      Suspend was tested by pressing Fn+Esc (Stand by). Suspend finished correctly. Woke up correctly. I'm a happy panda. Hell yes. I'm going to do it again just for the hell of it. Suspend finished correctly. Woke up correctly. RAWR. I'm going to do it again with compiz on. uspend finished correctly. Woke up correctly. RAWRx2. I gave my console window a little wobble to check too.

                      Hibernate was tested by pressing Fn+F1 (Hibernate). It got tested with compiz on since compiz was already loaded (see above). OpenSUSE has the nice splash while it prepares the hibernate. It's quite nice really. Anyways, hibernate is successful, and computer is turned off. But...does it turn back on? Interestingly, if you hibernate in OpenSUSE it skips Grub when you turn it back on. In any case, was able to resume successfully with Compiz on.

                      I'm not going to try without compiz on right now, but if someone wants me to try it, let me know.

                      Closing remarks:

                      So compiz works, but doesn't work. Mm. Maybe it's just how I set it up. I did set it up rather hastily. Or perhaps its the driver. In any case, barring compiz, it all works mighty fine and I really don't have any real complaints. Compiz? I don't usually use it...but people here like to use it so...tried it out.
                      Last edited by Uchikoma; 05 March 2008, 08:04 PM.