No announcement yet.

Solution: 8.42.3 openSUSE 10.3 fgl_glxgears

  • Filter
  • Time
  • Show
Clear All
new posts

  • Solution: 8.42.3 openSUSE 10.3 fgl_glxgears

    Sorry for my bad English...

    Since I have installed ATI driver 8.42.3 I couldn't start fgl_glxgears.
    "X Error of failed request: GLXUnsupportedPrivateRequest".

    Today I found the following bug report:

    With these infos I could create a solution for me.

    Solution 1:
    export LD_LIBRARY_PATH=/usr/X11R6/lib:$LD_LIBRARY_PATH

    Solution 2:

    Open /usr/X11R6/lib/ with a hex editor and change the string "" to "". Restart X if necessary. fgl_glxgears should work now.

    Last edited by Spooky; 03 November 2007, 11:02 AM.

  • #2
    Hi, thanks for sharing your solution.

    You have a typo in Solution 1.

    export $LD_LIBRARY_PATH=/usr/X11R6/lib:$LD_LIBRARY_PATH
    should be
    export LD_LIBRARY_PATH=/usr/X11R6/lib:$LD_LIBRARY_PATH
    without the leading $


    • #3

      Yes, you are right.
      It's fixed now.



      • #4
        Doesn't seem to be working for me.

        mfb@linux-morpheus:~> LD_LIBRARY_PATH=/usr/X11R6/lib64:$LD_LIBRARY_PATH fgl_glxgears
        Using GLX_SGIX_pbuffer
        Segmentation fault
        mfb@linux-morpheus:~> LD_LIBRARY_PATH=/usr/X11R6/lib64:$LD_LIBRARY_PATH fgl_glxgears -fbo -info
        Using GL_EXT_framebuffer_object
        GL_RENDERER   = Mesa GLX Indirect
        GL_VERSION    = 1.4 (2.1 Mesa 7.0.1)
        GL_VENDOR     = Mesa project:
        GL_EXTENSIONS = GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATIX_texture_env_combine3 GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_NV_blend_square GL_NV_fragment_program GL_NV_light_max_exponent GL_NV_point_sprite GL_NV_texgen_reflection GL_NV_texture_rectangle GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SGIX_shadow_ambient GL_SUN_multi_draw_arrays
        132 frames in 5.0 seconds = 26.400 FPS
        120 frames in 5.0 seconds = 24.000 FPS
        So, it's using mesa. I tried the second solution using KHexEdit, but that resulted in a corrupted SO.


        • #5
          or me but thanks for sharing it anyway.


          • #6
            Open /usr/X11R6/lib/ with a hex editor and change the string "" to "". Restart X if necessary. fgl_glxgears should work now.

            this seems the soname error bug. try to see if you have the /usr/lib/ file. if not symlink this to the /usr/lib/opengl/ati/lib/
            this should fix it without the hex editing or the ldpath.

            for what i know fgl_fglxgears is a little bugged. so try using the normal glxgears which is the one included in xorg.
            in my case i go from 180fps with fgl to 800 fps with glxgears with ultrastable settings and to 1900fps with ultrabreaking settings.
            i preffer the ultra stable since with beryl i get the same 700-800 fps when using them and get only 450-500 fps when using the ultrabreaking ones.


            • #7
              Hi, in my case the files are already linked. I am using the 64 bit version of the OS (openSUSE) so in my case I am talking about /usr/X11R6/lib64


              • #8
                Hi, in my case the files are already linked. I am using the 64 bit version of the OS (openSUSE) so in my case I am talking about /usr/X11R6/lib64
                /usr/lib links to lib64. if you do a ls -l /usr | grep lib you'll see this.

                anyway, i should have expected that since that's the only ati supported distro.
                anyway i've never experienced problems of that kind with it. i'll have to retry that and see if i get the same error on my opensuse box.


                • #9
                  It seems that the 32bit and 64bit version of openSUSE 10.3 are different. I doesn't have the directory /usr/lib/opengl.

                  At the original file you can look with:

                  objdump -p /usr/X11R6/lib/ | grep SONAME
                  if the SONAME is wrong or right. In my case was "" before. Therefore the library in /usr/lib was prefered, because fgl_glxgears search for "". You can compare this with:

                  ldd /usr/bin/fgl_glxgears
                  ldd /usr/bin/fgl_glxgears 
                 =>  (0xffffe000)
                  [color=red] => /usr/X11R6/lib/ (0xb7e74000)[/color]
                 => /usr/lib/ (0xb7d59000)
                 => /usr/lib/ (0xb7d4a000)
                 => /lib/ (0xb7d25000)
                 => /lib/ (0xb7bf2000)
                 => /lib/ (0xb7bdb000)
                 => /usr/lib/ (0xb7bd7000)
                 => /usr/lib/ (0xb7bbe000)
                 => /lib/ (0xb7bba000)
                 => /usr/lib/ (0xb7bb6000)
                          /lib/ (0xb7f1a000)


                  • #10
                    Don't remove some bytes. For correct hex edit (I use GHex) you should change:

                    6C 69 62 47 4C 2E 73 6F 2E 31 2E 32

                    " "
                    6C 69 62 47 4C 2E 73 6F 2E 31 [color=red]00 00[/color]
                    I don't know in which case it's necessary to patch "" and "" also.