No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • hey all, first time posting so im not sure on how the forum runs but i figured id have a comment on the divers and my experience.

    over all the fglrx drivers with xserver-xgl worked more smoothly for compiz.. but id always have to disable compiz to play opengl games.. with these new drivers i dont have to disable compiz (ive tested doom3, quake4, and ut2004)... i havent had the games crash yet.. ill need to do some more "testing"..

    the flickering ive found (maybe someone has a better idea/reason), is due to dropping the native resolution down to something lower than default desktop res.. eg, my laptops default (native) screen res is 1440x900.. in doom i have my screen set at 1024x768 and it flickers, in quake4 i set my screen res to custom and used the console to set the screen res to 1440x900 and no problem.. it looks good and runs faster than fglrx.. i guess its obvious that i havent done extensive testing.. havent had time... yet

    for firefox scrolling ive found that turning off smooth scrolling helps.. also, compiz runs smoothly when no apps are accessing the cpu (or ram) alot.. if i have ktorrent running or/and firefox, compiz seems jerky, if i dont have either/both of them running.. its smooth..

    havent noticed a problem with wine.. although i only use wine for diablo II and Starcraft (havent tested starcraft yet)

    and as for video playback.. i just followed what everyone else on the forum has been doing.

    heres a link to the guide i used for installing the drivers

    and following is my xorg.conf file... you guys might know a few things that can be added to help performance.. but from hacking around with it.. ive found this config works nice

    (btw.. when i said first time posting above, i meant first time posting generally.. i havent really ever posted in forums before, so im unsure of forum code for quoting and stuff.. sry guys) hope this stuff helps some people

    # xorg.conf (xorg X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"

    # Uncomment if you have a wacom tablet
    # InputDevice "stylus" "SendCoreEvents"
    # InputDevice "cursor" "SendCoreEvents"
    # InputDevice "eraser" "SendCoreEvents"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "Synaptics Touchpad"

    Section "Files"

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dbe"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizEdgeScroll" "0"

    Section "InputDevice"
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

    Section "InputDevice"
    Identifier "eraser"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

    Section "InputDevice"
    Identifier "cursor"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY

    Section "Monitor"
    Identifier "Generic Monitor"
    HorizSync 28.0 - 51.0
    VertRefresh 43.0 - 60.0
    Option "DPMS"

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"

    Section "Device"
    Identifier "Generic Video Card"
    Driver "vesa"
    BusID "PCI:6:0:0"

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "AccelMethod" "EXA"
    Option "EXANoOffscreenPixmaps"

    Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Modes "1024x768" "800x600" "640x480"

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24

    Section "Extensions"
    Option "Composite" "1"

    Section "ServerFlags"
    Option "AIGLX" "on"

    Section "DRI"
    Mode 0666


    • Xorg crashes after Xv or XxMc playback

      [FireGL V5250, hacked to PCI ID 0x71d5]

      I have just tried watching a movie trailer file using Fedora 7, xine and fglrx 8.42.3, and the Xorg server crashed as soon as playback was complete. The Xorg.0.log file said the following, and seems to be more or less the same for both Xv and XvMc:

      0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80c2d21]
      1: [0xb7fc7420]
      2: /lib/ [0x46008bcc]
      3: /usr/lib/xorg/modules// [0xb5e89bd2]
      4: /usr/lib/xorg/modules// [0xb5e8f1d8]
      5: /usr/lib/xorg/modules// [0xb5e6a8f2]
      6: /usr/lib/xorg/modules// [0xb5e51fc3]
      7: /usr/lib/xorg/modules// [0xb5e0c9cd]
      8: /usr/lib/xorg/modules// [0xb5df5a95]
      9: /usr/lib/xorg/modules// [0xb5df4166]
      10: /usr/lib/xorg/modules// [0xb5df2620]
      11: /usr/lib/xorg/modules// [0xb5df102f]
      12: /usr/bin/Xorg [0x80d16cf]
      13: /usr/lib/xorg/modules/extensions// [0xb7f38cb4]
      14: /usr/lib/xorg/modules/extensions// [0xb7f3bc87]
      15: /usr/bin/Xorg [0x815235e]
      16: /usr/bin/Xorg(Dispatch+0x1aa) [0x80899fa]
      17: /usr/bin/Xorg(main+0x495) [0x8071735]
      18: /lib/ [0x45faef70]
      19: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e9) [0x8070a21]
      Fatal server error:
      Caught signal 11.  Server aborting
      (II) AIGLX: Suspending AIGLX clients for VT switch


      • 8.42 - first impressions

        For the record, I'm using a T60 with an X1400 card, running (K)ubuntu.

        I used 8.37.6 from when it was released until a day ago because 8.37 proved stable and there were no significant changes in the releases prior to 8.42.

        Installation following the instructions at method 2 was reasonably smooth, the one thing that is missing from those instructions is that an additional link is needed as follows:

        ln -s /lib/modules/2.6.22-14-generic/misc/fglrx.ko /lib/modules/2.6.22-14-generic/kernel/drivers/video/fglrx.ko

        followed by depmod -a, otherwise the kernel module doesn't get loaded automatically after a reboot.

        Overall, all that worked in 8.37.6 still works in 8.42.3, just quicker.

        AIGLX and Composite work, but as others have reported there is severe flickering in video (both xv and opengl) when compiz is running, and compiz slows down Firefox scrolling.

        OTOH, the KDE3 native compositing effects now work for the first time, and very smoothly! The video flickering and firefox slowdown does not occur with KDE compositing.

        When playing video, both xv and opengl output work, though opengl output is noticeably crisper. The only thing I notice is a slight tearing during pans.

        Overall, I see a definite improvement since 8.37.6

        Main open issues from my point of view (any AMD developers listening?):
        • suspend is broken on kernels using the slub allocator. This is really bad, if I could ask for just one thing for 8.43 that would be it.

        • power management: I currently have aticonfig --set-powerstate=1 in the startup script, which works fine. I then set it to 3 manually when using something heavily reliant on 3D. It would be really nice if this could be somehow done automatically (the way the CPU changes frequency dynamically, depending on load). I know there is atieventsd but it seems to be very limited and I didn't find much documentation on it either.




        • Is there a way to notify the developers of a big probelm? I get a PC freeze when I do a logout, and sometimes when I reboot the pc. ater X closes


          • Originally posted by yelo3 View Post
            Is there a way to notify the developers of a big probelm? I get a PC freeze when I do a logout, and sometimes when I reboot the pc. ater X closes
            Post to the BugZilla at
            Michael Larabel


            • Originally posted by Michael View Post
              Post to the BugZilla at
              the bug is already posted.

              Are you sure that the ati developers are looking to that bugzilla? it is there since a long time, and they think the bug is fixed, since in an old release note (8.37) they were listing a similar bug in the "resolved issues" section (see below)


              • Originally posted by cornelius View Post
                That's interesting. The new driver hasn't fixed this problem for me. I'm guessing you're not using Ubuntu, right?

                Oh well, the next driver is supposed to fix this by introducing 2.6.23 kernel support (which comes with SLUB by default).
                Actually, am using 7.10 of Ubuntu. Have never gotten the fglrx drivers to work after resume still though, so it's not exactly usable...


                • so ati still hasnt posted the drivers on their site.... so what is this, just an elaborate beta testing setup or what?


                  • Originally posted by gummybearx View Post
                    so ati still hasnt posted the drivers on their site.... so what is this, just an elaborate beta testing setup or what?

                    yea, the drivers are not up on the page, yet how to install them is on cchtml, about all i could come up with is they want some "beta testing" done then at the endo of the month they will release the real 8.42 drivers, with some of the bugs fixed.

                    we can only hope...


                    • Hi, if this has been answerd before, i'll gladly (try) to read back.

                      I'm running this driver on an X1950Pro AGP and I get 'sluggish' performance. E.G. ET (not QW!) i get 110FPS at one point, but 20FPS by just looking around (empty server) and it feels more like ... 5 fps.

                      Wine (WoW) same thing, sluggish slow/fast mixed performance. Now the wine thing I may get, but the game run better 6 months ago on my 9500Pro on an Athlon XP (2.5Ghz barton, ~3400+) compared to my dualcore 2.4ghz Athlon XP (~4900+ *2) CPU load is very low (mostly if I use the ondemand gov. cpu speed stays at 1Ghz, though the performance gov. doesn't change anything).

                      Any thoughts/pointers?
                      Thanks, oliver