Announcement

Collapse
No announcement yet.

Marek Lands Radeon Gallium3D MSAA Changes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • droste
    replied
    so we basically have the same setup... reboot? ;-)

    Leave a comment:


  • ChrisXY
    replied
    Originally posted by curaga View Post
    Do you build with the patented float feature? It's required for GL 3.0 IIRC.
    Code:
       --with-dri-driverdir=/usr/lib/xorg/modules/dri \
       --with-gallium-drivers=r600 \
       --with-dri-drivers= \
       --with-egl-platforms=x11,drm,wayland \
       --enable-texture-float \
       --enable-gles1 \
       --enable-gles2 \
       --enable-egl \
       --enable-xorg \
       --enable-xa \
       --enable-vdpau \
       --enable-gallium-g3dvl \
       --enable-glx-tls \
       --enable-glu \
       --enable-gbm \
       --enable-gallium-gbm \
       --enable-shared-glapi \
       --enable-xorg \
       --enable-gallium-llvm \
       --enable-openvg \
       --enable-gallium-egl \
       --enable-osmesa \
       --enable-r600-llvm-compiler

    Leave a comment:


  • curaga
    replied
    Originally posted by ChrisXY View Post
    Well...
    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD REDWOOD
    OpenGL version string: 2.1 Mesa 8.1-devel (git-cf76edd)
    OpenGL shading language version string: 1.30
    Same commit.
    Do you build with the patented float feature? It's required for GL 3.0 IIRC.

    Leave a comment:


  • ChrisXY
    replied
    Originally posted by droste View Post
    It needs a recent libdrm (>=2.4.38) and 3.5 or 3.6 kernel IIRC (I have 3.6)
    Code:
     ~ % pkg-config libdrm --modversion
    2.4.38
    Actually I built it yesterday.
    Code:
     ~ % uname -r
    3.6.0-rc1-mainline
    But the kernel is probably build with a config similar to 3.5. Does it need some special configuration?

    Leave a comment:


  • droste
    replied
    It needs a recent libdrm (>=2.4.38) and 3.5 or 3.6 kernel IIRC (I have 3.6)

    Leave a comment:


  • ChrisXY
    replied
    Originally posted by droste View Post
    it does

    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
    OpenGL version string: 3.0 Mesa 8.1-devel (git-cf76edd)
    OpenGL shading language version string: 1.30
    Well...
    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD REDWOOD
    OpenGL version string: 2.1 Mesa 8.1-devel (git-cf76edd)
    OpenGL shading language version string: 1.30
    Same commit.

    Leave a comment:


  • Azpegath
    replied
    Originally posted by droste View Post
    it does

    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
    OpenGL version string: 3.0 Mesa 8.1-devel (git-cf76edd)
    OpenGL shading language version string: 1.30
    NERDGASM! *Waving hands in the air and flailing about!*
    This is quite huge, we've been waiting for it for 3 years now.

    Regarding 6000/5000 generation, I'll probably buy one when it's actually faster (across the board) than the 4000 generation for the FOSS drivers. But now there's simply no point.
    Last edited by Azpegath; 08-15-2012, 05:34 PM.

    Leave a comment:


  • Veerappan
    replied
    Originally posted by droste View Post
    it does

    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
    OpenGL version string: 3.0 Mesa 8.1-devel (git-cf76edd)
    OpenGL shading language version string: 1.30
    Awesome. Now, on to 3.1

    Code:
    GLSL 1.40                                             needs UBOs (in progress)
    Forward compatibile context support/deprecations      not started
    Instanced drawing (GL_ARB_draw_instanced)             DONE (i965, gallium, swrast)
    Buffer copying (GL_ARB_copy_buffer)                   DONE (i965, r300, r600, swrast)
    Primitive restart (GL_NV_primitive_restart)           DONE (i965, r600)
    16 vertex texture image units                         DONE
    Texture buffer objs (GL_ARB_texture_buffer_object)    needs GL3.1 enabling (i965)
    Rectangular textures (GL_ARB_texture_rectangle)       DONE (i965, r300, r600, swrast)
    Uniform buffer objs (GL_ARB_uniform_buffer_object)    DONE (i965)
    Signed normalized textures (GL_EXT_texture_snorm)     DONE (i965, r300, r600)
    Looks like we need the forward compatible context support/deprecations (I've seen what I believe are commits related to this in mesa-dev), UBOs (almost done?), and Texture Buffer Objects (which I'm assuming is only done for i965).

    Leave a comment:


  • droste
    replied
    it does

    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
    OpenGL version string: 3.0 Mesa 8.1-devel (git-cf76edd)
    OpenGL shading language version string: 1.30

    Leave a comment:


  • Veerappan
    replied
    Originally posted by phoronix View Post
    Phoronix: Marek Lands Radeon Gallium3D MSAA Changes

    Marek Ol??k, the prolific independent contributor to Mesa/Gallium3D and the open-source Radeon Linux graphics driver, has landed a number of commits today in Mesa pertaining to MSAA, a.k.a. multi-sample anti-aliasing for newer Radeon GPUs...

    http://www.phoronix.com/vr.php?view=MTE2MDc
    Coolness... can anyone confirm whether this does, or does not, cause r600g on Evergreen to advertise OpenGL 3.0?

    Leave a comment:

Working...
X