Announcement

Collapse
No announcement yet.

Can't enable Gallium3D on R700 (4650)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • dekomote
    started a topic Can't enable Gallium3D on R700 (4650)

    Can't enable Gallium3D on R700 (4650)

    Hi,

    I can't enable Gallium3D on my system. System Specs:

    Distro: Ubuntu 10.10 (Linux Mint 10)

    Kernel: 2.6.37-020637-generic

    xorg-edgers PPA added, Mesa 7.11-git, xf86-video-ati 6.13.99

    When I add Option "ForceGallium" "True" in xorg.conf, Xorg log says Option "ForceGallium" not used.

    Another question: How can I install 2.6.38? Latest kernel build in kernel ppa is 2.6.37-999

    Any help will be appreciated.

  • HokTar
    replied
    It worked for me too, thanks!

    Leave a comment:


  • zika
    replied
    Originally posted by joolsa View Post
    I set up Gallium using the /ppa. I couldn't find any examples of an xorg.conf for this, and I found that getting the syntax wrong causes X to refuse to start. This /etc/xorg.conf works for me:

    Section "Device"
    Identifier "Default screen"
    Option "ForceGallium" "True"
    EndSection
    Cool! It works! Thank You!
    (Natty, 2.6.38-rc1, ATI HD3650)

    Leave a comment:


  • dekomote
    replied
    Originally posted by joolsa View Post
    I set up Gallium using the /ppa. I couldn't find any examples of an xorg.conf for this, and I found that getting the syntax wrong causes X to refuse to start. This /etc/xorg.conf works for me:

    Section "Device"
    Identifier "Default screen"
    Option "ForceGallium" "True"
    EndSection
    I tried that, it didn't work for me. However the /radeon ppa worked.

    Leave a comment:


  • joolsa
    replied
    Originally posted by dekomote View Post
    Remove /ppa and leave just /radeon. Or better yet, remove both of them, then add /radeon and you should have gallium on by default. Tried that yesterday evening, it was working fine. Tried it with Penumbra Overture, huge performance gain.
    I set up Gallium using the /ppa. I couldn't find any examples of an xorg.conf for this, and I found that getting the syntax wrong causes X to refuse to start. This /etc/xorg.conf works for me:

    Section "Device"
    Identifier "Default screen"
    Option "ForceGallium" "True"
    EndSection

    Leave a comment:


  • zika
    replied
    When we can expect to see Gallium for Natty?

    Leave a comment:


  • zika
    replied
    Originally posted by zika View Post
    What about us that are on Natty?
    Sacrificed midory and epiphany, re-installed xserver-xorg-input-{all,synpatics} and, voila, 1.9.99.901...
    Thank You xorg-edgers...

    Leave a comment:


  • zika
    replied
    What about us that are on Natty?

    Leave a comment:


  • lucx
    replied

    Leave a comment:


  • JDShu
    replied
    Thank you! Works perfectly now

    Exciting times ahead for radeon oss drivers.

    Leave a comment:

Working...
X