No announcement yet.

"Hard" freeze when starting AMDCCC 9.3

  • Filter
  • Time
  • Show
Clear All
new posts

  • "Hard" freeze when starting AMDCCC 9.3

    After upgrading from Catalyst 9.2 to 9.3 I cannot start the Control Center anymore as it freezes my entire system - it requires a hard reboot. I'm running Ubuntu 8.10 on HP 5810p (Mobility HD2600).
    After restart I cannot access Gnome anymore until I boot in "safe mode" and invoke "sudo aticonfig --initial -f ".
    I have also tried to purge all fglrx* related packages, reinstall the Ubuntu's default repository version and upgrade again; but, the same result.

    Any suggestions?

  • #2
    Me too: andcccle hangs on launch. I tried killing the process
    then running strace on it, and at that point X froze up hard.
    This is on Xorg 7.2, x86. I have no problems with the amdcccle
    from the 9.1 release.


    • #3
      Something similar happens here too sometimes. When I start it, the system becomes sluggish for about 6 seconds. *Really* sluggish. KDE 4 even pops-up a warning that due to the sluggishness it is disabling Desktop Effects.


      • #4
        Attempting to launch CCC with the 9.3 driver pegs one of my cores at 100% usage and renders the whole system sluggish for about 5 seconds, but it launches eventually. 9.4 and above resolve this however.