Announcement

Collapse
No announcement yet.

KDE 4.11 Haswell Desktop Effects Performance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by josk View Post
    I'm not sure how good that suspend compositing in fullscreen option really is? Maybe someone of you have benchmarked that option against the blocked compositing. Please share the results if you have benchmarked that?

    So I have always just totally blocked the compositing when I run softwares like Steam and mplayer (that fixed all 1080p tearing problems). And I use binary nvidia drivers.

    So if you don't know how to totally block the compositing...

    Shortcut key combination to toggle compositing on/off

    Shift+alt+f12

    Or automatically for certain programs:

    System settings > Window Behavior > Window rules > New

    First tab:

    - Description = "Name the setting"

    - Window class (application) = "Binary name of the running program ex. steam"

    Last tab:

    - Check the BLOCK COMPOSITING, select FORCE and YES options.

    I thought I read that totally disabling composition caused tearing due to lack of Vsync? This idea of whether compositing causing issues or fixes them seems to go around in circles on this site. I have no idea what to think anymore.

    I use Unity for my desktop, would the ctrl-alt-F12 help me when running full screen? Does it cause or fix tearing? Does it et me more FPS? Can someone whom actually understands this, test it for me and report back?

    Comment


    • #12
      Originally posted by dh04000 View Post
      I thought I read that totally disabling composition caused tearing due to lack of Vsync? This idea of whether compositing causing issues or fixes them seems to go around in circles on this site. I have no idea what to think anymore.
      For me disabling the composition for mplayer fixed the tearing issues with GeForce210 when I played 1080p x264 video content. And yes I tried that suspend desktop effect for fullscreen option and it didn't worked.

      Comment


      • #13
        Shift+alt+f12 Worked for me AMD catalyst drivers. hd 5750

        After some time I changed the settings of kde.
        Turning about everything off, in the settings.

        KDE knows about these problems for a while, so they might have fixed it.

        I remember a question, why "we" would want to run programs full screen, on this forum by somebody who matters kde wise.
        (not recently though)

        Comment


        • #14
          Originally posted by smitty3268 View Post
          It's not clear that it hasn't been fixed.

          The first bug from a couple years ago looks like it was. There may be another problem present only in the i915g driver, which Intel doesn't support (they have a classic driver instead) but it's not clear whether that is still currently present or not.
          Yes both of the associated upstream bugs are marked as fixed:

          https://bugs.freedesktop.org/show_bug.cgi?id=32303

          https://bugs.freedesktop.org/show_bug.cgi?id=30509

          That bug mentioned by one user was specific to i915 as you say so was never looked at upstream:

          https://bugs.freedesktop.org/show_bug.cgi?id=58834

          Obviously disabling a feature on all Intel drivers because of a possible bug in one unsupported driver reported by one user is a bit extreme, a point that is made by some users in the KDE bug report.

          Comment


          • #15
            Originally posted by Michael View Post
            Shouldn't the user be informed when setting an option that is broken for their hardware rather than silently ignoring it?
            Well it's a homeopathic config option. The user thinks his system is faster by just clicking an option ;-)

            No, it's quite simple: change introduced after translation freeze.

            Comment


            • #16
              Originally posted by mgraesslin View Post
              what a wonderful benchmark you did there, Michael.

              void Options::setUnredirectFullscreen(bool unredirectFullscreen)
              {
              if (GLPlatform::instance()->driver() == Driver_Intel)
              unredirectFullscreen = false; // bug #252817

              whoops, the option is ignored for all Intel hardware.
              So, the benchmark is perfectly right, there are no gains, and, guess what... this is exactly what Michael said:

              there's no longer a big performance gain from being able to disable KDE's desktop effects when running fullscreen windows/games, at least for Intel's open-source driver with Core i7 Haswell hardware.

              Comment


              • #17
                There is a difference between getting fixed and getting released. And released in a stable release. And accepted in most distros in current versions. I still run the bleeding edge PPA in kubuntu so I get most of these fixes, but sometimes it gets buggy again and I need to go disabling stuff until it works again (somewhat)

                Comment


                • #18
                  Originally posted by mgraesslin View Post
                  Well it's a homeopathic config option. The user thinks his system is faster by just clicking an option ;-)

                  No, it's quite simple: change introduced after translation freeze.
                  I think the word you're looking for is placebo. Homeopathy is one of the schools of medicine and your usage of the term makes no sense in context because it's not delaying the system by an insignificantly tiny amount.

                  Comment


                  • #19
                    Originally posted by Luke_Wolf View Post
                    I think the word you're looking for is placebo. Homeopathy is one of the schools of medicine and your usage of the term makes no sense in context because it's not delaying the system by an insignificantly tiny amount.
                    No, no. I'm quite aware of what homeopathy is and what a placebo is. I chose that word on purpose :-) (It's also saying a lot about what I think about homeopathy and science in general - you could check my blog posts about what I think about benchmarks in general to get an idea on why I chose that word)

                    Comment


                    • #20
                      Originally posted by Luke_Wolf View Post
                      I think the word you're looking for is placebo. Homeopathy is one of the schools of medicine and your usage of the term makes no sense in context because it's not delaying the system by an insignificantly tiny amount.
                      Homeopathy is a subset of placebo medicine.
                      It has been documented and peer-reviewed countless of times.

                      Comment

                      Working...
                      X